Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-15 10:53 UTC by Vyacheslav
Modified: 2010-12-15 13:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vyacheslav 2010-12-15 10:53:20 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.9-64.fc14.x86_64 x86_64
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
111111111111111111111111111111111111111111111111111111111222222222222

The crash can be reproduced some of the time.

-- Backtrace:
Application: Рабочее пространство Plasma (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#6  KJob::isAutoDelete (this=0x1168510) at /usr/src/debug/kdelibs-4.5.4/kdecore/jobs/kjob.cpp:353
#7  0x00007f25d3507588 in KJob::emitResult (this=0x1168510) at /usr/src/debug/kdelibs-4.5.4/kdecore/jobs/kjob.cpp:314
#8  0x00007f25ba87dd43 in ?? () from /usr/lib64/kde4/plasma_engine_statusnotifieritem.so
#9  0x00007f25ba87ddb0 in ?? () from /usr/lib64/kde4/plasma_engine_statusnotifieritem.so
#10 0x00007f25d2e4504f in QMetaObject::activate (sender=0x1c5b8b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff29e57640) at kernel/qobject.cpp:3272
#11 0x00007f25ba87952f in ?? () from /usr/lib64/kde4/plasma_engine_statusnotifieritem.so
#12 0x00007f25ba87cbcc in ?? () from /usr/lib64/kde4/plasma_engine_statusnotifieritem.so
#13 0x00007f25d2e4504f in QMetaObject::activate (sender=0x1af23d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#14 0x000000386be1471c in DBusMenuImporter::slotMenuAboutToShow (this=0x1af23d0) at /usr/src/debug/libdbusmenu-qt-0.6.3/src/dbusmenuimporter.cpp:564
#15 0x000000386be1ad2c in DBusMenuImporter::qt_metacall (this=0x1af23d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff29e579f0) at /usr/src/debug/libdbusmenu-qt-0.6.3/x86_64-redhat-linux-gnu/src/dbusmenuimporter.moc:105
#16 0x00007f25d2e4504f in QMetaObject::activate (sender=0x1ba8da0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#17 0x00007f25d26388d8 in QMenu::qt_metacall (this=0x1ba8da0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff29e57b10) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f25d2e393af in QMetaMethod::invoke (this=0x7fff29e57d60, object=0x1ba8da0, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1578
#19 0x00007f25d2e3a040 in QMetaObject::invokeMethod (obj=0x1ba8da0, member=<value optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#20 0x000000386be13f11 in invokeMethod (this=<value optimized out>) at /usr/include/QtCore/qobjectdefs.h:424
#21 DBusMenuImporter::updateMenu (this=<value optimized out>) at /usr/src/debug/libdbusmenu-qt-0.6.3/src/dbusmenuimporter.cpp:497
#22 0x00007f25ba87911b in ?? () from /usr/lib64/kde4/plasma_engine_statusnotifieritem.so
#23 0x00007f25ba87e667 in ?? () from /usr/lib64/kde4/plasma_engine_statusnotifieritem.so
#24 0x00007f25d4f864d5 in slotStart (this=0x1168510, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at /usr/src/debug/kdelibs-4.5.4/plasma/servicejob.cpp:37
#25 Plasma::ServiceJob::qt_metacall (this=0x1168510, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at /usr/src/debug/kdelibs-4.5.4/x86_64-redhat-linux-gnu/plasma/servicejob.moc:72
#26 0x00007f25ba87dd90 in ?? () from /usr/lib64/kde4/plasma_engine_statusnotifieritem.so
#27 0x00007f25d2e44b4a in QObject::event (this=0x1168510, e=<value optimized out>) at kernel/qobject.cpp:1211
#28 0x00007f25d21fc8c4 in QApplicationPrivate::notify_helper (this=0x9a5b50, receiver=0x1168510, e=0x1c6f040) at kernel/qapplication.cpp:4445
#29 0x00007f25d22013da in QApplication::notify (this=<value optimized out>, receiver=0x1168510, e=0x1c6f040) at kernel/qapplication.cpp:4324
#30 0x00007f25d3ab5566 in KApplication::notify (this=0x992340, receiver=0x1168510, event=0x1c6f040) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#31 0x00007f25d2e307ac in QCoreApplication::notifyInternal (this=0x992340, receiver=0x1168510, event=0x1c6f040) at kernel/qcoreapplication.cpp:732
#32 0x00007f25d2e33f95 in sendEvent (receiver=0x0, event_type=0, data=0x978fb0) at kernel/qcoreapplication.h:215
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x978fb0) at kernel/qcoreapplication.cpp:1373
#34 0x00007f25d2e5b723 in sendPostedEvents (s=0x9a9120) at kernel/qcoreapplication.h:220
#35 postEventSourceDispatch (s=0x9a9120) at kernel/qeventdispatcher_glib.cpp:277
#36 0x0000003861641e33 in g_main_dispatch (context=0x9a8120) at gmain.c:2149
#37 g_main_context_dispatch (context=0x9a8120) at gmain.c:2702
#38 0x0000003861642610 in g_main_context_iterate (context=0x9a8120, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#39 0x00000038616428ad in g_main_context_iteration (context=0x9a8120, may_block=1) at gmain.c:2843
#40 0x00007f25d2e5b8bf in QEventDispatcherGlib::processEvents (this=0x9787c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#41 0x00007f25d22a159e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#42 0x00007f25d2e2fb42 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x00007f25d2e2fd8c in QEventLoop::exec (this=0x7fff29e58f40, flags=...) at kernel/qeventloop.cpp:201
#44 0x00007f25d2e3424b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#45 0x00007f25d63cdf88 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#46 0x000000385e61ee7d in __libc_start_main (main=0x400920 <_start+256>, argc=1, ubp_av=0x7fff29e59338, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff29e59328) at libc-start.c:226
#47 0x0000000000400849 in _start ()

Possible duplicates by query: bug 259530, bug 258849, bug 258571, bug 258339, bug 257691.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-12-15 13:16:36 UTC

*** This bug has been marked as a duplicate of bug 241562 ***