Bug 258849 - Plasma crashes when KPackageKit tray icon menu is open & icon goes away
Summary: Plasma crashes when KPackageKit tray icon menu is open & icon goes away
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-04 22:04 UTC by sheeettin
Modified: 2010-12-05 23:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sheeettin 2010-12-04 22:04:33 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was notified that I had updates, so I applied them. While it was working, I (right-?)clicked the little package-arrow icon and left the menu up. When that step completed, the icon changed or went away (to be replaced by another), and Plasma crashed.

(I don't remember exactly what it was doing, but it was either updating package lists or downloading packages.)

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe0d157e780 (LWP 1929))]

Thread 2 (Thread 0x7fe0b0d8b710 (LWP 1934)):
#0  0x00007fe0d0e90203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe0c5b0e009 in g_main_context_poll (context=0x989610, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:3093
#2  g_main_context_iterate (context=0x989610, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2775
#3  0x00007fe0c5b0e45c in g_main_context_iteration (context=0x989610, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#4  0x00007fe0ce5451e6 in QEventDispatcherGlib::processEvents (this=0x988d90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007fe0ce517a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007fe0ce517dec in QEventLoop::exec (this=0x7fe0b0d8ad90, flags=) at kernel/qeventloop.cpp:201
#7  0x00007fe0ce4222fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fe0ce4f75f8 in QInotifyFileSystemWatcherEngine::run (this=0x9883f0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fe0ce42527e in QThreadPrivate::start (arg=0x9883f0) at thread/qthread_unix.cpp:266
#10 0x00007fe0ce19a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007fe0d0e9c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe0d157e780 (LWP 1929)):
[KCrash Handler]
#6  0x00007fe0cebe9304 in KJob::isAutoDelete (this=0xdb3740) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007fe0cebe99b8 in KJob::emitResult (this=0xdb3740) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007fe0b415ec73 in StatusNotifierItemJob::contextMenuReady (this=0xdb3740, menu=0xf97fc0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007fe0b415ece0 in StatusNotifierItemJob::qt_metacall (this=0xdb3740, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff58f58f70) at ./statusnotifieritemjob.moc:75
#10 0x00007fe0ce530b27 in QMetaObject::activate (sender=0xf9a450, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fe0ce84b120) at kernel/qobject.cpp:3280
#11 0x00007fe0b4158c7f in StatusNotifierItemSource::contextMenuReady (this=0xdb3740, _t1=0xf97fc0) at ./statusnotifieritemsource.moc:109
#12 0x00007fe0b415dbe4 in StatusNotifierItemSource::qt_metacall (this=0xf9a450, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff58f59060) at ./statusnotifieritemsource.moc:90
#13 0x00007fe0ce530b27 in QMetaObject::activate (sender=0x9da410, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fe0ce84b120) at kernel/qobject.cpp:3280
#14 0x00007fe0c6e3389c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007fe0c6e34a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007fe0ce530b27 in QMetaObject::activate (sender=0xf97fc0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fe0ce84b120) at kernel/qobject.cpp:3280
#17 0x00007fe0cdac8f40 in QMenu::qt_metacall (this=0xf97fc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff58f594e0) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007fe0ce521bf9 in QMetaMethod::invoke (this=0x7fff58f59790, object=0xf97fc0, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007fe0ce523306 in QMetaObject::invokeMethod (obj=0xf97fc0, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007fe0c6e2e7c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007fe0b415a1bb in StatusNotifierItemSource::contextMenu (this=0xf9a450, x=994, y=1012) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007fe0b41602d8 in StatusNotifierItemJob::start (this=0xdb3740) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007fe0d0a69b21 in Plasma::ServiceJob::qt_metacall (this=0xdb3740, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007fe0b415ecc0 in StatusNotifierItemJob::qt_metacall (this=0xdb3740, _c=QMetaObject::InvokeMetaMethod, _id=7245264, _a=0x7fe0ce84b120) at ./statusnotifieritemjob.moc:70
#25 0x00007fe0ce52abde in QObject::event (this=0xdb3740, e=0xdb3740) at kernel/qobject.cpp:1219
#26 0x00007fe0cd662fdc in QApplicationPrivate::notify_helper (this=0x65b590, receiver=0xdb3740, e=0xaffe20) at kernel/qapplication.cpp:4396
#27 0x00007fe0cd668aed in QApplication::notify (this=0x645650, receiver=0xdb3740, e=0xaffe20) at kernel/qapplication.cpp:4277
#28 0x00007fe0cf1b4156 in KApplication::notify (this=0x645650, receiver=0xdb3740, event=0xaffe20) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007fe0ce518cdc in QCoreApplication::notifyInternal (this=0x645650, receiver=0xdb3740, event=0xaffe20) at kernel/qcoreapplication.cpp:732
#30 0x00007fe0ce51bc22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x62a560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x62a560) at kernel/qcoreapplication.cpp:1373
#32 0x00007fe0ce545653 in sendPostedEvents (s=0x65ec20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x65ec20) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007fe0c5b0a342 in g_main_dispatch (context=0x65dd20) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#35 g_main_context_dispatch (context=0x65dd20) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#36 0x00007fe0c5b0e2a8 in g_main_context_iterate (context=0x65dd20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#37 0x00007fe0c5b0e45c in g_main_context_iteration (context=0x65dd20, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#38 0x00007fe0ce545193 in QEventDispatcherGlib::processEvents (this=0x62a070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#39 0x00007fe0cd715a4e in QGuiEventDispatcherGlib::processEvents (this=0xdb3740, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fe0ce517a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007fe0ce517dec in QEventLoop::exec (this=0x7fff58f5aa20, flags=) at kernel/qeventloop.cpp:201
#42 0x00007fe0ce51bebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#43 0x00007fe0d1173a56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#44 0x00007fe0d0dd4d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff58f5ade8) at libc-start.c:226
#45 0x0000000000400669 in _start ()

Possible duplicates by query: bug 258571, bug 258339, bug 257691, bug 257645, bug 257505.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-12-05 23:55:09 UTC

*** This bug has been marked as a duplicate of bug 241562 ***