Bug 258339 - Software Management crashed during search. Says cannot get exclusive lock on backend
Summary: Software Management crashed during search. Says cannot get exclusive lock on ...
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-30 04:56 UTC by Andrew
Modified: 2010-11-30 13:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2010-11-30 04:56:56 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: 

Software management cannot update due to it not being able to get exclusive lock on the packaging backend. Advises to close other legacy packaging tools that may be open. No other tools are open or any programs in general. please advise.

thanks,
-Andrew

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5f139fa7a0 (LWP 2039))]

Thread 2 (Thread 0x7f5ee690a710 (LWP 2041)):
#0  0x00007f5f133061d3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5f07ef0009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f5f07ef045c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f5f109bb1e6 in QEventDispatcherGlib::processEvents (this=0x2727f00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f5f1098da02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f5f1098ddec in QEventLoop::exec (this=0x7f5ee6909cb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f5f108982fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f5f1096d5f8 in QInotifyFileSystemWatcherEngine::run (this=0x2727540) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f5f1089b27e in QThreadPrivate::start (arg=0x2727540) at thread/qthread_unix.cpp:266
#9  0x00007f5f0b54d953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f5f10610971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f5f1331291d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5f139fa7a0 (LWP 2039)):
[KCrash Handler]
#6  0x00007f5f1105f304 in KJob::isAutoDelete (this=0x330b160) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007f5f1105f9b8 in KJob::emitResult (this=0x330b160) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007f5eeeb9cc73 in StatusNotifierItemJob::contextMenuReady (this=0x330b160, menu=0x3310bd0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f5eeeb9cce0 in StatusNotifierItemJob::qt_metacall (this=0x330b160, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff213094e0) at ./statusnotifieritemjob.moc:75
#10 0x00007f5f109a6b27 in QMetaObject::activate (sender=0x3310940, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f5f10cc1120) at kernel/qobject.cpp:3280
#11 0x00007f5eeeb96c7f in StatusNotifierItemSource::contextMenuReady (this=0x330b160, _t1=0x3310bd0) at ./statusnotifieritemsource.moc:109
#12 0x00007f5eeeb9bbe4 in StatusNotifierItemSource::qt_metacall (this=0x3310940, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff213095d0) at ./statusnotifieritemsource.moc:90
#13 0x00007f5f109a6b27 in QMetaObject::activate (sender=0x32fcb30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f5f10cc1120) at kernel/qobject.cpp:3280
#14 0x00007f5f0921589c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f5f09216a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007f5f109a6b27 in QMetaObject::activate (sender=0x3310bd0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f5f10cc1120) at kernel/qobject.cpp:3280
#17 0x00007f5f0ff3ef40 in QMenu::qt_metacall (this=0x3310bd0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff21309a50) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f5f10997bf9 in QMetaMethod::invoke (this=0x7fff21309d00, object=0x3310bd0, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007f5f10999306 in QMetaObject::invokeMethod (obj=0x3310bd0, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007f5f092107c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007f5eeeb981bb in StatusNotifierItemSource::contextMenu (this=0x3310940, x=1678, y=1154) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007f5eeeb9e2d8 in StatusNotifierItemJob::start (this=0x330b160) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007f5f12edfb21 in Plasma::ServiceJob::qt_metacall (this=0x330b160, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007f5eeeb9ccc0 in StatusNotifierItemJob::qt_metacall (this=0x330b160, _c=QMetaObject::InvokeMetaMethod, _id=32997424, _a=0x7f5f10cc1120) at ./statusnotifieritemjob.moc:70
#25 0x00007f5f109a0bde in QObject::event (this=0x330b160, e=0x330b160) at kernel/qobject.cpp:1219
#26 0x00007f5f0fad8fdc in QApplicationPrivate::notify_helper (this=0x1ef1d60, receiver=0x330b160, e=0x3312b30) at kernel/qapplication.cpp:4396
#27 0x00007f5f0fadeaed in QApplication::notify (this=0x1ed81e0, receiver=0x330b160, e=0x3312b30) at kernel/qapplication.cpp:4277
#28 0x00007f5f1162a156 in KApplication::notify (this=0x1ed81e0, receiver=0x330b160, event=0x3312b30) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f5f1098ecdc in QCoreApplication::notifyInternal (this=0x1ed81e0, receiver=0x330b160, event=0x3312b30) at kernel/qcoreapplication.cpp:732
#30 0x00007f5f10991c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1e81560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1e81560) at kernel/qcoreapplication.cpp:1373
#32 0x00007f5f109bb653 in sendPostedEvents (s=0x1ef54c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x1ef54c0) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f5f07eec342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f5f07ef02a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f5f07ef045c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f5f109bb193 in QEventDispatcherGlib::processEvents (this=0x1e81070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f5f0fb8ba4e in QGuiEventDispatcherGlib::processEvents (this=0x330b160, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f5f1098da02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f5f1098ddec in QEventLoop::exec (this=0x7fff2130af90, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f5f10991ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f5f135e9a56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f5f1324ad8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff2130b358) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 257691, bug 257645, bug 257505, bug 257473, bug 257092.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-11-30 13:58:32 UTC

*** This bug has been marked as a duplicate of bug 241562 ***