Bug 258571 - plasma crash after update.
Summary: plasma crash after update.
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-02 15:20 UTC by sqwatop
Modified: 2010-12-02 22:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sqwatop 2010-12-02 15:20:36 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:plasma crashed after updates were applied. Before that I added medibuntu to the list of repositories using the guide on the medibuntu site and had to do it twice because I had synaptic open the first time. I also had Firefox open with 6 or so tabs open.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2021de8780 (LWP 1676))]

Thread 2 (Thread 0x7f1ffff73710 (LWP 1678)):
#0  0x00007fff4cfe9904 in clock_gettime ()
#1  0x00007f20167b00bf in clock_gettime (clock_id=1, tp=0x7f1ffff72ac0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f201ede294f in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#4  0x00007f201eeaf1fd in QTimerInfoList::updateCurrentTime (this=0x1) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007f201eeaf225 in QTimerInfoList::timerWait (this=0x1, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007f201eead3dd in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f1ffff72bfc) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f201eead485 in timerSourcePrepare (source=0x1, timeout=0x7f1ffff72ac0) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f201650da11 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#9  0x00007f201650de78 in ?? () from /lib/libglib-2.0.so.0
#10 0x00007f201650e45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#11 0x00007f201eead1e6 in QEventDispatcherGlib::processEvents (this=0x18dd190, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#12 0x00007f201ee7fa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#13 0x00007f201ee7fdec in QEventLoop::exec (this=0x7f1ffff72d90, flags=) at kernel/qeventloop.cpp:201
#14 0x00007f201ed8a2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#15 0x00007f201ee5f5f8 in QInotifyFileSystemWatcherEngine::run (this=0x18dc6d0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f201ed8d27e in QThreadPrivate::start (arg=0x18dc6d0) at thread/qthread_unix.cpp:266
#17 0x00007f201eb02971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#18 0x00007f202180494d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2021de8780 (LWP 1676)):
[KCrash Handler]
#6  0x00007f201f551304 in KJob::isAutoDelete (this=0x29f18f0) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007f201f5519b8 in KJob::emitResult (this=0x29f18f0) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007f20041c9c73 in StatusNotifierItemJob::contextMenuReady (this=0x29f18f0, menu=0x1f5b480) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f20041c9ce0 in StatusNotifierItemJob::qt_metacall (this=0x29f18f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4cfe57d0) at ./statusnotifieritemjob.moc:75
#10 0x00007f201ee98b27 in QMetaObject::activate (sender=0x29b7090, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f201f1b3120) at kernel/qobject.cpp:3280
#11 0x00007f20041c3c7f in StatusNotifierItemSource::contextMenuReady (this=0x29f18f0, _t1=0x1f5b480) at ./statusnotifieritemsource.moc:109
#12 0x00007f20041c8be4 in StatusNotifierItemSource::qt_metacall (this=0x29b7090, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4cfe58c0) at ./statusnotifieritemsource.moc:90
#13 0x00007f201ee98b27 in QMetaObject::activate (sender=0x1fdf930, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f201f1b3120) at kernel/qobject.cpp:3280
#14 0x00007f201783389c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f2017834a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007f201ee98b27 in QMetaObject::activate (sender=0x1f5b480, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f201f1b3120) at kernel/qobject.cpp:3280
#17 0x00007f201e430f40 in QMenu::qt_metacall (this=0x1f5b480, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4cfe5d40) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f201ee89bf9 in QMetaMethod::invoke (this=0x7fff4cfe5ff0, object=0x1f5b480, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007f201ee8b306 in QMetaObject::invokeMethod (obj=0x1f5b480, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007f201782e7c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007f20041c51bb in StatusNotifierItemSource::contextMenu (this=0x29b7090, x=1042, y=1001) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007f20041cb2d8 in StatusNotifierItemJob::start (this=0x29f18f0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007f20213d1b21 in Plasma::ServiceJob::qt_metacall (this=0x29f18f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007f20041c9cc0 in StatusNotifierItemJob::qt_metacall (this=0x29f18f0, _c=QMetaObject::InvokeMetaMethod, _id=19288544, _a=0x7f201f1b3120) at ./statusnotifieritemjob.moc:70
#25 0x00007f201ee92bde in QObject::event (this=0x29f18f0, e=0x29f18f0) at kernel/qobject.cpp:1219
#26 0x00007f201dfcafdc in QApplicationPrivate::notify_helper (this=0xfe7f70, receiver=0x29f18f0, e=0x2500b80) at kernel/qapplication.cpp:4396
#27 0x00007f201dfd0aed in QApplication::notify (this=0xfd8910, receiver=0x29f18f0, e=0x2500b80) at kernel/qapplication.cpp:4277
#28 0x00007f201fb1c156 in KApplication::notify (this=0xfd8910, receiver=0x29f18f0, event=0x2500b80) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f201ee80cdc in QCoreApplication::notifyInternal (this=0xfd8910, receiver=0x29f18f0, event=0x2500b80) at kernel/qcoreapplication.cpp:732
#30 0x00007f201ee83c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xfbd560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xfbd560) at kernel/qcoreapplication.cpp:1373
#32 0x00007f201eead653 in sendPostedEvents (s=0xfeb6c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0xfeb6c0) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f201650a342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f201650e2a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f201650e45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f201eead193 in QEventDispatcherGlib::processEvents (this=0xfbd070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f201e07da4e in QGuiEventDispatcherGlib::processEvents (this=0x29f18f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f201ee7fa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f201ee7fdec in QEventLoop::exec (this=0x7fff4cfe7280, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f201ee83ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f2021adba56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f202173cd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff4cfe7648) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 258339, bug 257691, bug 257645, bug 257505, bug 257473.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-02 22:20:34 UTC
[Comment from a bug triager]
This issue is being tracked at bug 241562; and some fixes are being analyzed. Merging. Thanks

*** This bug has been marked as a duplicate of bug 241562 ***