Bug 255626 - Plasma-desktop crashed while starting kde
Summary: Plasma-desktop crashed while starting kde
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-30 00:19 UTC by Franz-Rudolf Kuhnen
Modified: 2010-10-30 14:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Franz-Rudolf Kuhnen 2010-10-30 00:19:35 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I updated some packages of kde-4.5.2 from the factory-repository

System: 
opensuse-11.3
kde-4.5.2

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Floating point exception
[Current thread is 1 (Thread 0xb16c5720 (LWP 21065))]

Thread 2 (Thread 0xa96a8b70 (LWP 21091)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb63f3125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb764a24c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb4303457 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb44221a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb430349f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb44221a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb3bbcc38 in ?? () from /usr/X11R6/lib/libGL.so.1

Thread 1 (Thread 0xb16c5720 (LWP 21065)):
[KCrash Handler]
#7  0xb777210a in enter.8102 () from /lib/ld-linux.so.2
#8  0xb7772771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb7772b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb777445b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb777b823 in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb777750f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb777b2e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb3801bdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb777750f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb3802342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb3801ca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb65583e5 in QLibraryPrivate::load_sys (this=0x86ac830) at plugin/qlibrary_unix.cpp:205
#19 0xb6552864 in QLibraryPrivate::load (this=0x86ac830) at plugin/qlibrary.cpp:484
#20 0xb6552948 in QLibraryPrivate::loadPlugin (this=0x86ac830) at plugin/qlibrary.cpp:516
#21 0xb654c883 in QPluginLoader::load (this=0xbf90494c) at plugin/qpluginloader.cpp:227
#22 0xb689a92f in KPluginLoader::load (this=0xbf90494c) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:222
#23 0xb689adf5 in KPluginLoader::KPluginLoader (this=0xbf90494c, service=..., componentdata=..., parent=0x0) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:180
#24 0xb7381a5a in Plasma::DataEngineManager::loadEngine (this=0x85bbe70, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/dataenginemanager.cpp:137
#25 0xb73b8c55 in Plasma::DataEngineConsumer::dataEngine (this=0x8645610, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/private/dataengineconsumer.cpp:100
#26 0xb733dd97 in Plasma::Applet::dataEngine (this=0x8644388, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/applet.cpp:663
#27 0xa85b3f62 in ClockApplet::init (this=0x8644388) at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmaclock/clockapplet.cpp:570
#28 0xa86faa3e in Clock::init (this=0x8644388) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/generic/applets/digital-clock/clock.cpp:72
#29 0xb73648dd in Plasma::Containment::addApplet (this=0x81f1200, applet=0x8644388, pos=..., delayInit=false) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:996
#30 0xb7364c62 in Plasma::ContainmentPrivate::addApplet (this=0x8272698, name=..., args=..., appletGeometry=..., id=0, delayInit=false) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:2379
#31 0xb7364f7a in Plasma::Containment::addApplet (this=0x81f1200, name=..., args=..., appletGeometry=...) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:926
#32 0xb6f4a1b2 in WorkspaceScripting::Containment::addWidget (context=0xa89a8200, engine=0xbf9058c4) at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/containment.cpp:207
#33 0xb4379e5a in QScript::FunctionWrapper::proxyCall (exec=0xbf904160, callee=0xa8944f80, thisObject=..., args=...) at bridge/qscriptfunction.cpp:82
#34 0xb426c8e3 in QTJSC::NativeFuncWrapper::operator() (this=0xbf904ec8, exec=0xa89a8200, jsobj=0xa8944f80, thisValue=..., argList=...)
    at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#35 0xb42381d9 in QTJSC::cti_op_call_NotJSFunction (args=0xa8db1d38) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1771
#36 0xaf38f363 in ?? ()
#37 0xb41df75c in execute (this=0xa8db0360, eval=0xa8dca9d8, callFrame=0xa89a80a8, thisObj=0xa8940000, globalRegisterOffset=31, scopeChain=0xa8daa768, exception=0xbf905090)
    at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITCode.h:79
#38 QTJSC::Interpreter::execute (this=0xa8db0360, eval=0xa8dca9d8, callFrame=0xa89a80a8, thisObj=0xa8940000, globalRegisterOffset=31, scopeChain=0xa8daa768, exception=0xbf905090)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:886
#39 0xb41dfa35 in QTJSC::Interpreter::execute (this=0xa8db0360, eval=0xa8dca9d8, callFrame=0xa89a80a8, thisObj=0xa8940000, scopeChain=0xa8daa768, exception=0xbf905090)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:803
#40 0xb434c8a6 in QScriptEnginePrivate::evaluateHelper (this=0x817a9f0, exec=0xa89a80a8, sourceId=-1462065256, executable=0xa8dca9d8, compile=@0xbf90515f) at api/qscriptengine.cpp:1359
#41 0xb4353b39 in QScriptEngine::evaluate (this=0xa1c618f9, program=..., fileName=..., lineNumber=1) at api/qscriptengine.cpp:2606
#42 0xb6f4528d in WorkspaceScripting::ScriptEngine::evaluateScript (this=0xbf9058c4, script=..., path=...)
    at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/scriptengine.cpp:350
#43 0xb6f51900 in WorkspaceScripting::ScriptEngine::loadTemplate (context=0xa89a80a8, engine=0xbf9058c4)
    at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/scriptengine.cpp:304
#44 0xb4379e5a in QScript::FunctionWrapper::proxyCall (exec=0xbf904160, callee=0xa8944200, thisObject=..., args=...) at bridge/qscriptfunction.cpp:82
#45 0xb426c8e3 in QTJSC::NativeFuncWrapper::operator() (this=0xbf9054e8, exec=0xa89a80a8, jsobj=0xa8944200, thisValue=..., argList=...)
    at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#46 0xb42381d9 in QTJSC::cti_op_call_NotJSFunction (args=0xa8db1e28) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1771
#47 0xaf38e844 in ?? ()
#48 0xb41df75c in execute (this=0xa8db0360, eval=0xa8dc2038, callFrame=0x82744b4, thisObj=0xa8940000, globalRegisterOffset=9, scopeChain=0xa8daa2b8, exception=0xbf9056b0)
    at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITCode.h:79
#49 QTJSC::Interpreter::execute (this=0xa8db0360, eval=0xa8dc2038, callFrame=0x82744b4, thisObj=0xa8940000, globalRegisterOffset=9, scopeChain=0xa8daa2b8, exception=0xbf9056b0)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:886
#50 0xb41dfa35 in QTJSC::Interpreter::execute (this=0xa8db0360, eval=0xa8dc2038, callFrame=0x82744b4, thisObj=0xa8940000, scopeChain=0xa8daa2b8, exception=0xbf9056b0)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:803
#51 0xb434c8a6 in QScriptEnginePrivate::evaluateHelper (this=0x817a9f0, exec=0x82744b4, sourceId=-1462065136, executable=0xa8dc2038, compile=@0xbf90577f) at api/qscriptengine.cpp:1359
#52 0xb4353b39 in QScriptEngine::evaluate (this=0xa1c618f9, program=..., fileName=..., lineNumber=1) at api/qscriptengine.cpp:2606
#53 0xb6f4528d in WorkspaceScripting::ScriptEngine::evaluateScript (this=0xbf9058c4, script=..., path=...)
    at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/scriptengine.cpp:350
#54 0xb7711f65 in DesktopCorona::evaluateScripts (this=0x80a83f0, scripts=...) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/desktopcorona.cpp:320
#55 0xb77121f3 in DesktopCorona::loadDefaultLayout (this=0x80a83f0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/desktopcorona.cpp:337
#56 0xb7378ed3 in Plasma::Corona::initializeLayout (this=0x80a83f0, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:366
#57 0xb771819a in PlasmaApp::corona (this=0x80a51e0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:806
#58 0xb771b85e in PlasmaApp::setupDesktop (this=0x80a51e0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:286
#59 0xb7724409 in PlasmaApp::qt_metacall (this=0x80a51e0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0x8156440)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasmaapp.moc:149
#60 0xb656e96d in QMetaObject::metacall (object=0x80a51e0, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0x8156440) at kernel/qmetaobject.cpp:237
#61 0xb6579465 in QMetaCallEvent::placeMetaCall (this=0x8156760, object=0x80a51e0) at kernel/qobject.cpp:534
#62 0xb657d69f in QObject::event (this=0x80a51e0, e=0x8156760) at kernel/qobject.cpp:1211
#63 0xb656871a in QCoreApplication::event (this=0x80a51e0, e=0x8156760) at kernel/qcoreapplication.cpp:1561
#64 0xb5a6a8dd in QApplication::event (this=0x80a51e0, e=0x8156760) at kernel/qapplication.cpp:2439
#65 0xb5a681a4 in QApplicationPrivate::notify_helper (this=0x80adc20, receiver=0x80a51e0, e=0x8156760) at kernel/qapplication.cpp:4396
#66 0xb5a70dd7 in QApplication::notify (this=0x80a51e0, receiver=0x80a51e0, e=0x8156760) at kernel/qapplication.cpp:3798
#67 0xb6af09c1 in KApplication::notify (this=0x80a51e0, receiver=0x80a51e0, event=0x8156760) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#68 0xb656812e in QCoreApplication::notifyInternal (this=0x80a51e0, receiver=0x80a51e0, event=0x8156760) at kernel/qcoreapplication.cpp:732
#69 0xb656be6c in sendEvent (receiver=0x0, event_type=0, data=0x804e5b8) at kernel/qcoreapplication.h:215
#70 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x804e5b8) at kernel/qcoreapplication.cpp:1373
#71 0xb656bfbc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#72 0xb65966d4 in sendPostedEvents (s=0x80aff08) at kernel/qcoreapplication.h:220
#73 postEventSourceDispatch (s=0x80aff08) at kernel/qeventdispatcher_glib.cpp:277
#74 0xb3661b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#75 0xb3662350 in ?? () from /usr/lib/libglib-2.0.so.0
#76 0xb366260e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#77 0xb659685b in QEventDispatcherGlib::processEvents (this=0x80ad8a0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#78 0xb5b1d19a in QGuiEventDispatcherGlib::processEvents (this=0x80ad8a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#79 0xb656740d in QEventLoop::processEvents (this=0xbf906424, flags=...) at kernel/qeventloop.cpp:149
#80 0xb6567639 in QEventLoop::exec (this=0xbf906424, flags=...) at kernel/qeventloop.cpp:201
#81 0xb656c090 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#82 0xb5a65ed4 in QApplication::exec () at kernel/qapplication.cpp:3672
#83 0xb771106d in kdemain (argc=1, argv=0xbf906624) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#84 0x0804861b in main (argc=1, argv=0xbf906624) at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-30 14:13:59 UTC

*** This bug has been marked as a duplicate of bug 251719 ***