Bug 257057 - Dragonplayer does not support kio ressources
Summary: Dragonplayer does not support kio ressources
Status: RESOLVED DUPLICATE of bug 257903
Alias: None
Product: dragonplayer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 188291 285950 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-16 12:06 UTC by Christian Weilbach
Modified: 2012-11-25 09:52 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Weilbach 2010-11-16 12:06:17 UTC
Version:           unspecified (using KDE 4.5.3) 
OS:                Linux

Dragonplayer's phonon fallback for KIO does not work properly as one cannot load sftp:// addresses for example. Phononplay from the playground repository works as expected. 

Reproducible: Always

Steps to Reproduce:
Simply try loading a ressource which is not natively supported by xine. sftp is a good example.

Actual Results:  
Dragon keeps loading (mouse pointer shows its busy) but does not give any result or error. Command output hasn't helped me either.

Expected Results:  
Loading of the movie.

This is needed for a pet project of mine where I have wrapped a KIO-Slave around KTorrent to make loading of magnet:// resources as seemless as http:// ones. Phonon-xine generally supports that, as I have already tested it in KHTML's video element. I can watch a magnet-referenced torrent stream of the Sintel open movie inside the HTML5 video player.
Comment 1 Andreas Gölzer 2010-11-22 23:25:08 UTC
I can confirm this but, using dragon player 2.0 from kde 4.5.3 (ubuntu packages)

This is probably a duplicate of 
bug 188291 ( https://bugs.kde.org/show_bug.cgi?id=188291 , It's impossible to watch video in Dragon player from a password protected SMB share)
and 
bug 230327 ( https://bugs.kde.org/show_bug.cgi?id=230327 , Dragon Player shows black screen trying to open a (500MB) video over samba share) , 
though this bug's title seems to describe the problem best.
Comment 2 Harald Sitter 2012-07-13 02:14:50 UTC
*** Bug 188291 has been marked as a duplicate of this bug. ***
Comment 3 Harald Sitter 2012-07-13 02:19:49 UTC
*** Bug 285950 has been marked as a duplicate of this bug. ***
Comment 4 Harald Sitter 2012-11-25 09:52:21 UTC

*** This bug has been marked as a duplicate of bug 257903 ***