Bug 230327 - Dragon Player shows black screen trying to open a (500MB) video over samba share
Summary: Dragon Player shows black screen trying to open a (500MB) video over samba share
Status: RESOLVED DUPLICATE of bug 257903
Alias: None
Product: dragonplayer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-11 16:35 UTC by Fabio Albieri
Modified: 2012-11-25 09:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Albieri 2010-03-11 16:35:33 UTC
Version:            (using KDE 4.4.1)
Installed from:    openSUSE RPMs

Greetings,

as for description
- I open a (perfectly working in gnome, WinXP) samba share using Dolphin
- I navigate trough the folders and find the file
- I open the video file with DragonPlayer
- DragonPlayer opens, but screen stays black

Note 1: Kaffeine gives me black screen + a small, empty error message.

Note 2: I may be totally wrong... is it possible that KDE tries to download the video file locally before actually play it ?
I can't test this very well (I'm on a netbook, and have no plenty disk space for /tmp dir = every sort of crash/problems)
Comment 1 Chris 2011-04-03 18:35:19 UTC
I can confirm the issue with a password-protected SMB share. For shares without authentication, it seems to work fine.

A workaround for this, when you really need authentication is to manually mount the share instead of using KIO.

This is likely to be a phonon issue.
Comment 2 Jekyll Wu 2011-12-30 08:26:10 UTC
It is probably a problem of the phonon backend in use.  I have similar problem when using the gstremer backend, but fine with the vlc backend.
Comment 3 Harald Sitter 2012-11-25 09:52:13 UTC

*** This bug has been marked as a duplicate of bug 257903 ***