Bug 254131 - Add geotagging symbol in album view
Summary: Add geotagging symbol in album view
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Thumbs-Image (show other bugs)
Version: 3.5.0
Platform: Compiled Sources Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-14 11:00 UTC by PCB
Modified: 2014-05-27 13:47 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PCB 2010-10-14 11:00:05 UTC
Version:           1.2.0 (using KDE 4.4.5) 
OS:                Linux

While starting to geotag my older pictures, I had some problems that I think can be overcome by a few improvements to Digikam. Just one small example: Assume you have GPX-Records and a bunch of pictures you want to geotag. This can be done via the Geotag correlator already included, which is fine. But if the GPX record was not complete, or you happen to be in an area with poor GPS reception or even in a building, then not all of your pics will be geotagged. Thats ok so far.

My problem is that I want to easily find out which of my pictures have _not_ been geotagged so far. This is not only limited to single albums, but to my whole collection.

So, I have two suggestions for improving Digikam in this point:

1. There already is the possibility to filter images (left side) to, e.g. only show pics with a certain tag. This mechanism could be expanded to optionally show all pictures without geotagging information. This would help identifying pics without geotag on a collection-wide level

2. In album view, I can already choose which information to display below each pic preview, such as filename, date, file size etc. This could be extended to also display if there is already a geotag associated with this pic. I don't think it would be very reasonable to display the coordinates themselves there. But, for example, what about an icon? Each pic that was geotagged gets an (optional) icon in the lower left of the preview, depiciting, e.g., the earth (or whatever). This would allow me to easily find the pics in my album that were not yet geotagged.

I think both suggestions would clearly improve the act of geotagging pics in Digikam.

Oh, and as a side note: Keep up the good work! :-)

Reproducible: Didn't try
Comment 1 Axel Krebs 2010-10-16 16:24:48 UTC
I would like support this wish; in my daily`s work with DK, I appreciate any procedure to simplify workflow. Sometimes, work is similar to a set-algebra deal.

It would easy getting collections consistently which is an accepted pre-requisite in any database.
Comment 2 Michael G. Hansen 2011-02-02 22:03:20 UTC
*** Bug 225946 has been marked as a duplicate of this bug. ***
Comment 3 Michael G. Hansen 2011-09-16 06:18:07 UTC
*** Bug 281848 has been marked as a duplicate of this bug. ***
Comment 4 Michael G. Hansen 2011-10-16 21:07:49 UTC
Git commit 822cf19c7c03c146af2c35c89b6532871e124bd1 by Michael Georg Hansen.
Committed on 16/10/2011 at 23:05.
Pushed by mghansen into branch 'master'.

Add a geolocation filter option to the filtering sidebar.

The setting of the filter is not yet restored when digikam is restarted.

CCBUG: 254131

M  +1    -0    CMakeLists.txt
M  +16   -0    digikam/filters/filtersidebarwidget.cpp
M  +2    -0    digikam/filters/filtersidebarwidget.h
M  +6    -0    digikam/filters/filterstatusbar.cpp
A  +80   -0    digikam/filters/geolocationfilter.cpp     [License: GPL (v2+)]
A  +63   -0    digikam/filters/geolocationfilter.h     [License: GPL (v2+)]
M  +4    -0    digikam/views/digikamview.cpp
M  +8    -0    libs/models/imagefiltermodel.cpp
M  +2    -0    libs/models/imagefiltermodel.h
M  +43   -6    libs/models/imagefiltersettings.cpp
M  +21   -0    libs/models/imagefiltersettings.h

http://commits.kde.org/digikam/822cf19c7c03c146af2c35c89b6532871e124bd1
Comment 5 caulier.gilles 2011-10-30 09:05:23 UTC
Michael,

Can we close this file as resolved for 2.3.0, and add this new geolocation filter feature in NEWS file ?

Gilles Caulier
Comment 6 Axel Krebs 2011-10-30 09:18:13 UTC
(In reply to comment #5)
> Michael,
> 
> Can we close this file as resolved for 2.3.0, and add this new geolocation
> filter feature in NEWS file ?
> 
> Gilles Caulier

Thanx for information :-) !

Maybe, the mentioned solution should apply to watermarks and metadata as well as wished earlier. 

Axel
Comment 7 Michael G. Hansen 2011-10-30 09:26:22 UTC
Hi Gilles,

I only implemented an additional filter, which we could mention in the NEWS. But this wish is about an icon on the images to indicate the geotagging status, so I think we should keep it open. By the way, feel free to move this filter's UI elements further down in the filter panel, if you think the others are used more often.

Regards,

Michael
Comment 8 caulier.gilles 2013-12-04 18:08:37 UTC
*** Bug 303066 has been marked as a duplicate of this bug. ***
Comment 9 caulier.gilles 2014-05-27 13:47:43 UTC
Git commit 46767337dfc131e678f1b2c00b1099f1ba3e2f69 by Gilles Caulier.
Committed on 27/05/2014 at 13:43.
Pushed by cgilles into branch 'master'.

Add an icon over thumbnails to indicate the geotagging status.
This include : Album icon-view, Preview Thumbbar, Editor Thumbbar, LightTable Thumbbar, Import Icon-view, Import ThumbBar, Showfoto Thummbar
A new settings in digiKam-AlbumView, DigiKam-Camera, and Showfoto-Misc pages have been add to turn on/of this feature (disabled by default)
FIXED-IN: 4.1.0

M  +2    -1    NEWS
M  +2    -0    digikam/items/digikamimagedelegate.cpp
M  +14   -2    digikam/items/imagedelegate.cpp
M  +2    -0    digikam/items/imagedelegate.h
M  +4    -1    digikam/items/imagedelegatepriv.h
M  +4    -4    digikam/items/imagerotationoverlay.cpp
M  +5    -5    digikam/items/imagerotationoverlay.h
M  +4    -3    digikam/items/imagethumbnaildelegate.cpp
M  +1    -1    digikam/items/imagethumbnaildelegate.h
M  +1    -1    digikam/items/imagethumbnaildelegatepriv.h
M  +23   -2    digikam/utils/albumsettings.cpp
M  +4    -1    digikam/utils/albumsettings.h
M  +5    -0    libs/dmetadata/dmetadata.cpp
M  +8    -3    libs/dmetadata/infocontainer.cpp
M  +3    -1    libs/dmetadata/infocontainer.h
M  +12   -0    libs/widgets/itemview/itemviewimagedelegate.cpp
M  +2    -1    libs/widgets/itemview/itemviewimagedelegate.h
M  +37   -21   showfoto/main/showfotosettings.cpp
M  +4    -0    showfoto/main/showfotosettings.h
M  +19   -11   showfoto/setup/setupmisc.cpp
M  +1    -1    showfoto/setup/setupmisc.h
M  +12   -26   showfoto/thumbbar/itemviewshowfotodelegate.cpp
M  +1    -1    showfoto/thumbbar/itemviewshowfotodelegate.h
M  +17   -3    showfoto/thumbbar/showfotodelegate.cpp
M  +3    -1    showfoto/thumbbar/showfotodelegate.h
M  +9    -7    showfoto/thumbbar/showfotodelegatepriv.h
M  +1    -1    utilities/importui/backend/cameracontroller.cpp
M  +1    -1    utilities/importui/backend/cameracontroller.h
M  +9    -5    utilities/importui/backend/gpcamera.cpp
M  +32   -5    utilities/importui/items/importdelegate.cpp
M  +2    -1    utilities/importui/items/importdelegate.h
M  +4    -1    utilities/importui/items/importdelegatepriv.h
M  +3    -2    utilities/importui/items/importoverlays.cpp
M  +2    -1    utilities/importui/items/importoverlays.h
M  +8    -16   utilities/importui/items/itemviewimportdelegate.cpp
M  +2    -2    utilities/importui/items/itemviewimportdelegate.h
M  +17   -1    utilities/importui/main/importsettings.cpp
M  +10   -7    utilities/importui/main/importsettings.h
M  +14   -6    utilities/setup/setupalbumview.cpp
M  +18   -10   utilities/setup/setupcamera.cpp
M  +1    -1    utilities/setup/setupcamera.h

http://commits.kde.org/digikam/46767337dfc131e678f1b2c00b1099f1ba3e2f69