Bug 244291 - NetworkManager KDED crash after selection VPN connection through NM plasmoid
Summary: NetworkManager KDED crash after selection VPN connection through NM plasmoid
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-12 13:40 UTC by Sascha Peilicke
Modified: 2010-08-06 11:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Peilicke 2010-07-12 13:40:27 UTC
Application: kded4 ($Id: kded.cpp 1128583 2010-05-19 17:42:25Z aseigo $)
KDE Platform Version: 4.4.92 (KDE 4.4.92 (KDE 4.5 RC2)) "release 2"
Qt Version: 4.7.0
Operating System: Linux 2.6.34-12-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Logged in in a non-secured WLAN, tried to activate VPNC VPN connection... 
- Unusual behavior I noticed:
No response from NM plasmoid, KDED crash

- Custom settings of the application:
Custom VPN connection setup

A rather odd issue is that the KDED doesn't restart automatically, which leaves the networkmanager plasmoid unusable. One has to  manually start it in the related KCM.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x90b110) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x90b110) at /usr/include/QtCore/qstring.h:715
#8  Knm::Activatable::deviceUni (this=0x90b110) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0x00007fee12864c52 in compareDevices (first=<value optimized out>, second=0x90b110) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#10 0x00007fee12864f53 in activatableLessThan (first=0x8aaec0, second=0x90b110) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#11 0x00007fee12865a2a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x9602e8, lessThan=0x7fee12864f30 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#12 0x00007fee12865817 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x955b70, activatable=0x8aaec0)
    at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x955b70, activatable=0x8aaec0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#14 0x00007fee128560b3 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x8aaec0) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#15 0x00007fee12859f67 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=<value optimized out>, addedConnection=0x95c060)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:132
#16 0x00007fee12858cf5 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=0x9a04c0, ssid=...)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:176
#17 0x00007fee1285942f in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider (this=0x9a04c0, connectionList=<value optimized out>, activatableList=0x949060, 
    interface=<value optimized out>, parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:76
#18 0x00007fee12856b55 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x9517c0, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:71
#19 0x00007fee1285211d in NetworkInterfaceMonitor::qt_metacall (this=0x9517c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2e103020)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#20 0x00007fee2d48ab1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#21 0x00007fee18cbb505 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.92/build/libs/solid/control/networkmanager.moc:107
#22 0x00007fee18cbbad7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x801e10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2e103130)
    at /usr/src/debug/kdebase-workspace-4.4.92/build/libs/solid/control/networkmanager_p.moc:81
#23 0x00007fee2d48ab1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#24 0x00007fee18897b85 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.92/build/libs/solid/control/ifaces/networkmanager.moc:115
#25 0x00007fee14dea62a in NMNetworkManager::deviceAdded (this=0x8d28b0, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.92/solid/networkmanager-0.7/manager.cpp:199
#26 0x00007fee14ded119 in NMNetworkManager::qt_metacall (this=0x8d28b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2e1032e0)
    at /usr/src/debug/kdebase-workspace-4.4.92/build/solid/networkmanager-0.7/manager.moc:95
#27 0x00007fee2d48ab1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#28 0x00007fee14df59d2 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.92/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#29 0x00007fee14df5e94 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x8f03a0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff2e103720)
    at /usr/src/debug/kdebase-workspace-4.4.92/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#30 0x00007fee2a8a9358 in QDBusConnectionPrivate::deliverCall(QObject*, int, QDBusMessage const&, QList<int> const&, int) () from /usr/lib64/libQtDBus.so.4
#31 0x00007fee2a8b4f0f in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib64/libQtDBus.so.4
#32 0x00007fee2d48979a in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#33 0x00007fee2c640b34 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#34 0x00007fee2c648f5a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#35 0x00007fee2e1a7556 in KApplication::notify (this=0x7fff2e104200, receiver=0x8f03a0, event=0x9839e0) at /usr/src/debug/kdelibs-4.4.92/kdeui/kernel/kapplication.cpp:309
#36 0x00007fee2d47599c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#37 0x00007fee2d479145 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#38 0x00007fee2d4a0423 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/libQtCore.so.4
#39 0x00007fee28feea93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007fee28fef270 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007fee28fef510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007fee2d4a05bf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x00007fee2c6e479e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtGui.so.4
#44 0x00007fee2d474dd2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#45 0x00007fee2d474fe5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#46 0x00007fee2d4793fb in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#47 0x00007fee1fac73b7 in kdemain (argc=1, argv=0x6668f0) at /usr/src/debug/kdelibs-4.4.92/kded/kded.cpp:894
#48 0x00000000004070d9 in launch (argc=1, _name=0x40b259 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=
    false, startup_id_str=0x40b0fe "0") at /usr/src/debug/kdelibs-4.4.92/kinit/kinit.cpp:723
#49 0x00000000004098ea in main (argc=4, argv=0x7fff2e1051f8, envp=0x7fff2e105220) at /usr/src/debug/kdelibs-4.4.92/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-08-06 11:54:32 UTC

*** This bug has been marked as a duplicate of bug 210878 ***