Bug 231278 - crash when restarting underlying network manager
Summary: crash when restarting underlying network manager
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-19 08:58 UTC by Michael Eyrich
Modified: 2010-03-19 12:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Eyrich 2010-03-19 08:58:54 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32.8 x86_64
Distribution: Debian GNU/Linux testing (squeeze)

What I was doing when the application crashed:
When starting the service network-manager (e.g. after its crash), knetworkmanager often crashes.


 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QBasicAtomicInt::ref (this=0x217f6b0) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#6  QString (this=0x217f6b0) at /usr/include/qt4/QtCore/qstring.h:712
#7  Knm::Activatable::deviceUni (this=0x217f6b0) at ../../../libs/internals/activatable.cpp:51
#8  0x00007faf86c62495 in compareDevices (first=0x217f6b0, second=0x2283090) at ../../../libs/service/sortedactivatablelist.cpp:262
#9  0x00007faf86c625e3 in activatableLessThan (first=0x7ffff9b37a50, second=0x217f6b0) at ../../../libs/service/sortedactivatablelist.cpp:172
#10 0x00007faf86c62880 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=)
    at /usr/include/qt4/QtCore/qalgorithms.h:384
#11 0x00007faf86c62af0 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x21d0730, activatable=0x24d7610)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#12 SortedActivatableList::handleAdd (this=0x21d0730, activatable=0x24d7610) at ../../../libs/service/sortedactivatablelist.cpp:96
#13 0x00007faf86c50fdb in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x24d7610) at ../../../libs/service/activatablelist.cpp:99
#14 0x00007faf86c546ba in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x2514250, addedConnection=<value optimized out>)
    at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007faf86c526e1 in NetworkInterfaceActivatableProvider::init (this=0x2514250) at ../../../libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007faf86c51a48 in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...) at ../../../libs/service/networkinterfacemonitor.cpp:79
#17 0x00007faf86c4b88d in NetworkInterfaceMonitor::qt_metacall (this=0x2233ec0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff9b38070) at moc_networkinterfacemonitor.cpp:69
#18 0x00007faf85168df2 in QMetaObject::activate (sender=0x2187b40, from_signal_index=<value optimized out>, to_signal_index=5, argv=0x0) at kernel/qobject.cpp:3112
#19 0x00007faf8653dcf5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#20 0x00007faf8653e5cc in ?? () from /usr/lib/libsolidcontrol.so.4
#21 0x00007faf85168df2 in QMetaObject::activate (sender=0x2259b90, from_signal_index=<value optimized out>, to_signal_index=13, argv=0x0) at kernel/qobject.cpp:3112
#22 0x00007faf7c7c4985 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#23 0x00007faf7c7c6614 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#24 0x00007faf7c7c7ac9 in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#25 0x00007faf85168df2 in QMetaObject::activate (sender=0x225e090, from_signal_index=<value optimized out>, to_signal_index=5, argv=0x0) at kernel/qobject.cpp:3112
#26 0x00007faf7c7d4342 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x00007faf7c7d468d in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#28 0x00007faf85470b83 in QDBusConnectionPrivate::deliverCall (this=0x2185730, object=0x225e090, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:891
#29 0x00007faf8547835f in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#30 0x00007faf851636c8 in QObject::event (this=0x225e090, e=0x2231bc0) at kernel/qobject.cpp:1110
#31 0x00007faf8589701d in QApplicationPrivate::notify_helper (this=0x2113720, receiver=0x225e090, e=0x2231bc0) at kernel/qapplication.cpp:4065
#32 0x00007faf8589f07a in QApplication::notify (this=0x7ffff9b39250, receiver=0x225e090, e=0x2231bc0) at kernel/qapplication.cpp:4030
#33 0x00007faf8780ede6 in KApplication::notify (this=0x7ffff9b39250, receiver=0x225e090, event=0x2231bc0) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x00007faf85153c9c in QCoreApplication::notifyInternal (this=0x7ffff9b39250, receiver=0x225e090, event=0x2231bc0) at kernel/qcoreapplication.cpp:610
#35 0x00007faf851548e4 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x20f6980) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x20f6980) at kernel/qcoreapplication.cpp:1247
#37 0x00007faf8517c7d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007faf816bc90e in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x00007faf816c02c8 in ?? () from /lib/libglib-2.0.so.0
#41 0x00007faf816c03f0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0x00007faf8517c39c in QEventDispatcherGlib::processEvents (this=0x21134a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#43 0x00007faf8592df1f in QGuiEventDispatcherGlib::processEvents (this=0x7ffff9b37a50, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#44 0x00007faf85152562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007faf85152934 in QEventLoop::exec (this=0x7ffff9b391a0, flags=...) at kernel/qeventloop.cpp:201
#46 0x00007faf85154ba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#47 0x000000000040e68f in main (argc=<value optimized out>, argv=<value optimized out>) at ../../monolithic/main.cpp:45

This bug may be a duplicate of or related to bug 213237

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-19 12:55:42 UTC
This is being tracked at bug 210878. Regards

*** This bug has been marked as a duplicate of bug 210878 ***