Bug 241334 - KNotify dies with Segmentation Fault / SIG11 (Potential duplicate of Bug #232068)
Summary: KNotify dies with Segmentation Fault / SIG11 (Potential duplicate of Bug #232...
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-10 19:45 UTC by Deryl R. Doucette
Modified: 2010-06-10 20:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Deryl R. Doucette 2010-06-10 19:45:18 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I have the same problem as bug #232068 on an AMD64 laptop. I am also experiencing the exact same issue with amarok. HOWEVER, Whether I use the gstreamer backend or the xine backend, I still have both KNotify and Amarok dying with this error.

The crash can be reproduced every time.

 -- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f395945f760 (LWP 4238))]

Thread 2 (Thread 0x7f39467e6710 (LWP 4449)):
#0  0x00007f3956bfaf53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f394bb3141f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f394bb20d86 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f394bb22809 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f394bb228c0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f394bb3121b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f394b8f00e8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007f39552ca9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f3956c076cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f395945f760 (LWP 4238)):
[KCrash Handler]
#5  0x00007f394d9f8e49 in ?? () from /usr/lib/libasound.so.2
#6  0x00007f394d9bbb15 in snd_pcm_close () from /usr/lib/libasound.so.2
#7  0x00007f394bf536ff in gst_alsasink_close (asink=<value optimized out>) at gstalsasink.c:804
#8  0x00007f394c4853c6 in gst_audioringbuffer_close_device (buf=<value optimized out>) at gstaudiosink.c:365
#9  0x00007f394c478ecb in gst_ring_buffer_close_device (buf=0xa02330) at gstringbuffer.c:714
#10 0x00007f394c480ca6 in gst_base_audio_sink_change_state (element=<value optimized out>, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1879
#11 0x00007f394cd2418c in gst_element_change_state (element=0xa21710, transition=0) at gstelement.c:2548
#12 0x00007f394cd271bb in gst_element_set_state_func (element=0x849600, state=GST_STATE_NULL) at gstelement.c:2504
#13 0x00007f394d4679aa in Phonon::Gstreamer::AudioOutput::setOutputDevice (this=0x84b9c0, newDevice=<value optimized out>) at ../../gstreamer/audiooutput.cpp:217
#14 0x00007f3958a0c010 in callSetOutputDevice (this=0x778220) at ../3rdparty/phonon/phonon/audiooutput.cpp:67
#15 Phonon::AudioOutputPrivate::setupBackendObject (this=0x778220) at ../3rdparty/phonon/phonon/audiooutput.cpp:281
#16 0x00007f3958a0c6f0 in Phonon::AudioOutputPrivate::createBackendObject (this=0x778220) at ../3rdparty/phonon/phonon/audiooutput.cpp:124
#17 0x00007f3958a08eea in Phonon::AudioOutputPrivate::init (this=0x778220, c=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:106
#18 0x00007f3958a0959d in AudioOutput (this=0x7781f0, category=Phonon::NotificationCategory, parent=0x0) at ../3rdparty/phonon/phonon/audiooutput.cpp:76
#19 0x000000000040d101 in Player (this=0x767738) at ../../knotify/notifybysound.cpp:59
#20 PlayerPool::getPlayer (this=0x767738) at ../../knotify/notifybysound.cpp:99
#21 0x000000000040d63e in NotifyBySound::notify (this=0x75f950, eventId=5, config=0x7fff191ab990) at ../../knotify/notifybysound.cpp:243
#22 0x0000000000408d63 in KNotify::emitEvent (this=0x7fff191acc90, e=0x789a20) at ../../knotify/knotify.cpp:179
#23 0x0000000000409022 in KNotify::event (this=0x7fff191acc90, event=<value optimized out>, appname=<value optimized out>, contexts=<value optimized out>, title=<value optimized out>, 
    text=<value optimized out>, image=..., actions=..., timeout=-1, winId=0) at ../../knotify/knotify.cpp:128
#24 0x000000000040935f in KNotifyAdaptor::event (this=0x7a3e40, event=..., fromApp=..., contexts=<value optimized out>, title=..., text=<value optimized out>, image=..., actions=..., timeout=-1, 
    winId=0) at ../../knotify/knotify.cpp:236
#25 0x000000000040a03b in KNotifyAdaptor::qt_metacall (this=0x7a3e40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff191abf20) at ./knotify.moc:227
#26 0x00007f39582f5486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#27 0x00007f39582f674b in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x7a3e40, flags=273, msg=...) at qdbusintegrator.cpp:816
#28 0x00007f39582f71cd in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1364
#29 0x00007f39582f7468 in QDBusActivateObjectEvent::placeMetaCall (this=0x78ac10) at qdbusintegrator.cpp:1477
#30 0x00007f3957fcbd49 in QObject::event (this=0x7fff191acc90, e=0x78ac10) at kernel/qobject.cpp:1248
#31 0x00007f395737522c in QApplicationPrivate::notify_helper (this=0x70ef00, receiver=0x7fff191acc90, e=0x78ac10) at kernel/qapplication.cpp:4300
#32 0x00007f395737b6fb in QApplication::notify (this=0x7fff191accc0, receiver=0x7fff191acc90, e=0x78ac10) at kernel/qapplication.cpp:4183
#33 0x00007f3958e76526 in KApplication::notify (this=0x7fff191accc0, receiver=0x7fff191acc90, event=0x78ac10) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x00007f3957fbc06c in QCoreApplication::notifyInternal (this=0x7fff191accc0, receiver=0x7fff191acc90, event=0x78ac10) at kernel/qcoreapplication.cpp:704
#35 0x00007f3957fbe7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x6e9c20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x6e9c20) at kernel/qcoreapplication.cpp:1345
#37 0x00007f3957fe59d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007f3953c028c2 in g_main_dispatch (context=0x712d20) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:1960
#40 IA__g_main_context_dispatch (context=0x712d20) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2513
#41 0x00007f3953c06748 in g_main_context_iterate (context=0x712d20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2591
#42 0x00007f3953c068fc in IA__g_main_context_iteration (context=0x712d20, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#43 0x00007f3957fe5513 in QEventDispatcherGlib::processEvents (this=0x6e9760, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#44 0x00007f395742546e in QGuiEventDispatcherGlib::processEvents (this=0xa21710, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f3957fba992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#46 0x00007f3957fbad6c in QEventLoop::exec (this=0x7fff191acbe0, flags=) at kernel/qeventloop.cpp:201
#47 0x00007f3957fbeaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#48 0x0000000000407f4f in main (argc=<value optimized out>, argv=<value optimized out>) at ../../knotify/main.cpp:73

This bug may be a duplicate of or related to bug 232068.

Possible duplicates by query: bug 240428, bug 240181, bug 238918, bug 237744, bug 237442.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-06-10 20:08:01 UTC
The backtrace clearly indicates that you are still using the gstreamer backend (see symbols named "gst_" in backtrace). If you can reproduce a crash with the xine backend, please file a new bug.

*** This bug has been marked as a duplicate of bug 232068 ***