Bug 240181 - systemstart
Summary: systemstart
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-31 09:14 UTC by setzensechs
Modified: 2010-05-31 12:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description setzensechs 2010-05-31 09:14:02 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
einfacher systemstart nach deinstallation von pulse-audio (x-fi forte soundkarte)

 -- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1826292760 (LWP 2085))]

Thread 2 (Thread 0x7f1811e2d710 (LWP 2162)):
#0  0x00007f1823a1af53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f181717841f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f1817167d86 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f1817169809 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f18171698c0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f181717821b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f1816f370e8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007f18220ea9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f1823a276cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1826292760 (LWP 2085)):
[KCrash Handler]
#5  0x00007f181b438e49 in ?? () from /usr/lib/libasound.so.2
#6  0x00007f181b3fbb15 in snd_pcm_close () from /usr/lib/libasound.so.2
#7  0x00007f181759a6ff in gst_alsasink_close (asink=<value optimized out>) at gstalsasink.c:804
#8  0x00007f1819f963c6 in gst_audioringbuffer_close_device (buf=<value optimized out>) at gstaudiosink.c:365
#9  0x00007f1819f89ecb in gst_ring_buffer_close_device (buf=0xbbc1c0) at gstringbuffer.c:714
#10 0x00007f1819f91ca6 in gst_base_audio_sink_change_state (element=<value optimized out>, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1879
#11 0x00007f181a83518c in gst_element_change_state (element=0xbd0860, transition=0) at gstelement.c:2548
#12 0x00007f181a8381bb in gst_element_set_state_func (element=0xbd9600, state=GST_STATE_NULL) at gstelement.c:2504
#13 0x00007f181afd19aa in Phonon::Gstreamer::AudioOutput::setOutputDevice (this=0xbd8350, newDevice=<value optimized out>) at ../../gstreamer/audiooutput.cpp:217
#14 0x00007f182582c010 in callSetOutputDevice (this=0xab8950) at ../3rdparty/phonon/phonon/audiooutput.cpp:67
#15 Phonon::AudioOutputPrivate::setupBackendObject (this=0xab8950) at ../3rdparty/phonon/phonon/audiooutput.cpp:281
#16 0x00007f182582c6f0 in Phonon::AudioOutputPrivate::createBackendObject (this=0xab8950) at ../3rdparty/phonon/phonon/audiooutput.cpp:124
#17 0x00007f1825828eea in Phonon::AudioOutputPrivate::init (this=0xab8950, c=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:106
#18 0x00007f182582959d in AudioOutput (this=0xa7b8f0, category=Phonon::NotificationCategory, parent=0x0) at ../3rdparty/phonon/phonon/audiooutput.cpp:76
#19 0x000000000040d101 in Player (this=0xa4b0e8) at ../../knotify/notifybysound.cpp:59
#20 PlayerPool::getPlayer (this=0xa4b0e8) at ../../knotify/notifybysound.cpp:99
#21 0x000000000040d63e in NotifyBySound::notify (this=0xa3b650, eventId=6, config=0x7fff8e6bd2a0) at ../../knotify/notifybysound.cpp:243
#22 0x0000000000408d63 in KNotify::emitEvent (this=0x7fff8e6be5a0, e=0xa22670) at ../../knotify/knotify.cpp:179
#23 0x0000000000409022 in KNotify::event (this=0x7fff8e6be5a0, event=<value optimized out>, appname=<value optimized out>, contexts=<value optimized out>, title=<value optimized out>, 
    text=<value optimized out>, image=..., actions=..., timeout=-1, winId=0) at ../../knotify/knotify.cpp:128
#24 0x000000000040935f in KNotifyAdaptor::event (this=0xa383e0, event=..., fromApp=..., contexts=<value optimized out>, title=..., text=<value optimized out>, image=..., actions=..., timeout=-1, 
    winId=0) at ../../knotify/knotify.cpp:236
#25 0x000000000040a03b in KNotifyAdaptor::qt_metacall (this=0xa383e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8e6bd830) at ./knotify.moc:227
#26 0x00007f1825115486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#27 0x00007f182511674b in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0xa383e0, flags=273, msg=...) at qdbusintegrator.cpp:816
#28 0x00007f18251171cd in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1364
#29 0x00007f1825117468 in QDBusActivateObjectEvent::placeMetaCall (this=0x97de80) at qdbusintegrator.cpp:1477
#30 0x00007f1824debd49 in QObject::event (this=0x7fff8e6be5a0, e=0x97de80) at kernel/qobject.cpp:1248
#31 0x00007f182419522c in QApplicationPrivate::notify_helper (this=0x993190, receiver=0x7fff8e6be5a0, e=0x97de80) at kernel/qapplication.cpp:4300
#32 0x00007f182419b6fb in QApplication::notify (this=0x7fff8e6be5d0, receiver=0x7fff8e6be5a0, e=0x97de80) at kernel/qapplication.cpp:4183
#33 0x00007f1825c96526 in KApplication::notify (this=0x7fff8e6be5d0, receiver=0x7fff8e6be5a0, event=0x97de80) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x00007f1824ddc06c in QCoreApplication::notifyInternal (this=0x7fff8e6be5d0, receiver=0x7fff8e6be5a0, event=0x97de80) at kernel/qcoreapplication.cpp:704
#35 0x00007f1824dde7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x96fff0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x96fff0) at kernel/qcoreapplication.cpp:1345
#37 0x00007f1824e059d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007f1820a228c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x00007f1820a26748 in ?? () from /lib/libglib-2.0.so.0
#41 0x00007f1820a268fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0x00007f1824e05513 in QEventDispatcherGlib::processEvents (this=0x96fb30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#43 0x00007f182424546e in QGuiEventDispatcherGlib::processEvents (this=0xbd0860, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007f1824dda992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#45 0x00007f1824ddad6c in QEventLoop::exec (this=0x7fff8e6be4f0, flags=) at kernel/qeventloop.cpp:201
#46 0x00007f1824ddeaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#47 0x0000000000407f4f in main (argc=<value optimized out>, argv=<value optimized out>) at ../../knotify/main.cpp:73

Possible duplicates by query: bug 238918, bug 237744, bug 237442, bug 236928, bug 236266.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-05-31 12:03:03 UTC

*** This bug has been marked as a duplicate of bug 232068 ***