Bug 238704 - Crash on the editing.
Summary: Crash on the editing.
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-24 17:48 UTC by Neroslavsky Alexander
Modified: 2010-07-01 23:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neroslavsky Alexander 2010-05-24 17:48:22 UTC
Application: krusader (2.0.0 "Mars Pathfinder")
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33-ARCH i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
At the end of the file i had press the backspace and krusader's editor crashes. 

 -- Backtrace:
Application: Krusader (krusader), signal: Segmentation fault
[KCrash Handler]
#6  0x95028605 in KateLineLayout::viewLineCount() const () from /usr/lib/kde4/katepart.so
#7  0x9502482c in KateLayoutCache::viewLine(KTextEditor::Cursor const&) () from /usr/lib/kde4/katepart.so
#8  0x95024a3f in KateLayoutCache::textLayout(KTextEditor::Cursor const&) () from /usr/lib/kde4/katepart.so
#9  0x95085f88 in KateViewInternal::makeVisible(KTextEditor::Cursor const&, int, bool, bool, bool) () from /usr/lib/kde4/katepart.so
#10 0x9508a178 in KateViewInternal::updateCursor(KTextEditor::Cursor const&, bool, bool, bool) () from /usr/lib/kde4/katepart.so
#11 0x9508a26b in KateViewInternal::editEnd(int, int, bool) () from /usr/lib/kde4/katepart.so
#12 0x9506cc69 in KateView::editEnd(int, int, bool) () from /usr/lib/kde4/katepart.so
#13 0x94fecde4 in KateDocument::editEnd() () from /usr/lib/kde4/katepart.so
#14 0x94ff7d1c in KateDocument::removeText(KTextEditor::Range const&, bool) () from /usr/lib/kde4/katepart.so
#15 0x94ff5771 in KateDocument::backspace(KateView*, KTextEditor::Cursor const&) () from /usr/lib/kde4/katepart.so
#16 0x95080001 in KateViewInternal::doBackspace() () from /usr/lib/kde4/katepart.so
#17 0x9506fa11 in KateView::backspace() () from /usr/lib/kde4/katepart.so
#18 0x95073764 in KateView::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/katepart.so
#19 0xb58046ea in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#20 0xb5813715 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#21 0xb5b4d399 in QAction::triggered(bool) () from /usr/lib/libQtGui.so.4
#22 0xb5b4d5fb in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQtGui.so.4
#23 0xb5b4d7a8 in QAction::event(QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb6f886c3 in KAction::event(QEvent*) () from /usr/lib/libkdeui.so.5
#25 0xb5b545f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb5b587ee in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb70571ba in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#28 0xb57fe7db in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#29 0xb5b89bd7 in ?? () from /usr/lib/libQtGui.so.4
#30 0xb5b8b0b7 in ?? () from /usr/lib/libQtGui.so.4
#31 0xb5b5a794 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#32 0xb70571ba in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#33 0xb57fe7db in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#34 0xb5b51f5e in ?? () from /usr/lib/libQtGui.so.4
#35 0xb5bfd3cd in ?? () from /usr/lib/libQtGui.so.4
#36 0xb5bfd7d1 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb5bd8292 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#38 0xb5c00892 in ?? () from /usr/lib/libQtGui.so.4
#39 0xb4de3f72 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0xb4de4750 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#41 0xb4de4a04 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0xb582957c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#43 0xb5c004d5 in ?? () from /usr/lib/libQtGui.so.4
#44 0xb57fda29 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0xb57fdc9a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0xb58024cf in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#47 0xb5b51d17 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#48 0x08093761 in _start ()

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-07-01 23:15:33 UTC

*** This bug has been marked as a duplicate of bug 226409 ***