Bug 241487 - Plasma crashes after Kopete is closed or crashes
Summary: Plasma crashes after Kopete is closed or crashes
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-12 02:05 UTC by Raúl A V
Modified: 2010-06-12 10:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl A V 2010-06-12 02:05:44 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Plasma crashes after Kopete is closed or crashes
Plasma crashes after Kopete is closed or crashes

 -- Backtrace:
Application: Área de trabajo de Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f142e78b760 (LWP 1943))]

Thread 3 (Thread 0x7f1403863710 (LWP 1944)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f1403862aa0 in ?? ()
#2  0x00007fffbefff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f13fad8a710 (LWP 1958)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1424429ca6 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f1424429ce9 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f142c9d09ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f142b7836cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f142e78b760 (LWP 1943)):
[KCrash Handler]
#5  0x00007f142d2580f7 in QString (this=0x48, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#6  KIconEffect::fingerprint (this=0x48, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#7  0x00007f142d263e68 in KIconLoader::loadIcon (this=0x5d01790, _name=..., group=<value optimized out>, size=18, state=<value optimized out>, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#8  0x00007f142d25c5fc in KIconEngine::actualSize (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>)
    at ../../kdeui/icons/kiconengine.cpp:80
#9  0x00007f142bfa326c in QIcon::actualSize (this=<value optimized out>, size=..., mode=QIcon::Normal, state=QIcon::On) at image/qicon.cpp:700
#10 0x00007f14258097b7 in Plasma::IconWidgetPrivate::decoration (this=0x5deb060, option=<value optimized out>, useHoverEffect=true, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#11 0x00007f142580ae1c in Plasma::IconWidget::paint (this=0x3e109c0, painter=0x7fffbefac330, option=0x14f6be8, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1013
#12 0x00007f142c4fd81a in _q_paintItem (item=<value optimized out>, painter=0x7fffbefac330, option=0x14f6be8, widget=0x0, useWindowOpacity=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4243
#13 0x00007f142c4fdaac in _q_paintIntoCache (pix=0x7fffbefac9c0, item=<value optimized out>, pixmapExposed=..., itemToPixmap=<value optimized out>, renderHints=)
    at graphicsview/qgraphicsscene.cpp:4281
#14 0x00007f142c511d33 in QGraphicsScenePrivate::drawItemHelper (this=<value optimized out>, item=0x3e109d0, painter=0x7fffbefae930, option=0x14f6be8, widget=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4574
#15 0x00007f142c512625 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x3e109d0, painter=0x7fffbefae930, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x19b1000, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4827
#16 0x00007f142c513272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x3e109d0, painter=0x7fffbefae930, viewTransform=0x7fffbefae6e0, exposedRegion=0x2d0edf0, 
    widget=0x19b1000, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#17 0x00007f142c5126c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x22018d0, painter=0x7fffbefae930, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x19b1000, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#18 0x00007f142c513272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x22018d0, painter=0x7fffbefae930, viewTransform=0x7fffbefae6e0, exposedRegion=0x2d0edf0, 
    widget=0x19b1000, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#19 0x00007f142c5126c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x21d1ef0, painter=0x7fffbefae930, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x19b1000, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#20 0x00007f142c513272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x21d1ef0, painter=0x7fffbefae930, viewTransform=0x7fffbefae6e0, exposedRegion=0x2d0edf0, 
    widget=0x19b1000, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#21 0x00007f142c5126c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x21f30c0, painter=0x7fffbefae930, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x19b1000, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#22 0x00007f142c513272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x21f30c0, painter=0x7fffbefae930, viewTransform=0x7fffbefae6e0, exposedRegion=0x2d0edf0, 
    widget=0x19b1000, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#23 0x00007f142c513c34 in QGraphicsScenePrivate::drawItems (this=0x14f6990, painter=0x7fffbefae930, viewTransform=0x7fffbefae6e0, exposedRegion=0x2d0edf0, widget=0x19b1000)
    at graphicsview/qgraphicsscene.cpp:4619
#24 0x00007f142c533465 in QGraphicsView::paintEvent (this=0x21e34c0, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3393
#25 0x00007f1420592b09 in PanelView::paintEvent (this=0x7fffbefab9a0, event=0x48) at ../../../../plasma/desktop/shell/panelview.cpp:1300
#26 0x00007f142bf47162 in QWidget::event (this=0x21e34c0, event=0x7fffbefaf270) at kernel/qwidget.cpp:8144
#27 0x00007f142c2ee4e6 in QFrame::event (this=0x21e34c0, e=0x7fffbefaf270) at widgets/qframe.cpp:557
#28 0x00007f142c52ff0b in QGraphicsView::viewportEvent (this=0x21e34c0, event=0x7fffbefaf270) at graphicsview/qgraphicsview.cpp:2787
#29 0x00007f142cd54487 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x19b1000, event=0x7fffbefaf270) at kernel/qcoreapplication.cpp:819
#30 0x00007f142bef11fc in QApplicationPrivate::notify_helper (this=0x141acb0, receiver=0x19b1000, e=0x7fffbefaf270) at kernel/qapplication.cpp:4296
#31 0x00007f142bef76fb in QApplication::notify (this=0x1404810, receiver=0x19b1000, e=0x7fffbefaf270) at kernel/qapplication.cpp:4183
#32 0x00007f142d29c606 in KApplication::notify (this=0x1404810, receiver=0x19b1000, event=0x7fffbefaf270) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007f142cd5506c in QCoreApplication::notifyInternal (this=0x1404810, receiver=0x19b1000, event=0x7fffbefaf270) at kernel/qcoreapplication.cpp:704
#34 0x00007f142bf4f7dd in QCoreApplication::sendSpontaneousEvent (this=0x1a275b0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x18d27e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 QWidgetPrivate::drawWidget (this=0x1a275b0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x18d27e0)
    at kernel/qwidget.cpp:5339
#36 0x00007f142bf50478 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x18d27e0) at kernel/qwidget.cpp:5452
#37 0x00007f142bf4f53a in QWidgetPrivate::drawWidget (this=0x2d0e930, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x18d27e0) at kernel/qwidget.cpp:5388
#38 0x00007f142c1098c5 in QWidgetBackingStore::sync (this=0x18d27e0) at painting/qbackingstore.cpp:1291
#39 0x00007f142bf40b60 in QWidgetPrivate::syncBackingStore (this=0x2d0e930) at kernel/qwidget.cpp:1672
#40 0x00007f142bf47865 in QWidget::event (this=0x21e34c0, event=0x5b54ad0) at kernel/qwidget.cpp:8291
#41 0x00007f142c2ee4e6 in QFrame::event (this=0x21e34c0, e=0x5b54ad0) at widgets/qframe.cpp:557
#42 0x00007f142c3798ab in QAbstractScrollArea::event (this=0x21e34c0, e=0x5b54ad0) at widgets/qabstractscrollarea.cpp:989
#43 0x00007f1420595590 in PanelView::event (this=0x21e34c0, event=0x5b54ad0) at ../../../../plasma/desktop/shell/panelview.cpp:1314
#44 0x00007f142bef122c in QApplicationPrivate::notify_helper (this=0x141acb0, receiver=0x21e34c0, e=0x5b54ad0) at kernel/qapplication.cpp:4300
#45 0x00007f142bef76fb in QApplication::notify (this=0x1404810, receiver=0x21e34c0, e=0x5b54ad0) at kernel/qapplication.cpp:4183
#46 0x00007f142d29c606 in KApplication::notify (this=0x1404810, receiver=0x21e34c0, event=0x5b54ad0) at ../../kdeui/kernel/kapplication.cpp:302
#47 0x00007f142cd5506c in QCoreApplication::notifyInternal (this=0x1404810, receiver=0x21e34c0, event=0x5b54ad0) at kernel/qcoreapplication.cpp:704
#48 0x00007f142cd577e7 in QCoreApplication::sendEvent (receiver=0x21e34c0, event_type=<value optimized out>, data=0x1390c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x21e34c0, event_type=<value optimized out>, data=0x1390c30) at kernel/qcoreapplication.cpp:1345
#50 0x00007f142c51ab7a in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x14f6990) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#51 QGraphicsScenePrivate::_q_processDirtyItems (this=0x14f6990) at graphicsview/qgraphicsscene.cpp:509
#52 0x00007f142c51b102 in QGraphicsScene::qt_metacall (this=0x1474410, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x54c37b0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#53 0x00007f1425759df5 in Plasma::Corona::qt_metacall (this=0x7fffbefab9a0, _c=72, _id=0, _a=0x0) at ./corona.moc:107
#54 0x00007f1420584bd3 in DesktopCorona::qt_metacall (this=0x7fffbefab9a0, _c=72, _id=0, _a=0x0) at ./desktopcorona.moc:86
#55 0x00007f142cd64d49 in QObject::event (this=0x1474410, e=0x37cb840) at kernel/qobject.cpp:1248
#56 0x00007f142c516d80 in QGraphicsScene::event (this=0x1474410, event=0x37cb840) at graphicsview/qgraphicsscene.cpp:3500
#57 0x00007f142bef122c in QApplicationPrivate::notify_helper (this=0x141acb0, receiver=0x1474410, e=0x37cb840) at kernel/qapplication.cpp:4300
#58 0x00007f142bef76fb in QApplication::notify (this=0x1404810, receiver=0x1474410, e=0x37cb840) at kernel/qapplication.cpp:4183
#59 0x00007f142d29c606 in KApplication::notify (this=0x1404810, receiver=0x1474410, event=0x37cb840) at ../../kdeui/kernel/kapplication.cpp:302
#60 0x00007f142cd5506c in QCoreApplication::notifyInternal (this=0x1404810, receiver=0x1474410, event=0x37cb840) at kernel/qcoreapplication.cpp:704
#61 0x00007f142cd577e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1390c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1390c30) at kernel/qcoreapplication.cpp:1345
#63 0x00007f142cd7e9d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#65 0x00007f14281378c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#66 0x00007f142813b748 in ?? () from /lib/libglib-2.0.so.0
#67 0x00007f142813b8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#68 0x00007f142cd7e513 in QEventDispatcherGlib::processEvents (this=0x1392140, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#69 0x00007f142bfa146e in QGuiEventDispatcherGlib::processEvents (this=0x7fffbefab9a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#70 0x00007f142cd53992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#71 0x00007f142cd53d6c in QEventLoop::exec (this=0x7fffbefb1360, flags=) at kernel/qeventloop.cpp:201
#72 0x00007f142cd57aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#73 0x00007f142058bfb2 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:112
#74 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#75 0x0000000000407cb0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#76 0x000000000040823a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#77 0x0000000000408e22 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 226596.

Possible duplicates by query: bug 238133, bug 237830, bug 234299, bug 232784, bug 232279.

Reported using DrKonqi
Comment 1 Marco Martin 2010-06-12 10:59:03 UTC

*** This bug has been marked as a duplicate of bug 226596 ***