Bug 237830 - plasma desktop 20100516 kcrash
Summary: plasma desktop 20100516 kcrash
Status: RESOLVED DUPLICATE of bug 234299
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-16 15:47 UTC by Wassermann
Modified: 2010-05-19 09:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wassermann 2010-05-16 15:47:49 UTC
Version:            (using KDE 4.4.2)
Compiler:          gcc 4.4.3 Ubuntu 4.4.3.-4ubuntu5
OS:                Linux
Installed from:    Ubuntu Packages

Application: Plasma-Arbeitsfläche (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb774daa0 (LWP 1337))]

Thread 2 (Thread 0xa9759b70 (LWP 1340)):
#0  0x00310422 in __kernel_vsyscall ()
#1  0x00cabb86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x079074eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x078fa0ac in ?? () from /lib/libglib-2.0.so.0
#4  0x078fa4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0072660f in QEventDispatcherGlib::processEvents (this=0x9d8fd18, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x006f9059 in QEventLoop::processEvents (this=0xa9759290, flags=) at kernel/qeventloop.cpp:149
#7  0x006f94aa in QEventLoop::exec (this=0xa9759290, flags=...) at kernel/qeventloop.cpp:201
#8  0x005f55a8 in QThread::exec (this=0x9d72230) at thread/qthread.cpp:487
#9  0x006d8c1b in QInotifyFileSystemWatcherEngine::run (this=0x9d72230) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x005f832e in QThreadPrivate::start (arg=0x9d72230) at thread/qthread_unix.cpp:248
#11 0x001e896e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x00cb9a0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb774daa0 (LWP 1337)):
[KCrash Handler]
#6  0x010662c6 in QString (this=0x17, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x17, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x01072a54 in KIconLoader::loadIcon (this=0xa5121f0, _name=..., group=KIconLoader::Desktop, size=22, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0x0106abf8 in KIconEngine::actualSize (this=0xa5cde08, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0x06da74b6 in QIcon::actualSize (this=0xa5bfb14, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0x01650dc3 in Plasma::IconWidgetPrivate::decoration (this=0xa5bfa98, option=0x9684e90, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0x016529d7 in Plasma::IconWidget::paint (this=0x9ff4df0, painter=0xbfd2a66c, option=0x9684e90, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0x0737af2c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x9684e90, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0x0737db1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9684e90, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0x07397620 in QGraphicsScenePrivate::drawItemHelper (this=0x9684d30, item=0x9ff4df8, painter=0xbfd2c494, option=0x9684e90, widget=0x9dee6e0, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0x07398044 in QGraphicsScenePrivate::draw (this=0x9684d30, item=0x9ff4df8, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, transformPtr=0xbfd2b050, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0x07398cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9684d30, item=0x9ff4df8, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0x073980d4 in QGraphicsScenePrivate::draw (this=0x9684d30, item=0x99fb160, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, transformPtr=0xbfd2b550, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0x07398cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9684d30, item=0x99fb160, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0x073980d4 in QGraphicsScenePrivate::draw (this=0x9684d30, item=0x9987808, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, transformPtr=0xbfd2ba50, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0x07398cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9684d30, item=0x9987808, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0x073980d4 in QGraphicsScenePrivate::draw (this=0x9684d30, item=0x98a27a8, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, transformPtr=0xbfd2bf50, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0x07398cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9684d30, item=0x98a27a8, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, exposedRegion=0x9cab434, widget=0x9dee6e0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0x073996be in QGraphicsScenePrivate::drawItems (this=0x9684d30, painter=0xbfd2c494, viewTransform=0xbfd2c2cc, exposedRegion=0x9cab434, widget=0x9dee6e0) at graphicsview/qgraphicsscene.cpp:4619
#25 0x073b3beb in QGraphicsView::paintEvent (this=0x9cbfa30, event=0xbfd2cbb4) at graphicsview/qgraphicsview.cpp:3393
#26 0x076a3c79 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#27 0x06d436b6 in QWidget::event (this=0x9cbfa30, event=0xbfd2cbb4) at kernel/qwidget.cpp:8144
#28 0x0713ffd3 in QFrame::event (this=0x9cbfa30, e=0xbfd2cbb4) at widgets/qframe.cpp:557
#29 0x071da382 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x17) at widgets/qabstractscrollarea.cpp:1036
#30 0x073b006b in QGraphicsView::viewportEvent (this=0x9cbfa30, event=0xbfd2cbb4) at graphicsview/qgraphicsview.cpp:2787
#31 0x071dcc65 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9d49fd8, o=0x9dee6e0, e=0xbfd2cbb4) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9d49fd8, o=0x9dee6e0, e=0xbfd2cbb4) at widgets/qabstractscrollarea_p.h:116
#33 0x006f9cda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x95d0360, receiver=0x9dee6e0, event=0xbfd2cbb4) at kernel/qcoreapplication.cpp:819
#34 0x06ce54b9 in QApplicationPrivate::notify_helper (this=0x95d0360, receiver=0x9dee6e0, e=0xbfd2cbb4) at kernel/qapplication.cpp:4296
#35 0x06cec0f9 in QApplication::notify (this=0x95ca1a8, receiver=0x9dee6e0, e=0xbfd2cbb4) at kernel/qapplication.cpp:4265
#36 0x010aff2a in KApplication::notify (this=0x95ca1a8, receiver=0x9dee6e0, event=0xbfd2cbb4) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x006faa3b in QCoreApplication::notifyInternal (this=0x95ca1a8, receiver=0x9dee6e0, event=0xbfd2cbb4) at kernel/qcoreapplication.cpp:704
#38 0x06d4c9d6 in QCoreApplication::sendSpontaneousEvent (this=0x9ae7c48, pdev=0x9ded0a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9b593e8)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x9ae7c48, pdev=0x9ded0a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9b593e8) at kernel/qwidget.cpp:5339
#40 0x06d4d815 in QWidgetPrivate::paintSiblingsRecursive (this=0x9cab0d0, pdev=0x9ded0a4, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9b593e8)
    at kernel/qwidget.cpp:5452
#41 0x06d4d64e in QWidgetPrivate::paintSiblingsRecursive (this=0x9cab0d0, pdev=0x9ded0a4, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9b593e8)
    at kernel/qwidget.cpp:5439
#42 0x06d4c725 in QWidgetPrivate::drawWidget (this=0x9cab0d0, pdev=0x9ded0a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9b593e8) at kernel/qwidget.cpp:5388
#43 0x06f23890 in QWidgetBackingStore::sync (this=0x9b593e8) at painting/qbackingstore.cpp:1291
#44 0x06d3cb93 in QWidgetPrivate::syncBackingStore (this=0x9cab0d0) at kernel/qwidget.cpp:1672
#45 0x06d43e76 in QWidget::event (this=0x9cbfa30, event=0x9f4ac10) at kernel/qwidget.cpp:8291
#46 0x0713ffd3 in QFrame::event (this=0x9cbfa30, e=0x9f4ac10) at widgets/qframe.cpp:557
#47 0x071dad97 in QAbstractScrollArea::event (this=0x9cbfa30, e=0x9f4ac10) at widgets/qabstractscrollarea.cpp:989
#48 0x073b2216 in QGraphicsView::event (this=0x9cbfa30, event=0x9f4ac10) at graphicsview/qgraphicsview.cpp:2666
#49 0x076a4613 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#50 0x06ce54dc in QApplicationPrivate::notify_helper (this=0x95d0360, receiver=0x9f4ac10, e=0x9cbfa30) at kernel/qapplication.cpp:4300
#51 0x06cec0f9 in QApplication::notify (this=0x95ca1a8, receiver=0x9cbfa30, e=0x9f4ac10) at kernel/qapplication.cpp:4265
#52 0x010aff2a in KApplication::notify (this=0x95ca1a8, receiver=0x9cbfa30, event=0x9f4ac10) at ../../kdeui/kernel/kapplication.cpp:302
#53 0x006faa3b in QCoreApplication::notifyInternal (this=0x95ca1a8, receiver=0x9cbfa30, event=0x9f4ac10) at kernel/qcoreapplication.cpp:704
#54 0x006fd473 in QCoreApplication::sendEvent (receiver=0x9cbfa30, event_type=77, data=0x9569fc8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9cbfa30, event_type=77, data=0x9569fc8) at kernel/qcoreapplication.cpp:1345
#56 0x006fd5dd in QCoreApplication::sendPostedEvents (receiver=0x9cbfa30, event_type=77) at kernel/qcoreapplication.cpp:1238
#57 0x07395326 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x9684d30) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#58 QGraphicsScenePrivate::_q_processDirtyItems (this=0x9684d30) at graphicsview/qgraphicsscene.cpp:509
#59 0x07395876 in QGraphicsScene::qt_metacall (this=0x968e6d8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xa1779b8) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#60 0x0158fd3a in Plasma::Corona::qt_metacall (this=0x968e6d8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa1779b8) at ./corona.moc:107
#61 0x07693fad in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#62 0x006ffc9a in QMetaObject::metacall (object=0x968e6d8, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x0) at kernel/qmetaobject.cpp:237
#63 0x0070a336 in QMetaCallEvent::placeMetaCall (this=0xa0012d8, object=0x968e6d8) at kernel/qobject.cpp:561
#64 0x0070b3fe in QObject::event (this=0x968e6d8, e=0xa0012d8) at kernel/qobject.cpp:1248
#65 0x07391554 in QGraphicsScene::event (this=0x968e6d8, event=0xa0012d8) at graphicsview/qgraphicsscene.cpp:3500
#66 0x06ce54dc in QApplicationPrivate::notify_helper (this=0x95d0360, receiver=0x968e6d8, e=0xa0012d8) at kernel/qapplication.cpp:4300
#67 0x06cec05e in QApplication::notify (this=0x95ca1a8, receiver=0x968e6d8, e=0xa0012d8) at kernel/qapplication.cpp:3704
#68 0x010aff2a in KApplication::notify (this=0x95ca1a8, receiver=0x968e6d8, event=0xa0012d8) at ../../kdeui/kernel/kapplication.cpp:302
#69 0x006faa3b in QCoreApplication::notifyInternal (this=0x95ca1a8, receiver=0x968e6d8, event=0xa0012d8) at kernel/qcoreapplication.cpp:704
#70 0x006fd473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9569fc8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#71 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9569fc8) at kernel/qcoreapplication.cpp:1345
#72 0x006fd5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#73 0x00726adf in QCoreApplication::sendPostedEvents (s=0x95d2510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#74 postEventSourceDispatch (s=0x95d2510) at kernel/qeventdispatcher_glib.cpp:276
#75 0x078f65e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#76 0x078fa2d8 in ?? () from /lib/libglib-2.0.so.0
#77 0x078fa4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#78 0x007265d5 in QEventDispatcherGlib::processEvents (this=0x95d0030, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#79 0x06da5135 in QGuiEventDispatcherGlib::processEvents (this=0x95d0030, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#80 0x006f9059 in QEventLoop::processEvents (this=0xbfd2e5d4, flags=) at kernel/qeventloop.cpp:149
#81 0x006f94aa in QEventLoop::exec (this=0xbfd2e5d4, flags=...) at kernel/qeventloop.cpp:201
#82 0x006fd69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#83 0x06ce5577 in QApplication::exec () at kernel/qapplication.cpp:3579
#84 0x0769c05e in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#85 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x95a0388 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#86 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#87 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#88 0x0804fe4f in main (argc=4, argv=0xbfd2f084, envp=0xbfd2f098) at ../../kinit/kinit.cpp:1845
Comment 1 Beat Wolf 2010-05-19 09:26:30 UTC

*** This bug has been marked as a duplicate of bug 234299 ***