Bug 236069 - When I try to write a blu ray disc k3b says please insert media with greater capacity, even with a media size of 25 gigs and a compliation size of 17 gigs
Summary: When I try to write a blu ray disc k3b says please insert media with greater ...
Status: RESOLVED FIXED
Alias: None
Product: k3b
Classification: Unclassified
Component: general (show other bugs)
Version: 1.91.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 2.0
Assignee: Michał Małek
URL:
Keywords:
: 227339 229039 237324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-02 21:06 UTC by cjae
Modified: 2010-05-26 15:40 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.92.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cjae 2010-05-02 21:06:53 UTC
Version:           1.91.0 (using KDE 4.4.2)
OS:                Linux
Installed from:    Ubuntu Packages

It s an LG BD-RE  WH08LS20 bluray burner and 25 GB sonik data media. Seems that no matter the compilation size the disc will not be recognized. I am just trying to backup random data.

Using Kubuntu 10.04 and kde 4.4.2 and k3b 1.91.0
Comment 1 Sebastian Trueg 2010-05-05 11:49:07 UTC
Does K3b properly detect the media size? You can check that via right-click -> media info.
Comment 2 Christian Muehlhaeuser 2010-05-10 17:46:18 UTC
That's the info I get to see under "Media Info". It's also notable that the "Available Space" indicator at the bottom of the mainwindow behaves fine when adding stuff to my current project. (e.g. shows 5,0 GiB of 23,3GiB)

Type:	BD-R Sequential (SRM)
Capacity:	2715:25:17 min (23,3 GiB)
Rewritable:	no
Appendable:	no
Empty:	yes
Layers:	1
Sessions:	0
Supported writing speeds:	2.0x (8991 KB/s)
4.0x (17982 KB/s)
Comment 3 Michał Małek 2010-05-11 00:42:52 UTC
I've had a debugging session with Christian today and I think we disovered the issue. Device::writeCapabilities() doesn't contain MEDIA_BD_R_SRM. Since that's the medium which is inserted to the burner it doesn't get detected in EmptyDiscWaiter.
Now, why Device::writeCapabilities() doesn't contain MEDIA_BD_R_SRM? Looks like nowhere in k3bdevice.cpp d->writeCapabilities is OR-ed with this flag. Maybe it should in line k3bdevice.cpp:2776, but we weren't sure. It probably is the same issue for MEDIA_BD_R_SRM_POW and MEDIA_BD_R_RRM. For plain MEDIA_BD_R it will work, maybe that's why it worked for Sebastian.
Comment 4 Sebastian Trueg 2010-05-11 16:49:18 UTC
SVN commit 1125491 by trueg:

Properly set writeCapabilities for BD devices.

BUG: 236069


 M  +3 -1      k3bdevice.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1125491
Comment 5 Michał Małek 2010-05-13 12:57:28 UTC
*** Bug 237324 has been marked as a duplicate of this bug. ***
Comment 6 Tim Nelson 2010-05-13 13:53:38 UTC
Ok, I tried this, and it gets past that stage now.  I still can't burn, but I'll post that at http://forum.kde.org/viewtopic.php?f=153&t=85895&p=158221#p158221 since I'm not sure my other problem is a bug.
Comment 7 Michał Małek 2010-05-13 22:26:52 UTC
*** Bug 227339 has been marked as a duplicate of this bug. ***
Comment 8 Michał Małek 2010-05-13 22:27:03 UTC
*** Bug 229039 has been marked as a duplicate of this bug. ***