Bug 234335 - Kate crashed after pressed Backspace
Summary: Kate crashed after pressed Backspace
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-14 13:19 UTC by Roman
Modified: 2010-04-14 19:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman 2010-04-14 13:19:28 UTC
Application: kwrite (4.4.1 (KDE 4.4.1))
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.30.10-105.2.4.fc11.i586 i686
Distribution: "Fedora release 11 (Leonidas)"

-- Information about the crash:
I opened a file, selected several lines at the end of the document and pressed Backspace to remove them, and Kate crashed

The crash does not seem to be reproducible.

 -- Backtrace:
Application: KWrite (kwrite), signal: Segmentation fault
[Current thread is 1 (Thread 0xb773e780 (LWP 4136))]

Thread 2 (Thread 0xb5d7cb70 (LWP 4138)):
#0  0x00d1e422 in __kernel_vsyscall ()
#1  0x00630f85 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x03a3baf7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3b0d5c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#3  0x03a3bb41 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x3b0d5c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#4  0x0062c8f5 in start_thread (arg=0xb5d7cb70) at pthread_create.c:297
#5  0x00558fce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb773e780 (LWP 4136)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at /usr/src/debug/kdelibs-4.4.1/kate/render/katelinelayout.cpp:173
#7  0x00fe1b0c in KateLayoutCache::viewLine (this=0x94d0ec8, realCursor=@0xbfb8c1f8) at /usr/src/debug/kdelibs-4.4.1/kate/render/katelayoutcache.cpp:395
#8  0x0104fbb2 in KateViewInternal::viewLineOffset (this=0x94cf508, virtualCursor=@0x94cf5a8, offset=0, keepX=false) at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:1351
#9  0x010533b5 in KateViewInternal::makeVisible (this=0x94cf508, c=@0x94cf5a8, endCol=-1, force=false, center=false, calledExternally=false)
    at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:663
#10 0x01053bd0 in KateViewInternal::updateCursor (this=0x94cf508, newCursor=@0x94cf558, force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:1914
#11 0x0105495b in KateViewInternal::editEnd (this=0x94cf508, editTagLineStart=911, editTagLineEnd=911, tagFrom=true) at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:3399
#12 0x01032e79 in KateView::editEnd (this=0x94c6d20, editTagLineStart=911, editTagLineEnd=911, tagFrom=<value optimized out>) at /usr/src/debug/kdelibs-4.4.1/kate/view/kateview.cpp:1602
#13 0x00f9a804 in KateDocument::editEnd (this=0x94c1a18) at /usr/src/debug/kdelibs-4.4.1/kate/document/katedocument.cpp:981
#14 0x00fa1a66 in KateDocument::removeText (this=0x94c1a18, _range=@0xbfb8c514, block=false) at /usr/src/debug/kdelibs-4.4.1/kate/document/katedocument.cpp:825
#15 0x00fa37ad in KateDocument::backspace (this=0x94c1a18, view=0x94c6d20, c=@0x94cf558) at /usr/src/debug/kdelibs-4.4.1/kate/document/katedocument.cpp:2910
#16 0x010484c1 in KateViewInternal::doBackspace (this=0x94cf508) at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:854
#17 0x0103630c in KateView::backspace (this=0x94c6d20) at /usr/src/debug/kdelibs-4.4.1/kate/view/kateview.cpp:2295
#18 0x0103b1a4 in KateView::qt_metacall (this=0x94c6d20, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbfb8c708) at /usr/src/debug/kdelibs-4.4.1/i586-redhat-linux-gnu/kate/kateview.moc:373
#19 0x079f65ea in QMetaObject::metacall (object=0x94c6d20, cl=QMetaObject::ReadProperty, idx=90, argv=0xbfb8c708) at kernel/qmetaobject.cpp:237
#20 0x07a04da5 in QMetaObject::activate (sender=0x95f33c0, m=0x2a62118, local_signal_index=1, argv=0xbfb8c708) at kernel/qobject.cpp:3293
#21 0x02136329 in QAction::triggered (this=0x95f33c0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x0213857c in QAction::activate (this=0x95f33c0, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x02139e98 in QAction::event (this=0x9402198, e=0x0) at kernel/qaction.cpp:1181
#24 0x055b0c03 in KAction::event (this=0x95f33c0, event=0xbfb8cc28) at /usr/src/debug/kdelibs-4.4.1/kdeui/actions/kaction.cpp:129
#25 0x0213cc4c in QApplicationPrivate::notify_helper (this=0x931c880, receiver=0x95f33c0, e=0xbfb8cc28) at kernel/qapplication.cpp:4300
#26 0x021438ee in QApplication::notify (this=0xbfb8db08, receiver=0x95f33c0, e=0xbfb8cc28) at kernel/qapplication.cpp:3704
#27 0x0569c48a in KApplication::notify (this=0xbfb8db08, receiver=0x95f33c0, event=0xbfb8cc28) at /usr/src/debug/kdelibs-4.4.1/kdeui/kernel/kapplication.cpp:302
#28 0x079f123b in QCoreApplication::notifyInternal (this=0xbfb8db08, receiver=0x95f33c0, event=0xbfb8cc28) at kernel/qcoreapplication.cpp:704
#29 0x0217ea8d in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qshortcutmap.cpp:879
#31 0x021808b6 in QShortcutMap::tryShortcutEvent (this=0x931c92c, o=0x94cf508, e=0xbfb8d0a4) at kernel/qshortcutmap.cpp:364
#32 0x0214568d in QApplication::notify (this=0xbfb8db08, receiver=0x94cf508, e=0xbfb8d0a4) at kernel/qapplication.cpp:3746
#33 0x0569c48a in KApplication::notify (this=0xbfb8db08, receiver=0x94cf508, event=0xbfb8d0a4) at /usr/src/debug/kdelibs-4.4.1/kdeui/kernel/kapplication.cpp:302
#34 0x079f123b in QCoreApplication::notifyInternal (this=0xbfb8db08, receiver=0x94cf508, event=0xbfb8d0a4) at kernel/qcoreapplication.cpp:704
#35 0x0213db5e in QCoreApplication::sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:5279
#37 0x021f5790 in QKeyMapper::sendKeyEvent (keyWidget=0x94cf508, grab=false, type=QEvent::KeyPress, code=16777219, modifiers={i = 0}, text=@0xbfb8d228, autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#38 0x021f7cb5 in QKeyMapperPrivate::translateKeyEvent (this=0x9343d38, keyWidget=0x94cf508, event=0xbfb8d76c, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x021ccb2f in QApplication::x11ProcessEvent (this=0xbfb8db08, event=0xbfb8d76c) at kernel/qapplication_x11.cpp:3399
#40 0x021faf8a in x11EventSourceDispatch (s=0x931faa8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x006b9308 in g_main_dispatch (context=<value optimized out>) at gmain.c:1824
#42 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2377
#43 0x006bc9e0 in g_main_context_iterate (context=0x931ec90, block=<value optimized out>, dispatch=1, self=0x931cac8) at gmain.c:2455
#44 0x006bcb13 in IA__g_main_context_iteration (context=0x931ec90, may_block=1) at gmain.c:2518
#45 0x07a1cf25 in QEventDispatcherGlib::processEvents (this=0x93068b8, flags={i = 36}) at kernel/qeventdispatcher_glib.cpp:412
#46 0x021faab5 in QGuiEventDispatcherGlib::processEvents (this=0x93068b8, flags={i = 36}) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x079ef849 in QEventLoop::processEvents (this=0xbfb8da64, flags={i = 36}) at kernel/qeventloop.cpp:149
#48 0x079efc9a in QEventLoop::exec (this=0xbfb8da64, flags={i = 0}) at kernel/qeventloop.cpp:201
#49 0x079f241f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#50 0x0213ccf7 in QApplication::exec () at kernel/qapplication.cpp:3579
#51 0x0011c5b3 in kdemain (argc=2, argv=0xbfb8de64) at /usr/src/debug/kdebase-4.4.1/apps/kwrite/kwritemain.cpp:691
#52 0x0804864b in main (argc=2, argv=0xbfb8de64) at /usr/src/debug/kdebase-4.4.1/i586-redhat-linux-gnu/apps/kwrite/kwrite_dummy.cpp:3

Possible duplicates by query: bug 233224, bug 233081, bug 231425, bug 231107, bug 228980.

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-04-14 19:43:31 UTC
fixed in KDE 4.5.

*** This bug has been marked as a duplicate of bug 226409 ***