Bug 231425 - KDevelop crashes when deleting last line from particular file
Summary: KDevelop crashes when deleting last line from particular file
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 4.0
Platform: Gentoo Packages Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-20 15:56 UTC by Jakub Caban
Modified: 2010-03-20 17:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The file causing crash (2.13 KB, text/plain)
2010-03-20 15:58 UTC, Jakub Caban
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Caban 2010-03-20 15:56:51 UTC
Version:           3.9.99 (using KDE 4.4.1)
Compiler:          gcc-4.4.3 
OS:                Linux
Installed from:    Gentoo Packages

When I delete last line from particular file (will attach full file) while editing it in KDevelop. Both selecting and "delete" and pressing backspace while on that line are causing this behavior.

I have both PHP plugins, upload plugin and CSS plugin.

Backtrace from GDB:

Application: KDevelop (kdevelop.bin), signal: Segmentation fault
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/libgobject-2.0.so.0.2200.4-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
[Current thread is 1 (Thread 0x7f3aaab7f760 (LWP 4244))]

Thread 4 (Thread 0x7f3a96b6f710 (LWP 4248)):
#0  0x00007f3aa72185f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f3aa74a2e11 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f3aa3f1341e in KDevelop::DUChainPrivate::CleanupThread::run() () from /usr/lib64/libkdevplatformlanguage.so.1
#3  0x00007f3aa74a1f15 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f3aa72138e4 in start_thread () from /lib/libpthread.so.0
#5  0x00007f3aa5901dfd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3a92194710 (LWP 4249)):
#0  0x00007f3aa721828c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f3aa74a2e9b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f3aa8ff26a6 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f3aa8ff4c0b in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f3aa8ff3197 in ThreadWeaver::ThreadRunHelper::run(ThreadWeaver::WeaverImpl*, ThreadWeaver::Thread*) () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f3aa8ff36f8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f3aa74a1f15 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f3aa72138e4 in start_thread () from /lib/libpthread.so.0
#8  0x00007f3aa5901dfd in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3a8b678710 (LWP 4253)):
#0  0x00007f3aa721828c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f3aa4acbdb6 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib64/qt4/libQtScript.so.4
#2  0x00007f3aa4acbdf9 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f3aa72138e4 in start_thread () from /lib/libpthread.so.0
#4  0x00007f3aa5901dfd in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3aaab7f760 (LWP 4244)):
[KCrash Handler]
#5  0x00007f3a8b76ce70 in KateLineLayout::viewLineCount() const () from /usr/lib64/kde4/katepart.so
#6  0x00007f3a8b76a412 in KateLayoutCache::viewLine(KTextEditor::Cursor const&) () from /usr/lib64/kde4/katepart.so
#7  0x00007f3a8b7cbd73 in KateViewInternal::viewLineOffset(KTextEditor::Cursor const&, int, bool) () from /usr/lib64/kde4/katepart.so
#8  0x00007f3a8b7cee7a in KateViewInternal::makeVisible(KTextEditor::Cursor const&, int, bool, bool, bool) () from /usr/lib64/kde4/katepart.so
#9  0x00007f3a8b7cf5d9 in KateViewInternal::updateCursor(KTextEditor::Cursor const&, bool, bool, bool) () from /usr/lib64/kde4/katepart.so
#10 0x00007f3a8b7d0198 in KateViewInternal::editEnd(int, int, bool) () from /usr/lib64/kde4/katepart.so
#11 0x00007f3a8b729e29 in KateDocument::editEnd() () from /usr/lib64/kde4/katepart.so
#12 0x00007f3a8b7309bf in KateDocument::removeText(KTextEditor::Range const&, bool) () from /usr/lib64/kde4/katepart.so
#13 0x00007f3a8b7324a8 in KateDocument::backspace(KateView*, KTextEditor::Cursor const&) () from /usr/lib64/kde4/katepart.so
#14 0x00007f3a8b7b6af4 in KateView::backspace() () from /usr/lib64/kde4/katepart.so
#15 0x00007f3a8b7bb2ed in KateView::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/kde4/katepart.so
#16 0x00007f3aa75a48af in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#17 0x00007f3aa67416c2 in QAction::triggered(bool) () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007f3aa67436cb in QAction::activate(QAction::ActionEvent) () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007f3aa6744f67 in QAction::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007f3aa7c7095d in KAction::event(QEvent*) () from /usr/lib64/libkdeui.so.5
#21 0x00007f3aa674768c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007f3aa674db6b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007f3aa7d41e96 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#24 0x00007f3aa7591f7b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#25 0x00007f3aa6782f29 in QShortcutMap::dispatchEvent(QKeyEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#26 0x00007f3aa6784cef in QShortcutMap::tryShortcutEvent(QObject*, QKeyEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00007f3aa674f66a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#28 0x00007f3aa7d41e96 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#29 0x00007f3aa7591f7b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#30 0x00007f3aa67ef1e7 in QKeyMapper::sendKeyEvent(QWidget*, bool, QEvent::Type, int, QFlags<Qt::KeyboardModifier>, QString const&, bool, int, unsigned int, unsigned int, unsigned int, bool*) ()
   from /usr/lib64/qt4/libQtGui.so.4
#31 0x00007f3aa67f1681 in QKeyMapperPrivate::translateKeyEvent(QWidget*, _XEvent const*, bool) () from /usr/lib64/qt4/libQtGui.so.4
#32 0x00007f3aa67cacb4 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#33 0x00007f3aa67f475a in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtGui.so.4
#34 0x00007f3aa076ef8b in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#35 0x00007f3aa0772890 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#36 0x00007f3aa07729c0 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#37 0x00007f3aa75baa83 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#38 0x00007f3aa67f435e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#39 0x00007f3aa7590912 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#40 0x00007f3aa7590ced in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#41 0x00007f3aa7594933 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#42 0x00000000004089f7 in main ()
Comment 1 Jakub Caban 2010-03-20 15:58:17 UTC
Created attachment 41783 [details]
The file causing crash

I had similar crashes on other files, but there I got like 5 crashes in a row trying to edit file, so it's a good opportunity to report with example.
Comment 2 Milian Wolff 2010-03-20 16:06:20 UTC
reassigning for now, will investigate later on. a file to reproduce - really awesome, thanks!
Comment 3 Dominik Haumann 2010-03-20 17:57:06 UTC
probably fixed for 4.5, see other bug report for further details.

*** This bug has been marked as a duplicate of bug 226409 ***