Bug 233081 - kwrite crash while deleting lines
Summary: kwrite crash while deleting lines
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-02 17:25 UTC by selth.blackwings
Modified: 2010-04-02 19:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description selth.blackwings 2010-04-02 17:25:11 UTC
Application: kwrite (4.4.1 (KDE 4.4.1))
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.10-90.fc12.x86_64 x86_64
Distribution: "Fedora release 12 (Constantine)"

-- Information about the crash:
I was deleting lines quickly by pressing backspace and kwrite crashed.

 -- Backtrace:
Application: KWrite (kwrite), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fd613401840 (LWP 25319))]

Thread 2 (Thread 0x7fd6084ed710 (LWP 25324)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003dedf274f6 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3dee200b20) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x0000003dedf27539 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x3dee20ebec) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00000039cd006a3a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00000039cc4de67d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd613401840 (LWP 25319)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at /usr/src/debug/kdelibs-4.4.1/kate/render/katelinelayout.cpp:173
#6  0x00007fd6085d363a in KateLayoutCache::viewLine (this=0x167f330, realCursor=...) at /usr/src/debug/kdelibs-4.4.1/kate/render/katelayoutcache.cpp:395
#7  0x00007fd60862ecf3 in KateViewInternal::viewLineOffset (this=0x167dfa0, virtualCursor=..., offset=0, keepX=<value optimized out>)
    at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:1351
#8  0x00007fd608631e5b in KateViewInternal::makeVisible (this=0x167dfa0, c=..., endCol=-1, force=false, center=<value optimized out>, calledExternally=false)
    at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:663
#9  0x00007fd6086325b9 in KateViewInternal::updateCursor (this=0x167dfa0, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:1914
#10 0x00007fd608633199 in KateViewInternal::editEnd (this=0x167dfa0, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at /usr/src/debug/kdelibs-4.4.1/kate/view/kateviewinternal.cpp:3399
#11 0x00007fd608594e51 in KateDocument::editEnd (this=0x1668b60) at /usr/src/debug/kdelibs-4.4.1/kate/document/katedocument.cpp:981
#12 0x00007fd60859bb40 in KateDocument::removeText (this=0x1668b60, _range=<value optimized out>, block=<value optimized out>) at /usr/src/debug/kdelibs-4.4.1/kate/document/katedocument.cpp:825
#13 0x00007fd60859d68a in KateDocument::backspace (this=0x1668b60, view=<value optimized out>, c=<value optimized out>) at /usr/src/debug/kdelibs-4.4.1/kate/document/katedocument.cpp:2910
#14 0x00007fd60861b18c in KateView::backspace (this=0x167b690) at /usr/src/debug/kdelibs-4.4.1/kate/view/kateview.cpp:2295
#15 0x00007fd60861f86d in KateView::qt_metacall (this=0x167b690, _c=InvokeMetaMethod, _id=51, _a=0x7ffffb5adb40) at /usr/src/debug/kdelibs-4.4.1/x86_64-redhat-linux-gnu/kate/kateview.moc:373
#16 0x0000003de516a2af in QMetaObject::activate (sender=0x1752f70, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffffb5adb40) at kernel/qobject.cpp:3293
#17 0x0000003c6d1a5b52 in QAction::triggered (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x0000003c6d1a728b in QAction::activate (this=0x1752f70, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x0000003c6d1a8347 in QAction::event (this=<value optimized out>, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x0000003d88d4bd7d in KAction::event (this=<value optimized out>, event=0x7ffffb5ae1b0) at /usr/src/debug/kdelibs-4.4.1/kdeui/actions/kaction.cpp:129
#21 0x0000003c6d1aa9dc in QApplicationPrivate::notify_helper (this=0x13ceae0, receiver=0x1752f70, e=0x7ffffb5ae1b0) at kernel/qapplication.cpp:4300
#22 0x0000003c6d1b0aab in QApplication::notify (this=<value optimized out>, receiver=0x1752f70, e=0x7ffffb5ae1b0) at kernel/qapplication.cpp:4183
#23 0x0000003d88e06846 in KApplication::notify (this=0x7ffffb5af760, receiver=0x1752f70, event=0x7ffffb5ae1b0) at /usr/src/debug/kdelibs-4.4.1/kdeui/kernel/kapplication.cpp:302
#24 0x0000003de515774c in QCoreApplication::notifyInternal (this=0x7ffffb5af760, receiver=0x1752f70, event=0x7ffffb5ae1b0) at kernel/qcoreapplication.cpp:704
#25 0x0000003c6d1ddae6 in sendEvent (this=<value optimized out>, e=0x7ffffb5ae7b0) at ../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7ffffb5ae7b0) at kernel/qshortcutmap.cpp:879
#27 0x0000003c6d1df997 in QShortcutMap::tryShortcutEvent (this=0x13cec08, o=<value optimized out>, e=0x7ffffb5ae7b0) at kernel/qshortcutmap.cpp:364
#28 0x0000003c6d1b25db in QApplication::notify (this=0x7ffffb5af760, receiver=0x167dfa0, e=0x7ffffb5ae7b0) at kernel/qapplication.cpp:3746
#29 0x0000003d88e06846 in KApplication::notify (this=0x7ffffb5af760, receiver=0x167dfa0, event=0x7ffffb5ae7b0) at /usr/src/debug/kdelibs-4.4.1/kdeui/kernel/kapplication.cpp:302
#30 0x0000003de515774c in QCoreApplication::notifyInternal (this=0x7ffffb5af760, receiver=0x167dfa0, event=0x7ffffb5ae7b0) at kernel/qcoreapplication.cpp:704
#31 0x0000003c6d24493a in QKeyMapper::sendKeyEvent (keyWidget=0x167dfa0, grab=<value optimized out>, type=KeyPress, code=16777219, modifiers=<value optimized out>, text=..., autorepeat=false, count=
    1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#32 0x0000003c6d246d50 in QKeyMapperPrivate::translateKeyEvent (this=<value optimized out>, keyWidget=0x167dfa0, event=<value optimized out>, grab=<value optimized out>)
    at kernel/qkeymapper_x11.cpp:1831
#33 0x0000003c6d220ee4 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7ffffb5af380) at kernel/qapplication_x11.cpp:3399
#34 0x0000003c6d249d82 in x11EventSourceDispatch (s=0x13d27d0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x0000003502a3923e in g_main_dispatch (context=0x13d1520) at gmain.c:1960
#36 IA__g_main_context_dispatch (context=0x13d1520) at gmain.c:2513
#37 0x0000003502a3cc28 in g_main_context_iterate (context=0x13d1520, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#38 0x0000003502a3cd4a in IA__g_main_context_iteration (context=0x13d1520, may_block=1) at gmain.c:2654
#39 0x0000003de517d063 in QEventDispatcherGlib::processEvents (this=0x13b4c60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#40 0x0000003c6d249a4e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x0000003de5156192 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x0000003de515645c in QEventLoop::exec (this=0x7ffffb5af6b0, flags=...) at kernel/qeventloop.cpp:201
#43 0x0000003de5158749 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#44 0x0000003d89a0d2ad in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-4.4.1/apps/kwrite/kwritemain.cpp:691
#45 0x00000039cc41eb1d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=<value optimized out>) at libc-start.c:226
#46 0x00000000004006c9 in _start ()

Possible duplicates by query: bug 231425, bug 231107, bug 228980, bug 226322, bug 224308.

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-04-02 19:21:39 UTC

*** This bug has been marked as a duplicate of bug 226409 ***