Bug 233224 - Kate crashes when deleting C code in Python file
Summary: Kate crashes when deleting C code in Python file
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-04 07:28 UTC by Lisa Miller
Modified: 2010-05-28 01:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lisa Miller 2010-04-04 07:28:29 UTC
Application: kate (3.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
I had some C code pasted into a Python file to copy it. I saved and tried to run it before realizing I hadn't deleted the C code. I went back to the file selected the C code with the mouse, hit backspace, and Kate was gone.

The file is not at all large, but I had been running some pretty cpu and memory heavy stuff from the terminal within Kate before this happened.

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f87520bf750 (LWP 15022))]

Thread 2 (Thread 0x7f873a9c9910 (LWP 15026)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f873c87d396 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f873cb5b220) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x00007f873c87d3d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f873cb692ec) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00007f874f0f7a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f8751a4880d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f87520bf750 (LWP 15022)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f873cebd2aa in KateLayoutCache::viewLine (this=0x1a598f0, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007f873cf1fd53 in KateViewInternal::viewLineOffset (this=0x2046e40, virtualCursor=..., offset=0, keepX=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:1351
#8  0x00007f873cf22eeb in KateViewInternal::makeVisible (this=0x2046e40, c=..., endCol=-1, force=false, center=<value optimized out>, calledExternally=false)
    at ../../kate/view/kateviewinternal.cpp:663
#9  0x00007f873cf23649 in KateViewInternal::updateCursor (this=0x2046e40, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x00007f873cf24229 in KateViewInternal::editEnd (this=0x2046e40, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3399
#11 0x00007f873ce7bb71 in KateDocument::editEnd (this=0xb24640) at ../../kate/document/katedocument.cpp:977
#12 0x00007f873ce82926 in KateDocument::removeText (this=0xb24640, _range=<value optimized out>, block=<value optimized out>) at ../../kate/document/katedocument.cpp:821
#13 0x00007f873ce8449a in KateDocument::backspace (this=0xb24640, view=<value optimized out>, c=<value optimized out>) at ../../kate/document/katedocument.cpp:2906
#14 0x00007f873cf0a89c in KateView::backspace (this=0x20440e0) at ../../kate/view/kateview.cpp:2295
#15 0x00007f873cf0f0dd in KateView::qt_metacall (this=0x20440e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0e757bc0) at ./kateview.moc:373
#16 0x00007f874f9cfc0f in QMetaObject::activate (sender=0x22d2b20, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007f8750e8b022 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007f8750e8d09b in QAction::activate (this=0x22d2b20, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007f8750e8e9a7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007f87500aa19d in KAction::event (this=0x0, event=0x7fff0e758230) at ../../kdeui/actions/kaction.cpp:129
#21 0x00007f8750e9112c in QApplicationPrivate::notify_helper (this=0x6dbaa0, receiver=0x22d2b20, e=0x7fff0e758230) at kernel/qapplication.cpp:4300
#22 0x00007f8750e9771b in QApplication::notify (this=0x7fff0e759870, receiver=0x22d2b20, e=0x7fff0e758230) at kernel/qapplication.cpp:4183
#23 0x00007f8750180076 in KApplication::notify (this=0x7fff0e759870, receiver=0x22d2b20, event=0x7fff0e758230) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f874f9bce0c in QCoreApplication::notifyInternal (this=0x7fff0e759870, receiver=0x22d2b20, event=0x7fff0e758230) at kernel/qcoreapplication.cpp:704
#25 0x00007f8750ecce76 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff0e758830) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff0e758830) at kernel/qshortcutmap.cpp:879
#27 0x00007f8750ecec77 in QShortcutMap::tryShortcutEvent (this=0x6dbbc8, o=<value optimized out>, e=0x7fff0e758830) at kernel/qshortcutmap.cpp:364
#28 0x00007f8750e99273 in QApplication::notify (this=0x7fff0e759870, receiver=0x2046e40, e=0x7fff0e758830) at kernel/qapplication.cpp:3746
#29 0x00007f8750180076 in KApplication::notify (this=0x7fff0e759870, receiver=0x2046e40, event=0x7fff0e758830) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007f874f9bce0c in QCoreApplication::notifyInternal (this=0x7fff0e759870, receiver=0x2046e40, event=0x7fff0e758830) at kernel/qcoreapplication.cpp:704
#31 0x00007f8750f3bc1a in QKeyMapper::sendKeyEvent (keyWidget=0x2046e40, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007f8750f3e190 in QKeyMapperPrivate::translateKeyEvent (this=0x716610, keyWidget=0x2046e40, event=<value optimized out>, grab=176) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007f8750f15734 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff0e759400) at kernel/qapplication_x11.cpp:3394
#34 0x00007f8750f41322 in x11EventSourceDispatch (s=0x6de2d0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f874ec4cbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007f874ec50598 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007f874ec506c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007f874f9e6333 in QEventDispatcherGlib::processEvents (this=0x6b4770, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#39 0x00007f8750f40f0e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f874f9bb732 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007f874f9bbb0c in QEventLoop::exec (this=0x7fff0e759730, flags=) at kernel/qeventloop.cpp:201
#42 0x00007f874f9bf84b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00007f8751cddead in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../kate/app/katemain.cpp:377
#44 0x00007f8751987abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff0e75adf8) at libc-start.c:220
#45 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 226409.

Possible duplicates by query: bug 233081, bug 231425, bug 231107, bug 228980, bug 226322.

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-05-28 01:42:08 UTC
fixed for KDE >= 4.4.4.

*** This bug has been marked as a duplicate of bug 226409 ***