Bug 226322 - Kwrite crashed on doubleclick somewhere in window
Summary: Kwrite crashed on doubleclick somewhere in window
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Unclassified
Component: kwrite (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-11 15:13 UTC by Alexander Varnin
Modified: 2010-02-16 12:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Varnin 2010-02-11 15:13:38 UTC
Application that crashed: kwrite
Version of the application: 4.3.5 (KDE 4.3.5)
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Kwrite crashed, when i doubleclicked at the botom of editor form.

 -- Backtrace:
Application: KWrite (kwrite), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f47fc78821a in KateLayoutCache::viewLine (this=0x1ded8b0, realCursor=...) at ../../kate/render/katelayoutcache.cpp:392
#7  0x00007f47fc7d85ec in KateViewInternal::viewLineOffset (this=0x1df21e0, virtualCursor=..., offset=0, keepX=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:1338
#8  0x00007f47fc7db6db in KateViewInternal::makeVisible (this=0x1df21e0, c=..., endCol=-1, force=false, center=<value optimized out>, calledExternally=false)
    at ../../kate/view/kateviewinternal.cpp:657
#9  0x00007f47fc7dbe39 in KateViewInternal::updateCursor (this=0x1df21e0, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1876
#10 0x00007f47fc7e047d in KateViewInternal::mousePressEvent (this=0x1df21e0, e=0x7fffc69d5f50) at ../../kate/view/kateviewinternal.cpp:2539
#11 0x00007f4808cf09a6 in QWidget::event (this=0x1df21e0, event=0x7fffc69d5f50) at kernel/qwidget.cpp:7545
#12 0x00007f4808ca1efc in QApplicationPrivate::notify_helper (this=0x1add890, receiver=0x1df21e0, e=0x7fffc69d5f50) at kernel/qapplication.cpp:4056
#13 0x00007f4808ca9011 in QApplication::notify (this=<value optimized out>, receiver=0x1df21e0, e=0x7fffc69d5f50) at kernel/qapplication.cpp:3758
#14 0x00007f48098d8f46 in KApplication::notify (this=0x7fffc69d7f10, receiver=0x1df21e0, event=0x7fffc69d5f50) at ../../kdeui/kernel/kapplication.cpp:302
#15 0x00007f480837dc2c in QCoreApplication::notifyInternal (this=0x7fffc69d7f10, receiver=0x1df21e0, event=0x7fffc69d5f50) at kernel/qcoreapplication.cpp:610
#16 0x00007f4808ca88e0 in QCoreApplication::sendSpontaneousEvent (receiver=0x1df21e0, event=0x7fffc69d5f50, alienWidget=0x1df21e0, nativeWidget=0x1c2f9b0, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#17 QApplicationPrivate::sendMouseEvent (receiver=0x1df21e0, event=0x7fffc69d5f50, alienWidget=0x1df21e0, nativeWidget=0x1c2f9b0, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at kernel/qapplication.cpp:2924
#18 0x00007f4808d0ea0e in QETWidget::translateMouseEvent (this=0x1c2f9b0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#19 0x00007f4808d0daa9 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffc69d7a80) at kernel/qapplication_x11.cpp:3550
#20 0x00007f4808d36d0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#21 0x00007f4804c42bce in g_main_dispatch (context=0x1ae01f0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#22 IA__g_main_context_dispatch (context=0x1ae01f0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#23 0x00007f4804c46598 in g_main_context_iterate (context=0x1ae01f0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#24 0x00007f4804c466c0 in IA__g_main_context_iteration (context=0x1ae01f0, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#25 0x00007f48083a61a6 in QEventDispatcherGlib::processEvents (this=0x1ac1c80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f4808d364be in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f480837c532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f480837c904 in QEventLoop::exec (this=0x7fffc69d7db0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f480837eab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x00007f480a9a605d in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../apps/kwrite/kwritemain.cpp:782
#31 0x00007f480a645abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffc69d8bb8) at libc-start.c:220
#32 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 203884

Reported using DrKonqi
Comment 1 Milian Wolff 2010-02-11 15:42:07 UTC
somehow the line has no layout assigned and hence crashes there, we have to investigate this one... I thought I backported every crash fix to KDE 4.3.5...

@Reporter: If you can, please update to 4.4 eventually and see whehter it's fixed there. Maybe (hopefully) I just forgot to backport something.
Comment 2 Alexander Varnin 2010-02-11 19:53:40 UTC
I'm using Ubuntu default KDE version. Is it possible, that there is no your backports yet?
Comment 3 Christoph Cullmann 2010-02-16 12:56:29 UTC
Seems like same error as in other bug.
Problem is: I doubt my fix is that correct, not sure if backporting it is ok.

*** This bug has been marked as a duplicate of bug 226409 ***