Bug 231951 - Kate Crushed qhen i reloaded a text file
Summary: Kate Crushed qhen i reloaded a text file
Status: RESOLVED DUPLICATE of bug 208486
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-23 23:29 UTC by Vndecid
Modified: 2010-03-24 13:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vndecid 2010-03-23 23:29:43 UTC
Application: kwrite (4.4.00 (KDE 4.4.0))
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.1
Operating System: Linux 2.6.31.12-desktop586-1mnb i686
Distribution: "Mandriva Linux 2010.0"

-- Information about the crash:
I reloaded a file who was changed by a C program when kate crushed...only crushed the file could see but intantanly kate crushed...

 -- Backtrace:
Application: KWrite (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb54836d0 (LWP 14183))]

Thread 2 (Thread 0xb08feb70 (LWP 14185)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6a259e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb0ad5127 in ?? () from /usr/lib/libQtScript.so.4
#3  0xb0ad516f in ?? () from /usr/lib/libQtScript.so.4
#4  0xb6a21885 in start_thread () from /lib/i686/libpthread.so.0
#5  0xb5e1657e in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb54836d0 (LWP 14183)):
[KCrash Handler]
#6  KDirWatchPrivate::Entry::propagate_dirty (this=0x840f3f4) at /usr/lib/qt4/include/QtCore/qatomic_i386.h:120
#7  0xb71bf08e in KDirWatchPrivate::Entry::propagate_dirty (this=0x86d27a4) at /usr/src/debug/kdelibs-4.4.0/kio/kio/kdirwatch.cpp:421
#8  0xb71ca701 in KDirWatchPrivate::slotRescan (this=0x841c948) at /usr/src/debug/kdelibs-4.4.0/kio/kio/kdirwatch.cpp:1349
#9  0xb71cb2fc in KDirWatchPrivate::qt_metacall (this=0x841c948, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf82a4ac) at /usr/src/debug/kdelibs-4.4.0/build/kio/kdirwatch_p.moc:81
#10 0xb6ba42ed in QMetaObject::metacall () from /usr/lib/libQtCore.so.4
#11 0xb6bb311a in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#12 0xb6c06185 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#13 0xb6bbb406 in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#14 0xb6bafc24 in QObject::event () from /usr/lib/libQtCore.so.4
#15 0xb60b372c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#16 0xb60ba578 in QApplication::notify () from /usr/lib/libQtGui.so.4
#17 0xb6e8b001 in KApplication::notify (this=0xbf82ad60, receiver=0x841c990, event=0xbf82a9f0) at /usr/src/debug/kdelibs-4.4.0/kdeui/kernel/kapplication.cpp:302
#18 0xb6b9ef7e in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#19 0xb6bcf14a in ?? () from /usr/lib/libQtCore.so.4
#20 0xb6bcbe25 in ?? () from /usr/lib/libQtCore.so.4
#21 0xb5840b92 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb5844468 in ?? () from /usr/lib/libglib-2.0.so.0
#23 0xb584458e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0xb6bcbac1 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#25 0xb6173dba in ?? () from /usr/lib/libQtGui.so.4
#26 0xb6b9d5ed in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#27 0xb6b9da39 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#28 0xb6ba1bb0 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#29 0xb60b37d4 in QApplication::exec () from /usr/lib/libQtGui.so.4
#30 0xb5093634 in kdemain () from /usr/lib/libkdeinit4_kwrite.so
#31 0x0804dc3f in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x82fe8c3 "DISPLAY=:0.0", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x82fe8d4 "localhost;1269383095;559778;10326_TIME38801447") at /usr/src/debug/kdelibs-4.4.0/kinit/kinit.cpp:717
#32 0x0804e8d7 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at /usr/src/debug/kdelibs-4.4.0/kinit/kinit.cpp:1209
#33 0x0804ed24 in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.4.0/kinit/kinit.cpp:1402
#34 0x0804fabf in main (argc=2, argv=0xbf82b9e4, envp=0xbf82b9f0) at /usr/src/debug/kdelibs-4.4.0/kinit/kinit.cpp:1841

Possible duplicates by query: bug 231273, bug 229647, bug 229119, bug 226571, bug 226171.

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-24 13:13:39 UTC
Fixed in KDE SC 4.4.1 already.
Regards

*** This bug has been marked as a duplicate of bug 208486 ***