Bug 226171 - kate closing modified file
Summary: kate closing modified file
Status: RESOLVED DUPLICATE of bug 222547
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-10 18:43 UTC by Michael Hind
Modified: 2010-02-10 20:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hind 2010-02-10 18:43:58 UTC
Application that crashed: kate
Version of the application: 3.3.5
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I changed a file under subversion control and commited it

As the commit changes certain information in the file (svn properties - Author, Id etc) the file was marked with a red cross.

When I then attempted to close the file Kate then exited with a Segmentation fault rather then just closing the file.

This has happened to me 3 or 4 times since Kate was upgraded from Ubuntu Karmic backports, so I installed the nessecary .dbg files and submitted this report.

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QBasicAtomicInt::ref (this=0x2564578) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#6  QList (this=0x2564578) at /usr/include/qt4/QtCore/qlist.h:111
#7  QForeachContainer (this=0x2564578) at /usr/include/qt4/QtCore/qglobal.h:2054
#8  KDirWatchPrivate::Entry::propagate_dirty (this=0x2564578) at ../../kio/kio/kdirwatch.cpp:399
#9  0x00007fb7de74f46b in KDirWatchPrivate::Entry::propagate_dirty (this=<value optimized out>) at ../../kio/kio/kdirwatch.cpp:404
#10 0x00007fb7de756b27 in KDirWatchPrivate::slotRescan (this=0xde99e0) at ../../kio/kio/kdirwatch.cpp:1275
#11 0x00007fb7de7576f4 in KDirWatchPrivate::qt_metacall (this=0xde99e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdd81a2c0) at ./kdirwatch_p.moc:73
#12 0x00007fb7e26bcddc in QMetaObject::activate (sender=0xde9a48, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3113
#13 0x00007fb7e26b6d83 in QObject::event (this=0xde9a48, e=0x0) at kernel/qobject.cpp:1075
#14 0x00007fb7e3aeeefc in QApplicationPrivate::notify_helper (this=0xbb2dc0, receiver=0xde9a48, e=0x7fffdd81a8c0) at kernel/qapplication.cpp:4056
#15 0x00007fb7e3af61ce in QApplication::notify (this=0x7fffdd81ac60, receiver=0xde9a48, e=0x7fffdd81a8c0) at kernel/qapplication.cpp:4021
#16 0x00007fb7e2e2ef46 in KApplication::notify (this=0x7fffdd81ac60, receiver=0xde9a48, event=0x7fffdd81a8c0) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007fb7e26a7c2c in QCoreApplication::notifyInternal (this=0x7fffdd81ac60, receiver=0xde9a48, event=0x7fffdd81a8c0) at kernel/qcoreapplication.cpp:610
#18 0x00007fb7e26d2862 in QCoreApplication::sendEvent (this=0xbb69c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QTimerInfoList::activateTimers (this=0xbb69c0) at kernel/qeventdispatcher_unix.cpp:572
#20 0x00007fb7e26d025d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#21 0x00007fb7e1080bce in g_main_dispatch (context=0xbb5920) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#22 IA__g_main_context_dispatch (context=0xbb5920) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#23 0x00007fb7e1084598 in g_main_context_iterate (context=0xbb5920, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#24 0x00007fb7e10846c0 in IA__g_main_context_iteration (context=0xbb5920, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#25 0x00007fb7e26d01a6 in QEventDispatcherGlib::processEvents (this=0xb95c80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007fb7e3b834be in QGuiEventDispatcherGlib::processEvents (this=0x2564578, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007fb7e26a6532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007fb7e26a6904 in QEventLoop::exec (this=0x7fffdd81ab60, flags=) at kernel/qeventloop.cpp:201
#29 0x00007fb7e26a8ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x00007fb7e4875d2d in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../kate/app/katemain.cpp:257
#31 0x00007fb7e4520abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffdd81be78) at libc-start.c:220
#32 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 223584

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-10 20:36:49 UTC
Those issues are being tracked at bug 222547. Merging. Thanks

*** This bug has been marked as a duplicate of bug 222547 ***