Bug 231273 - Saving a file over a changed file.
Summary: Saving a file over a changed file.
Status: RESOLVED DUPLICATE of bug 208486
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-19 07:28 UTC by George Dvorak
Modified: 2010-03-19 13:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George Dvorak 2010-03-19 07:28:25 UTC
Application that crashed: kate
Version of the application: 3.3.5
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I had opened a file before it was going to be changed by another app.  Then after the file was changed I saved the original file and that is when the crash occured.  This has happened a number of times.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QBasicAtomicInt::ref (this=0x25c2b38) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#6  QList (this=0x25c2b38) at /usr/include/qt4/QtCore/qlist.h:111
#7  QForeachContainer (this=0x25c2b38) at /usr/include/qt4/QtCore/qglobal.h:2054
#8  KDirWatchPrivate::Entry::propagate_dirty (this=0x25c2b38) at ../../kio/kio/kdirwatch.cpp:399
#9  0x00007f11f35ab46b in KDirWatchPrivate::Entry::propagate_dirty (this=<value optimized out>) at ../../kio/kio/kdirwatch.cpp:404
#10 0x00007f11f35b2b27 in KDirWatchPrivate::slotRescan (this=0x1e8afc0) at ../../kio/kio/kdirwatch.cpp:1275
#11 0x00007f11f35b36f4 in KDirWatchPrivate::qt_metacall (this=0x1e8afc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4d766a60) at ./kdirwatch_p.moc:73
#12 0x00007f11f44adddc in QMetaObject::activate (sender=0x1e8b028, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3113
#13 0x00007f11f44a7d83 in QObject::event (this=0x1e8b028, e=0x0) at kernel/qobject.cpp:1075
#14 0x00007f11f2442efc in QApplicationPrivate::notify_helper (this=0x1da78c0, receiver=0x1e8b028, e=0x7fff4d767060) at kernel/qapplication.cpp:4056
#15 0x00007f11f244a1ce in QApplication::notify (this=0x7fff4d767400, receiver=0x1e8b028, e=0x7fff4d767060) at kernel/qapplication.cpp:4021
#16 0x00007f11f3079f46 in KApplication::notify (this=0x7fff4d767400, receiver=0x1e8b028, event=0x7fff4d767060) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f11f4498c2c in QCoreApplication::notifyInternal (this=0x7fff4d767400, receiver=0x1e8b028, event=0x7fff4d767060) at kernel/qcoreapplication.cpp:610
#18 0x00007f11f44c3862 in QCoreApplication::sendEvent (this=0x1dab3a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QTimerInfoList::activateTimers (this=0x1dab3a0) at kernel/qeventdispatcher_unix.cpp:572
#20 0x00007f11f44c125d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#21 0x00007f11f1373bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f11f1377598 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f11f13776c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f11f44c11a6 in QEventDispatcherGlib::processEvents (this=0x1d1e040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#25 0x00007f11f24d74be in QGuiEventDispatcherGlib::processEvents (this=0x25c2b38, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x00007f11f4497532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#27 0x00007f11f4497904 in QEventLoop::exec (this=0x7fff4d767300, flags=) at kernel/qeventloop.cpp:201
#28 0x00007f11f4499ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0x00007f11e8858d2d in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../kate/app/katemain.cpp:257
#30 0x0000000000406da8 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x1d67d59 "the-desktop;1268979399;586945;3006_TIME25002049") at ../../kinit/kinit.cpp:677
#31 0x0000000000407aa0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#32 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#33 0x0000000000408bb2 in main (argc=1, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-19 13:37:19 UTC
Fixed for KDE SC 4.4.1 and later. (bug 222547 / bug 208486)
Regards

*** This bug has been marked as a duplicate of bug 208486 ***