Bug 226571 - Kate crashes when open files are deleted on disk
Summary: Kate crashes when open files are deleted on disk
Status: RESOLVED DUPLICATE of bug 208486
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-12 17:02 UTC by Dave Plater
Modified: 2010-02-15 23:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Plater 2010-02-12 17:02:21 UTC
Application: kate (3.3.98)
KDE Platform Version: 4.3.98 (KDE 4.3.98 (KDE 4.4 RC3)) "release 216"
Qt Version: 4.6.1
Operating System: Linux 2.6.31.12-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
I was deleting a directory with midnight commander which contained files open in kate when the crash occurred

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa2adcb67f0 (LWP 7376))]

Thread 2 (Thread 0x7fa29b944910 (LWP 7377)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fa29be906a6 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fa29c16e220) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x00007fa29be906e9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fa29c17c2ec) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00007fa2abf8165d in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00007fa2aad50e1d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa2adcb67f0 (LWP 7376)):
[KCrash Handler]
#5  ref (this=<value optimized out>) at /usr/include/QtCore/qatomic_x86_64.h:121
#6  QList (this=<value optimized out>) at /usr/include/QtCore/qlist.h:114
#7  QForeachContainer (this=<value optimized out>) at /usr/include/QtCore/qglobal.h:2228
#8  KDirWatchPrivate::Entry::propagate_dirty (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.98/kio/kio/kdirwatch.cpp:416
#9  0x00007fa2accefd9b in KDirWatchPrivate::Entry::propagate_dirty (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.98/kio/kio/kdirwatch.cpp:421
#10 0x00007fa2ace506df in KDirWatchPrivate::slotRescan (this=0x78ebb0) at /usr/src/debug/kdelibs-4.3.98/kio/kio/kdirwatch.cpp:1349
#11 0x00007fa2ace511f4 in KDirWatchPrivate::qt_metacall (this=0x78ebb0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffed10cf20)
    at /usr/src/debug/kdelibs-4.3.98/build/kio/kdirwatch_p.moc:81
#12 0x00007fa2ac316bff in QMetaObject::activate (sender=0x78ec18, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3) at kernel/qobject.cpp:3275
#13 0x00007fa2ac313853 in QObject::event (this=0x78ec18, e=0x7fffed10d6b0) at kernel/qobject.cpp:1212
#14 0x00007fa2ab4a6c9c in QApplicationPrivate::notify_helper (this=0x68c430, receiver=0x78ec18, e=0x7fffed10d6b0) at kernel/qapplication.cpp:4298
#15 0x00007fa2ab4ad27b in QApplication::notify (this=0x7fffed10db40, receiver=0x78ec18, e=0x7fffed10d6b0) at kernel/qapplication.cpp:4181
#16 0x00007fa2ac7d6ba6 in KApplication::notify (this=0x7fffed10db40, receiver=0x78ec18, event=0x7fffed10d6b0) at /usr/src/debug/kdelibs-4.3.98/kdeui/kernel/kapplication.cpp:302
#17 0x00007fa2ac303dfc in QCoreApplication::notifyInternal (this=0x7fffed10db40, receiver=0x78ec18, event=0x7fffed10d6b0) at kernel/qcoreapplication.cpp:704
#18 0x00007fa2ac330ac5 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#19 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:617
#20 0x00007fa2ac32d658 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#21 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#22 0x00007fa2a755fdee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fa2a75637b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fa2a75638e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#25 0x00007fa2ac32d323 in QEventDispatcherGlib::processEvents (this=0x61aec0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007fa2ab554dce in QGuiEventDispatcherGlib::processEvents (this=0x2df5138, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007fa2ac302712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007fa2ac302aec in QEventLoop::exec (this=0x7fffed10da00, flags=) at kernel/qeventloop.cpp:201
#29 0x00007fa2ac30683b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x00007fa29ee1eead in kdemain () from /usr/lib64/libkdeinit4_kate.so
#31 0x00000000004073b8 in _start ()
The current source language is "auto; currently asm".

Possible duplicates by query: bug 226171, bug 224229, bug 223584, bug 222547, bug 221469.

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-15 23:35:26 UTC
Fixed in KDE SC 4.4.1 and 4.5

*** This bug has been marked as a duplicate of bug 208486 ***