Bug 227530 - Album-sorting gone from menus [patch]
Summary: Album-sorting gone from menus [patch]
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Menus (show other bugs)
Version: 3.5.0
Platform: openSUSE RPMs Linux
: NOR normal with 85 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks: 126116 218023
  Show dependency treegraph
 
Reported: 2010-02-18 15:59 UTC by S. Burmeister
Modified: 2017-07-29 06:22 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0
languitar: Junior_Jobs+


Attachments
added an item to the view menu that sorts albums in the side bar by name "ascending & descending" (12.84 KB, patch)
2013-05-13 00:55 UTC, Mohamed
Details
Patch for Digikam to add Album Sorting by name (Ascending and Descending) to the View menu (11.29 KB, patch)
2013-11-02 01:31 UTC, Mohamed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2010-02-18 15:59:29 UTC
Version:           1.2.0 svn (using KDE 4.4.0)
OS:                Linux
Installed from:    openSUSE RPMs

Using Rev: 1092212 I cannot find a way to sort the album-tree. NEither the view menu nor the album menu contain any "sort albums by..." items.
Comment 1 Johannes Wienke 2010-02-18 16:34:18 UTC
Yes, this indeed missing since the model view port since we didn't find a simple solution to implement this, although it is possible.

Can you explain a bit more for which purpose you need this feature. Maybe we can use this as an opportunity to also improve the general usability.
Comment 2 S. Burmeister 2010-02-22 17:45:41 UTC
Each album has properties, such as date, name or category. Some people like to have the most recent albums on top other the oldest. It's basically like a file/folder list in dolphin where I can sort by properties and group by properties.

I only use one collection, so I'm not sure whether it makes sense to be able to sort collection-less.
Comment 3 Marcel Wiesweg 2010-02-22 21:43:04 UTC
Sorting, when keeping the hierarchy, is no problem at all. What is bugging is is the grouping - in the old versions, all albums were put in a flat list and new parent entries were inserted for each category. Currently this regrouping is virtually impossible to do with model/view (a class to achieve this is being developed for akonadi but not yet in kdelibs).
Comment 4 Johannes Wienke 2010-02-26 19:02:54 UTC
Just stumbled over bug 126116. If we fix this bug we should also resolve the other one. Should not be too much additional work.
Comment 5 Roland 2010-04-10 08:49:35 UTC
In my view the previous option to sort albums via categories was an important option to structure an increasing amount of albums. With the current solution based on a flat list the album overview has become a bit confusing.
Comment 6 Frédéric COIFFIER 2010-05-08 10:57:59 UTC
In my case, I sorted all my albums by date.
I think that the calendar view is different as we can't see Album names in the tree.

Moreover, the album date defined in "Properties" is become useless in this current version as it was essentially used for sorting, isn't it ?
Comment 7 Andi Clemens 2010-12-04 12:21:35 UTC
Sorting albums seems to be gone from the menu... have we removed this feature on purpose?
Comment 8 Johannes Wienke 2010-12-04 15:00:05 UTC
See #1 and #3.
Comment 9 Frédéric COIFFIER 2010-12-23 11:03:50 UTC
Regarding #3, is there some news about this class in akonadi and its inclusion in kdelibs ?
Have you another plan for near future ?

Since this feature had disappeared, I have to rename all my Albums (which is the opposite of the original purpose of Digikam).
Comment 10 Hermann Avenariusus 2011-06-23 13:01:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 11 caulier.gilles 2012-01-14 23:54:02 UTC
*** Bug 291544 has been marked as a duplicate of this bug. ***
Comment 12 caulier.gilles 2013-03-18 13:22:16 UTC
Some technical information from Marcel taken from a current thread in digikam-users mailing list :

The task is not too difficult. Sorting is implemented in
AlbumFilterModel::lessThan. This method does not need to be changed if the
sort role is adjusted properly. For that, we'll need a special AlbumDateRole
in AlbumModel, and a reimplementation of albumData for that class.
In the UI, DigikamView / leftsidebarwidgets need to set the sort role on the
album model (from albummodelcollection) which is used for the left side bar.
Comment 13 Mohamed 2013-05-13 00:55:44 UTC
Created attachment 79864 [details]
added an item to the view menu that sorts albums in the side bar by name "ascending & descending"

My mentor [Islam al Wazery] asked me to work on this bug, 
He explained and clarified the different parts of the source code of Digikam to me when we met.
then I started to work on the bug which is actually a feature to be added to Digikam's view menu.
I added a new Item to the menu called "Sort Albums By Name" which is branched after that to 
"ascending & descending" sort orders.
after my exams I will work on adding some sorting options for albums "By Name, By Size , By Path ,....".
thats all.
Comment 14 Frédéric COIFFIER 2013-05-13 08:04:15 UTC
The most important is to be able to sorting them by date (thanks to the date which is assigned in the property of each album)
Comment 15 Islam Wazery 2013-05-13 18:21:47 UTC
Gilles, can you review and apply the patch, if not I will do that in Thursday.

On 5/13/13, Mohamed <mohammed.ahmed.anwer@gmail.com> wrote:
> https://bugs.kde.org/show_bug.cgi?id=227530
>
> --- Comment #13 from Mohamed <mohammed.ahmed.anwer@gmail.com> ---
> Created attachment 79864 [details]
>   --> https://bugs.kde.org/attachment.cgi?id=79864&action=edit
> added an item to the view menu that sorts albums in the side bar by name
> "ascending & descending"
>
> My mentor [Islam al Wazery] asked me to work on this bug,
> He explained and clarified the different parts of the source code of Digikam
> to
> me when we met.
> then I started to work on the bug which is actually a feature to be added
> to
> Digikam's view menu.
> I added a new Item to the menu called "Sort Albums By Name" which is
> branched
> after that to
> "ascending & descending" sort orders.
> after my exams I will work on adding some sorting options for albums "By
> Name,
> By Size , By Path ,....".
> thats all.
>
> --
> You are receiving this mail because:
> You are the assignee for the bug.
> _______________________________________________
> Digikam-devel mailing list
> Digikam-devel@kde.org
> https://mail.kde.org/mailman/listinfo/digikam-devel
>
Comment 16 caulier.gilles 2013-07-23 08:38:35 UTC
Islam, 

Do you review this patch ?

Gilles Caulier
Comment 17 caulier.gilles 2013-07-24 09:24:26 UTC
Mohamed,

I review you patch, and it look mostly uncomplete. For example, i see slot named "S" in signal/slot connection. I think you attach and old version of patch in this file. Also, it do not compile against git/master. It must be updated.

Thanks in advance

Gilles Caulier
Comment 18 Mohamed 2013-07-27 15:04:46 UTC
Mr Gilles,

Yes, I wil update it soon

Thanks,
Mohamed Anwer
Comment 19 caulier.gilles 2013-10-21 09:46:33 UTC
Mohamed,

I'm always waiting your updated patch here...

Gilles Caulier
Comment 20 Mohamed 2013-11-02 01:31:55 UTC
Created attachment 83274 [details]
Patch for Digikam to add Album Sorting by name (Ascending and Descending) to the View menu

Here is the patch Mr Gilles ,, sorry for being late
Comment 21 caulier.gilles 2013-11-28 23:21:30 UTC
Mohamed,

Patch checked and tested.
 
It sound fine, but it miss real improvements to sort albums as by date.

Note : Sorting album by name, is not really an improvement since this option is already available in album tree-view header. Just click one time album are sorted in descending mode, and one another time, albums are sorted in ascending mode...

Gilles Caulier
Comment 22 caulier.gilles 2013-11-28 23:23:40 UTC
*** Bug 218022 has been marked as a duplicate of this bug. ***