Bug 218022 - albums are sorted alphabetically within the month
Summary: albums are sorted alphabetically within the month
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Searches-Dates (show other bugs)
Version: 3.5.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-09 19:47 UTC by S. Burmeister
Modified: 2019-12-24 18:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0
caulier.gilles: Junior_Jobs+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2009-12-09 19:47:32 UTC
Version:           1.0.0 (using KDE 4.3.4)
OS:                Linux
Installed from:    openSUSE RPMs

If one picks View > Sort albums > By Date digikam creates a tree of months. Within one month however the albums are not sorted according to the date set in their properties but alphabetically, e.g.

B1 [date set in properties is 01.01.2009]
B2 [date set in properties is 03.01.2009]
2009-08 [date set in properties is 01.01.2009]
2009-09

Expected:

B1 [date set in properties is 01.01.2009]
2009-08 [date set in properties is 01.01.2009]
B2 [date set in properties is 03.01.2009]
2009-09
Comment 1 caulier.gilles 2009-12-09 21:18:14 UTC
Johannes,

Same there, it's a Qt4 model view port candidate...

Gilles Caulier
Comment 2 Andi Clemens 2010-11-29 22:00:15 UTC
Hmm, is this option gone? I can not find "Sort albums -> by date" anymore.
Comment 3 S. Burmeister 2010-11-29 22:04:25 UTC
yes, there is a regression reported as bug 227530
Comment 4 caulier.gilles 2013-11-28 23:23:40 UTC

*** This bug has been marked as a duplicate of bug 227530 ***
Comment 5 caulier.gilles 2019-12-24 18:45:43 UTC
Not reproducible using 7.0.0 beta1