Bug 291544 - A sort-by-date for albums should be available as an alternative to the current sort-by-name.
Summary: A sort-by-date for albums should be available as an alternative to the curren...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Albums-Sort (show other bugs)
Version: 1.2.0
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 21:01 UTC by Omid
Modified: 2022-01-29 14:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Omid 2012-01-14 21:01:07 UTC
Version:           1.2.0 (using KDE 4.4.5) 
OS:                Linux

Currently, albums sort order is alphabetical only. (The images in an album can be sorted using several methods but this doesn't apply to the albums themselves.) The Calendar view is not equivalent to being able to sort the albums by date because it doesn't show one the album names. It's very useful to be able to see one's recent albums close to the top of the view tree, with the album names (i.e., the corresponding directory names) there too. The date for an album may be taken to be the date of the first image in it (coming from Metadata) or a date that the user specifies and is saved in the corresponding folder to a digiKam folder specific configuration file or to a central database. (The former would be preferable as it is easier to give someone a copy of a particular album with one's particular settings/edits for that album also copied and passed. Also, it would lend itself to script manipulation easily.)
These (both sorting albums by date and saving directory specific settings) are present in Picasa and are some of the features that one might wish to have when migrating to digiKam.

Reproducible: Always


Actual Results:  
The only option for sorting albums is by name.

Expected Results:  
There should be an option to sort the albums by date too.

OS: Linux (i686) release 2.6.32-37-generic
Compiler: cc
Comment 1 S. Burmeister 2012-01-14 21:38:31 UTC
Dup of the years old bug 227530.
Comment 2 caulier.gilles 2012-01-14 23:54:02 UTC

*** This bug has been marked as a duplicate of bug 227530 ***
Comment 3 caulier.gilles 2022-01-29 14:48:48 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=227530