Bug 126116 - Keep directory hierarchy when albums are view by category
Summary: Keep directory hierarchy when albums are view by category
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Albums-MainView (show other bugs)
Version: 0.8.1
Platform: Mandriva RPMs Linux
: NOR wishlist with 61 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on: 227530
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-23 16:55 UTC by Jérôme Martin
Modified: 2014-01-26 08:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0
caulier.gilles: Junior_Jobs+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jérôme Martin 2006-04-23 16:55:27 UTC
Version:           0.8.1 (using KDE KDE 3.4.2)
Installed from:    Mandriva RPMs
OS:                Linux

If my album hierarchy is (category in bracket):
  - My Albums
    - Album1 [c1]
       - May [c1]
       - June [c1]
    - Album2 [c2]

Album wiew by category show:
 - My Albums
   - c1
      - Album1
      - May
      - June
   - c2
      - Album2

And not
 - My Albums
   - c1
      - Album1
        - May
        - June
   - c2
      - Album2
Comment 1 Andi Clemens 2008-12-04 20:48:39 UTC
Ok this is an old one, but I can confirm this.
Will we fix this or do we use other mechanisms with model-view after 0.10 release anyway?

Andi
Comment 2 caulier.gilles 2008-12-04 21:14:45 UTC
yes, absolutly...

Gilles Caulier
Comment 3 Mikolaj Machowski 2008-12-06 17:25:56 UTC
Well, this bug is INVALID for practical reasons - album categories are no more.
Comment 4 Andi Clemens 2008-12-06 17:59:37 UTC
Sure they are... it's called collection
Comment 5 caulier.gilles 2011-12-23 11:33:45 UTC
Andi,

I think Mik is right. Categories are not Collection.

Categories is old filtering rules, not used anymore (setup panel need to be removed in the future)

Gilles Caulier
Comment 6 Roland 2011-12-27 13:08:44 UTC
Gilles,

I agree on your and Mik's statement that categories are not collections. 
But I do not agree on your subsequent conclusion. In my opinion the filtering on categories was a very useful option to select photos within a big collection. This feature is independent from all other posibilities to select photos (e.g. based on key words).
Therefore I would really appreciate if this function will return soon (see also 227530).

Roland
Comment 7 caulier.gilles 2012-03-21 08:54:08 UTC
*** Bug 296484 has been marked as a duplicate of this bug. ***