Bug 226749 - some of dolphin's right click menu items are grayed out - altough this menu items should be clickable
Summary: some of dolphin's right click menu items are grayed out - altough this menu i...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 226200 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-14 01:00 UTC by Jim Jones
Modified: 2010-11-12 18:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
picture showing the bug (160.69 KB, image/png)
2010-02-14 01:01 UTC, Jim Jones
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Jones 2010-02-14 01:00:00 UTC
Version:            (using KDE 4.4.0)
OS:                Linux

steps re reproduce:

1.) open new dolphin session in column mode - normally it opens $HOME
2.) click on a folder in dolphin
3.) right click on a file/folder on the newly opened column

some items are grayed out - like Copy,Cut,Rename,Move to Trash, Delete
altough i have enough rights to do this

if 2.) is done 2 times the menu shown in 3.) is as it should be
Comment 1 Jim Jones 2010-02-14 01:01:41 UTC
Created attachment 40755 [details]
picture showing the bug
Comment 2 Frank Reininghaus 2010-02-14 15:56:16 UTC
*** Bug 226200 has been marked as a duplicate of this bug. ***
Comment 3 Frank Reininghaus 2010-02-14 15:58:30 UTC
@Peter: This seems to be bug 224475 which you've closed as fixed. Maybe the
issue has reappeared?
Comment 4 Peter Penz 2010-02-14 19:22:04 UTC
@Frank: It seems the fix for 224475 only has fixed some parts, I could reproduce the issue on trunk :-(
Comment 5 Frank Reininghaus 2010-02-18 01:23:53 UTC
The cause of the disabled actions is that DolphinView does not receive the selectionChanged(...) signal of the selection model if the selection is changed in the second column.

To fix that, one could either

1. adjust the connection to the selection model's signal (which is done in DolphinView::createView() now) every time another column is activated, or

2. always use the same selection model, i.e., call DolphinColumnView::setSelectionModel(...) every time a new column is activated.
Comment 6 Peter Penz 2010-02-18 07:58:48 UTC
Thanks Frank for the hint, I hope I've time until end of February to fix this (it has a high priority on my list, as it is a dirty regression to KDE 4.3.x).
Comment 7 Peter Penz 2010-02-21 14:21:45 UTC
SVN commit 1093803 by ppenz:

Assure that the changed selection model is reconnected when changing columns. This fixes the regression that some operations have been disabled on sub columns. Thanks to Frank Reininghaus for the analyses.

BUG: 226749

 M  +22 -14    dolphinview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1093803
Comment 8 Peter Penz 2010-02-21 14:29:40 UTC
SVN commit 1093807 by ppenz:

Forward port of SVN commit 1093803: Assure that the changed selection model is reconnected when changing columns. This fixes the regression that some operations have been disabled on sub columns. Thanks to Frank Reininghaus for the analyses.

CCBUG: 226749

 M  +22 -14    dolphinview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1093807
Comment 9 Dimitrios Glentadakis 2010-11-11 21:05:32 UTC
i use kde 4.5.3 with mandriva 2010.1 and i still have this bug in konqueror https://bugs.kde.org/show_bug.cgi?id=226200 
When i switch to columns view, everything works fine, but if i delete a file in a folder then the menus cut,copy,paste,delete are disabled (grised)

in dolphin it works fine, i have the problem only in konqueror
Comment 10 Frank Reininghaus 2010-11-12 11:15:43 UTC
Dimitrios, I could not reproduce this so far. Could you open a new report for your problem and describe in detail which steps are required to see the bug (switch to columns view, delete a file, ...)? If you think that a screenshot of the disabled menus would help (so we can see better for which item the actions are disabled), feel free to attach one.

Thanks for your help.
Comment 11 Dimitrios Glentadakis 2010-11-12 18:47:09 UTC
Ok you can found the new report here with a video clip
https://bugs.kde.org/show_bug.cgi?id=256728