Bug 221469 - crash while editing printer properties
Summary: crash while editing printer properties
Status: RESOLVED DUPLICATE of bug 210091
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: qt (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-06 03:25 UTC by Kenyon Ralph
Modified: 2010-01-06 11:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenyon Ralph 2010-01-06 03:25:44 UTC
Application that crashed: okular
Version of the application: 0.9.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.30-2-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

What I was doing when the application crashed:
In okular's print dialog: I edited the "advanced" tab of printer properties for printer A, closed it, changed to a  different printer, and went to its advanced printer properties, and then okular crashed. Standby, I will see if I can reproduce this soon.

 -- Backtrace:
Application: Okular (okular), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5f53700 (LWP 20498))]

Thread 5 (Thread 0xb0fc6b70 (LWP 20509)):
#0  0xb7f3d424 in __kernel_vsyscall ()
#1  0xb62d00a5 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0xb68e682d in __pthread_cond_wait (cond=0x8bbfd80, mutex=0x8bbfd68) at forward.c:139
#3  0xb74565c2 in QWaitConditionPrivate::wait (this=0x8b66ee8, mutex=0x8b66ee4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x8b66ee8, mutex=0x8b66ee4, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb6636a9a in QHostInfoAgent::run (this=0x8b66ed8) at kernel/qhostinfo.cpp:260
#6  0xb74555e2 in QThreadPrivate::start (arg=0x8b66ed8) at thread/qthread_unix.cpp:188
#7  0xb62cc585 in start_thread (arg=0xb0fc6b70) at pthread_create.c:300
#8  0xb68d92be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 4 (Thread 0xb1d12b70 (LWP 20577)):
#0  0xb7f3d424 in __kernel_vsyscall ()
#1  0xb62d00a5 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0xb68e682d in __pthread_cond_wait (cond=0x8bacf08, mutex=0x8bacef0) at forward.c:139
#3  0xb74565c2 in QWaitConditionPrivate::wait (this=0x86cbd74, mutex=0x86cbd70, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x86cbd74, mutex=0x86cbd70, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb745205d in QSemaphore::acquire (this=0x8bacd98, n=1) at thread/qsemaphore.cpp:143
#6  0xaffacbe8 in GSRendererThread::run (this=0x8bacd90) at ../../../../okular/generators/spectre/rendererthread.cpp:69
#7  0xb74555e2 in QThreadPrivate::start (arg=0x8bacd90) at thread/qthread_unix.cpp:188
#8  0xb62cc585 in start_thread (arg=0xb1d12b70) at pthread_create.c:300
#9  0xb68d92be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xaf78bb70 (LWP 20657)):
#0  0xb7f3d424 in __kernel_vsyscall ()
#1  0xb62d00a5 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0xb68e682d in __pthread_cond_wait (cond=0x8bc1270, mutex=0x8bc1258) at forward.c:139
#3  0xb74565c2 in QWaitConditionPrivate::wait (this=0x86cd868, mutex=0x86cd864, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x86cd868, mutex=0x86cd864, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb70a617a in QFileInfoGatherer::run (this=0x86cd85c) at dialogs/qfileinfogatherer.cpp:207
#6  0xb74555e2 in QThreadPrivate::start (arg=0x86cd85c) at thread/qthread_unix.cpp:188
#7  0xb62cc585 in start_thread (arg=0xaf78bb70) at pthread_create.c:300
#8  0xb68d92be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb2513b70 (LWP 20658)):
#0  0xb62cf3d4 in __pthread_mutex_unlock_usercnt (mutex=<value optimized out>, decr=1) at pthread_mutex_unlock.c:77
#1  0xb68e6a36 in pthread_mutex_unlock (mutex=0x8c202e4) at forward.c:184
#2  0xb631ccf9 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0xb631d5e5 in ?? () from /lib/libglib-2.0.so.0
#4  0xb631d838 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb757105f in QEventDispatcherGlib::processEvents (this=0x8b2bdc0, flags=...) at kernel/qeventdispatcher_glib.cpp:409
#6  0xb754483a in QEventLoop::processEvents (this=0xb25132e0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb7544c82 in QEventLoop::exec (this=0xb25132e0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb7452309 in QThread::exec (this=0x8c21368) at thread/qthread.cpp:487
#9  0xb7527c1b in QInotifyFileSystemWatcherEngine::run (this=0x8c21368) at io/qfilesystemwatcher_inotify.cpp:214
#10 0xb74555e2 in QThreadPrivate::start (arg=0x8c21368) at thread/qthread_unix.cpp:188
#11 0xb62cc585 in start_thread (arg=0xb2513b70) at pthread_create.c:300
#12 0xb68d92be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb5f53700 (LWP 20498)):
[KCrash Handler]
#6  0xb7047d5f in QPPDOptionsModel::flags (this=0x8c54378, index=...) at dialogs/qprintdialog_unix.cpp:1114
#7  0xb711b4b3 in QItemSelectionRange::indexes (this=0x8c58480) at itemviews/qitemselectionmodel.cpp:285
#8  0xb711b624 in QItemSelection::indexes (this=0x8c58e5c) at itemviews/qitemselectionmodel.cpp:407
#9  0xb711c31b in QItemSelectionModelPrivate::_q_layoutAboutToBeChanged (this=0x8c58e10) at itemviews/qitemselectionmodel.cpp:712
#10 0xb7121e0e in QItemSelectionModel::qt_metacall (this=0x8c58e00, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfbbfa78) at .moc/release-shared/moc_qitemselectionmodel.cpp:133
#11 0xb755b303 in QMetaObject::activate (sender=0x8c54378, from_signal_index=7, to_signal_index=7, argv=0x0) at kernel/qobject.cpp:3112
#12 0xb755bf42 in QMetaObject::activate (sender=0x8c54378, m=0xb7637978, local_signal_index=3, argv=0x0) at kernel/qobject.cpp:3186
#13 0xb7595e47 in QAbstractItemModel::layoutAboutToBeChanged (this=0x8c54378) at .moc/release-shared/moc_qabstractitemmodel.cpp:145
#14 0xb704919f in QPPDOptionsModel::parseItems (this=0x8c54378) at dialogs/qprintdialog_unix.cpp:1125
#15 0xb70496aa in QPrintPropertiesDialog::selectPrinter (this=0x8cbdcf0) at dialogs/qprintdialog_unix.cpp:318
#16 0xb704b84b in QUnixPrintWidgetPrivate::_q_printerChanged (this=0x8a1d608, index=0) at dialogs/qprintdialog_unix.cpp:808
#17 0xb704d790 in QUnixPrintWidget::qt_metacall (this=0x8bf6258, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbbfd6c) at .moc/release-shared/moc_qprintdialog.cpp:69
#18 0xb755b303 in QMetaObject::activate (sender=0x8cdc4e8, from_signal_index=32, to_signal_index=32, argv=0xbfbbfd6c) at kernel/qobject.cpp:3112
#19 0xb755bf42 in QMetaObject::activate (sender=0x8cdc4e8, m=0xb73e1638, local_signal_index=5, argv=0xbfbbfd6c) at kernel/qobject.cpp:3186
#20 0xb6f4a703 in QComboBox::currentIndexChanged (this=0x8cdc4e8, _t1=0) at .moc/release-shared/moc_qcombobox.cpp:297
#21 0xb6f4c88a in QComboBoxPrivate::_q_emitCurrentIndexChanged (this=0x895b4b8, index=...) at widgets/qcombobox.cpp:1205
#22 0xb6f4ee23 in QComboBoxPrivate::setCurrentIndex (this=0x895b4b8, mi=...) at widgets/qcombobox.cpp:1953
#23 0xb6f4efae in QComboBoxPrivate::_q_itemSelected (this=0x895b4b8, item=...) at widgets/qcombobox.cpp:1174
#24 0xb6f546f6 in QComboBox::qt_metacall (this=0x8cdc4e8, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfbbff4c) at .moc/release-shared/moc_qcombobox.cpp:186
#25 0xb755b303 in QMetaObject::activate (sender=0x8c3ff88, from_signal_index=27, to_signal_index=27, argv=0xbfbbff4c) at kernel/qobject.cpp:3112
#26 0xb755bf42 in QMetaObject::activate (sender=0x8c3ff88, m=0xb73ee834, local_signal_index=0, argv=0xbfbbff4c) at kernel/qobject.cpp:3186
#27 0xb7206d93 in QComboBoxPrivateContainer::itemSelected (this=0x8c3ff88, _t1=...) at .moc/release-shared/moc_qcombobox_p.cpp:198
#28 0xb6f4c4a4 in QComboBoxPrivateContainer::eventFilter (this=0x8c3ff88, o=0x8a7a458, e=0xbfbc052c) at widgets/qcombobox.cpp:667
#29 0xb754541a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8690ae0, receiver=0x8a7a458, event=0xbfbc052c) at kernel/qcoreapplication.cpp:726
#30 0xb6b84a6c in QApplicationPrivate::notify_helper (this=0x8690ae0, receiver=0x8a7a458, e=0xbfbc052c) at kernel/qapplication.cpp:4061
#31 0xb6b8d551 in QApplication::notify (this=0xbfbc3fa4, receiver=0x8a7a458, e=0xbfbc052c) at kernel/qapplication.cpp:3767
#32 0xb7abc0fd in QBasicAtomicInt::ref (this=0xbfbc3fa4, sm=...) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#33 QList (this=0xbfbc3fa4, sm=...) at /usr/include/qt4/QtCore/qlist.h:111
#34 QForeachContainer (this=0xbfbc3fa4, sm=...) at /usr/include/qt4/QtCore/qglobal.h:2058
#35 KApplication::commitData (this=0xbfbc3fa4, sm=...) at ../../kdeui/kernel/kapplication.cpp:638
#36 0xb75461eb in QCoreApplication::notifyInternal (this=0xbfbc3fa4, receiver=0x8a7a458, event=0xbfbc052c) at kernel/qcoreapplication.cpp:610
#37 0xb6b8c5de in QCoreApplication::sendSpontaneousEvent (receiver=0x8a7a458, event=0xbfbc052c, alienWidget=0x8a7a458, nativeWidget=0x8c3ff88, buttonDown=0xb73fb580, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#38 QApplicationPrivate::sendMouseEvent (receiver=0x8a7a458, event=0xbfbc052c, alienWidget=0x8a7a458, nativeWidget=0x8c3ff88, buttonDown=0xb73fb580, lastMouseReceiver=...)
    at kernel/qapplication.cpp:2924
#39 0xb6bfb3bf in QETWidget::translateMouseEvent (this=0x8c3ff88, event=0xbfbc1adc) at kernel/qapplication_x11.cpp:4345
#40 0xb6bfa646 in QApplication::x11ProcessEvent (this=0xbfbc3fa4, event=0xbfbc1adc) at kernel/qapplication_x11.cpp:3430
#41 0xb6c24bc2 in x11EventSourceDispatch (s=0x8693cf0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#42 0xb6319f28 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0xb631d6b3 in ?? () from /lib/libglib-2.0.so.0
#44 0xb631d838 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0xb7571041 in QEventDispatcherGlib::processEvents (this=0x867b340, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#46 0xb6c24305 in QGuiEventDispatcherGlib::processEvents (this=0x867b340, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#47 0xb754483a in QEventLoop::processEvents (this=0xbfbc1d3c, flags=...) at kernel/qeventloop.cpp:149
#48 0xb7544c82 in QEventLoop::exec (this=0xbfbc1d3c, flags=...) at kernel/qeventloop.cpp:201
#49 0xb7067873 in QDialog::exec (this=0x8b20940) at dialogs/qdialog.cpp:498
#50 0xb704877d in QPrintDialog::exec (this=0x8b20940) at dialogs/qprintdialog_unix.cpp:609
#51 0xb4055bdb in Part::slotPrint (this=0x87948b0) at ../../okular/part.cpp:1930
#52 0xb4059591 in Part::qt_metacall (this=0x87948b0, _c=QMetaObject::InvokeMetaMethod, _id=52, _a=0xbfbc1edc) at ./part.moc:228
#53 0xb755b303 in QMetaObject::activate (sender=0x89549f8, from_signal_index=5, to_signal_index=6, argv=0xbfbc1edc) at kernel/qobject.cpp:3112
#54 0xb755b720 in QMetaObject::activate (sender=0x89549f8, m=0xb73dd1c8, from_local_signal_index=1, to_local_signal_index=2, argv=0xbfbc1edc) at kernel/qobject.cpp:3206
#55 0xb6b7e591 in QAction::triggered (this=0x89549f8, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#56 0xb6b7fadf in QAction::activate (this=0x89549f8, event=QAction::Trigger) at kernel/qaction.cpp:1167
#57 0xb6fc41d4 in QMenuPrivate::activateCausedStack (this=0x87919c8, causedStack=..., action=0x89549f8, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:967
#58 0xb6fca8ab in QMenuPrivate::activateAction (this=0x87919c8, action=0x89549f8, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1060
#59 0xb6fcb3f2 in QMenu::mouseReleaseEvent (this=0x8791c38, e=0xbfbc26bc) at widgets/qmenu.cpp:2259
#60 0xb7ba2655 in KMenu::aboutToShowContextMenu (this=0x8791c38, _t1=0xbfbc26bc, _t2=0xbfbc20a8, _t3=0xb694cff4) at ./kmenu.moc:91
#61 0xb6bda9fb in QWidget::event (this=0x8791c38, event=0xbfbc26bc) at kernel/qwidget.cpp:7554
#62 0xb6fcd631 in QMenu::event (this=0x8791c38, e=0xbfbc26bc) at widgets/qmenu.cpp:2358
#63 0xb6b84a94 in QApplicationPrivate::notify_helper (this=0x8690ae0, receiver=0x8791c38, e=0xbfbc26bc) at kernel/qapplication.cpp:4065
#64 0xb6b8d551 in QApplication::notify (this=0xbfbc3fa4, receiver=0x8791c38, e=0xbfbc26bc) at kernel/qapplication.cpp:3767
#65 0xb7abc0fd in QBasicAtomicInt::ref (this=0xbfbc3fa4, sm=...) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#66 QList (this=0xbfbc3fa4, sm=...) at /usr/include/qt4/QtCore/qlist.h:111
#67 QForeachContainer (this=0xbfbc3fa4, sm=...) at /usr/include/qt4/QtCore/qglobal.h:2058
#68 KApplication::commitData (this=0xbfbc3fa4, sm=...) at ../../kdeui/kernel/kapplication.cpp:638
#69 0xb75461eb in QCoreApplication::notifyInternal (this=0xbfbc3fa4, receiver=0x8791c38, event=0xbfbc26bc) at kernel/qcoreapplication.cpp:610
#70 0xb6b8c5de in QCoreApplication::sendSpontaneousEvent (receiver=0x8791c38, event=0xbfbc26bc, alienWidget=0x0, nativeWidget=0x8791c38, buttonDown=0xb73fb580, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#71 QApplicationPrivate::sendMouseEvent (receiver=0x8791c38, event=0xbfbc26bc, alienWidget=0x0, nativeWidget=0x8791c38, buttonDown=0xb73fb580, lastMouseReceiver=...) at kernel/qapplication.cpp:2924
#72 0xb6bfb3bf in QETWidget::translateMouseEvent (this=0x8791c38, event=0xbfbc3c6c) at kernel/qapplication_x11.cpp:4345
#73 0xb6bfa646 in QApplication::x11ProcessEvent (this=0xbfbc3fa4, event=0xbfbc3c6c) at kernel/qapplication_x11.cpp:3430
#74 0xb6c24bc2 in x11EventSourceDispatch (s=0x8693cf0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#75 0xb6319f28 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#76 0xb631d6b3 in ?? () from /lib/libglib-2.0.so.0
#77 0xb631d838 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#78 0xb7571041 in QEventDispatcherGlib::processEvents (this=0x867b340, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#79 0xb6c24305 in QGuiEventDispatcherGlib::processEvents (this=0x867b340, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#80 0xb754483a in QEventLoop::processEvents (this=0xbfbc3ed0, flags=...) at kernel/qeventloop.cpp:149
#81 0xb7544c82 in QEventLoop::exec (this=0xbfbc3ed0, flags=...) at kernel/qeventloop.cpp:201
#82 0xb75470d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#83 0xb6b84917 in QApplication::exec () at kernel/qapplication.cpp:3525
#84 0x0804e78f in main (argc=-1223576853, argv=0xb73f3364) at ../../../okular/shell/main.cpp:81
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Pino Toscano 2010-01-06 11:26:30 UTC

*** This bug has been marked as a duplicate of bug 210091 ***