Bug 223584 - Kate crash after closing file that was changed on a shell
Summary: Kate crash after closing file that was changed on a shell
Status: RESOLVED DUPLICATE of bug 222547
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-20 16:02 UTC by Steffen Schoenwiese
Modified: 2010-01-20 16:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Schoenwiese 2010-01-20 16:02:20 UTC
Application: kate (3.3.90)
KDE Platform Version: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic-pae i686
Distribution: Ubuntu 9.10

-- Information about the crash:
I "svn reverted" a file, that was opened in kate. When I tried to close the file in kate (the file, not kate completely), kate crashed

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5288700 (LWP 6852))]

Thread 2 (Thread 0xb34abb70 (LWP 6853)):
#0  0xb7828430 in __kernel_vsyscall ()
#1  0xb6183e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb779287d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb369ebb7 in WTF::TCMalloc_PageHeap::scavengerThread (this=0xb37781a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#4  0xb369ec01 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0xb37781a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#5  0xb617f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0xb77858de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5288700 (LWP 6852)):
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x99a7a84) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  QList (this=0x99a7a84) at /usr/include/qt4/QtCore/qlist.h:114
#8  QForeachContainer (this=0x99a7a84) at /usr/include/qt4/QtCore/qglobal.h:2229
#9  KDirWatchPrivate::Entry::propagate_dirty (this=0x99a7a84) at ../../kio/kio/kdirwatch.cpp:416
#10 0xb5795ab1 in KDirWatchPrivate::Entry::propagate_dirty (this=0x982557c) at ../../kio/kio/kdirwatch.cpp:421
#11 0xb579f7a1 in KDirWatchPrivate::slotRescan (this=0x8d7b2a8) at ../../kio/kio/kdirwatch.cpp:1349
#12 0xb57a0383 in KDirWatchPrivate::qt_metacall (this=0x8d7b2a8, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf9cc74c) at ./kdirwatch_p.moc:81
#13 0xb641f11a in QMetaObject::metacall (object=0x8d7b2a8, cl=QMetaObject::ReadProperty, idx=4, argv=0xbf9cc74c) at kernel/qmetaobject.cpp:237
#14 0xb642d89b in QMetaObject::activate (sender=0x8d7b2f0, m=0xb652e5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3294
#15 0xb647f1c7 in QTimer::timeout (this=0x8d7b2f0) at .moc/release-shared/moc_qtimer.cpp:134
#16 0xb6435b4e in QTimer::timerEvent (this=0x8d7b2f0, e=0xbf9ccc10) at kernel/qtimer.cpp:271
#17 0xb642a704 in QObject::event (this=0x8d7b2f0, e=0x99a7a84) at kernel/qobject.cpp:1224
#18 0xb6d7a19c in QApplicationPrivate::notify_helper (this=0x8cb0b18, receiver=0x8d7b2f0, e=0xbf9ccc10) at kernel/qapplication.cpp:4242
#19 0xb6d80df7 in QApplication::notify (this=0xbf9ccfc4, receiver=0x8d7b2f0, e=0xbf9ccc10) at kernel/qapplication.cpp:3661
#20 0xb678967a in KApplication::notify (this=0xbf9ccfc4, receiver=0x8d7b2f0, event=0xbf9ccc10) at ../../kdeui/kernel/kapplication.cpp:302
#21 0xb6419eab in QCoreApplication::notifyInternal (this=0xbf9ccfc4, receiver=0x8d7b2f0, event=0xbf9ccc10) at kernel/qcoreapplication.cpp:704
#22 0xb6449286 in QCoreApplication::sendEvent (this=0x8cb07e4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QTimerInfoList::activateTimers (this=0x8cb07e4) at kernel/qeventdispatcher_unix.cpp:603
#24 0xb6445f17 in timerSourceDispatch (source=0x8cb0820) at kernel/qeventdispatcher_glib.cpp:184
#25 idleTimerSourceDispatch (source=0x8cb0820) at kernel/qeventdispatcher_glib.cpp:231
#26 0xb60e1e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0xb60e5730 in ?? () from /lib/libglib-2.0.so.0
#28 0xb60e5863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0xb6445bd5 in QEventDispatcherGlib::processEvents (this=0x8cb0768, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#30 0xb6e37b75 in QGuiEventDispatcherGlib::processEvents (this=0x8cb0768, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#31 0xb64184c9 in QEventLoop::processEvents (this=0xbf9cced4, flags=) at kernel/qeventloop.cpp:149
#32 0xb641891a in QEventLoop::exec (this=0xbf9cced4, flags=...) at kernel/qeventloop.cpp:201
#33 0xb641cb0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#34 0xb6d7a237 in QApplication::exec () at kernel/qapplication.cpp:3570
#35 0xb7803a25 in kdemain () from /usr/lib/libkdeinit4_kate.so
#36 0x080485cb in _start ()

Possible duplicates by query: bug 222547, bug 221469.

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-20 16:11:20 UTC
This is a KIO issue being tracked at bug 222547. Thanks

*** This bug has been marked as a duplicate of bug 222547 ***