Bug 22540 - Creating/Editing Symlinks
Summary: Creating/Editing Symlinks
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist with 95 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 8581 29277 52379 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-03-16 20:18 UTC by tbutler
Modified: 2019-03-15 15:24 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tbutler 2001-03-16 20:16:02 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           konqueror
Version:           KDE 2.1.0 
Severity:          wishlist
Installed from:    SuSE
Compiler:          gcc version 2.95.2 19991024 (release)
OS:                Linux 2.4.0 i686
OS/Compiler notes: 

Hi there
  I've been thinking since KDE 1.x that it would be really nice if Konqueror (and before that KFM) would be able to create and edit symlinks. It seems to me that it would be great if the "Create New" menu had a "symbolic link" option and viewing the properties of an already created symlink would allow you to change where it points to.
  Just a thought. Thanks for all of your hard work Konqueror is great!

  -Tim

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Stephan Binner 2003-10-19 16:31:28 UTC
*** Bug 52379 has been marked as a duplicate of this bug. ***
Comment 2 Nick Shaforostoff 2003-12-03 18:33:12 UTC
and also creating/editing symlinks for ftp directories (i want one file had few names)

(sorry for ugly engl)
Comment 3 Sridhar Dhanapalan 2004-02-26 06:19:49 UTC
In KDE 3.2, symlinks can be created but not edited. Please add a facility to edit existing symbolic links. A clean way would be to make it part of the Properties dialogue box.
Comment 4 Lukáš Tinkl 2004-03-28 14:24:09 UTC
*** Bug 29277 has been marked as a duplicate of this bug. ***
Comment 5 Lukáš Tinkl 2004-03-28 14:27:18 UTC
Just for the record, it would be nice to put http://www.keelhaul.demon.co.uk/linux/#symlink into CVS...
Comment 6 Sridhar Dhanapalan 2004-04-01 14:37:23 UTC
This bug appears to be duplicate of bug 8580.
Comment 7 Michael Jahn 2004-09-09 00:38:59 UTC
*** Bug 8581 has been marked as a duplicate of this bug. ***
Comment 8 Mathieu Jobin 2004-09-25 02:52:49 UTC
using 3.3
RMB->properties on a symlink show then destination
why can't I modify it ?

Comment 9 Hagai Kariti 2005-08-13 12:29:30 UTC
In 3.4, the properties dialog of a symlink doesn't make much sense...
Say I have a symlink to a dir, when I see it's properties I see the name of the symlink, it's location and where it points to (that's good), but also "Type: Folder" - BAD! It should read something like "Type: Symbolic link" and then "Points to: /path/of/destination (Folder)" or something like that...
Comment 10 José Luis Tallón 2005-08-14 21:25:34 UTC
This is indeed a dup of #8850... but the point given there is quite interesting. Please take a look at the possibility of integrating the functionality present in http://kde-apps.org/content/show.php?content=11626 into the properties dialog.

Thanks for a wonderful desktop!
Comment 11 FiNeX 2009-09-09 00:32:28 UTC
Managing symlinks will be available in KDE 4.4.
Comment 12 Lucas Willems 2019-03-15 15:24:30 UTC
I don't understand how we can create or edit symlinks...
It seems like it is not implemented.