Bug 223178 - KWin crashes when attempting to open "analyze" menu in Adobe Reader [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: KWin crashes when attempting to open "analyze" menu in Adobe Reader [KWin::Sc...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-17 18:33 UTC by Storm Walden
Modified: 2010-01-18 09:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Storm Walden 2010-01-17 18:33:49 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-18-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
When trying to open the "analyze" menu in the Adobe PDF reader (in the Firefox browser), KWin crashed. This has happened each time, thus far.

The crash can be reproduced everytime.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x257cef0, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007effa284b78c in KWin::Scene::paintSimpleScreen (this=0x1f87dd0, orig_mask=<value optimized out>, region=<value optimized out>) at ../../kwin/scene.cpp:237
#7  0x00007effa28491e5 in KWin::Scene::finalPaintScreen (this=0x1f87dd0, mask=8, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:176
#8  0x00007effa2860096 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=8, region=) at ../../kwin/effects.cpp:126
#9  0x00007eff8f8ce42f in KWin::LogoutEffect::paintScreen (this=0x207df50, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#10 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#11 0x00007eff8f8ed610 in KWin::ShadowEffect::paintScreen (this=0x200c9a0, mask=8, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#12 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#13 0x00007eff8f8d4b02 in KWin::PresentWindowsEffect::paintScreen (this=0x207a0e0, mask=8, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#14 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#15 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#17 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#19 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#21 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#23 0x00007eff8f916307 in KWin::FlipSwitchEffect::paintScreen (this=0x1fe30f0, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:146
#24 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#25 0x00007eff8f8b87a2 in KWin::BoxSwitchEffect::paintScreen (this=0x207bf70, mask=8, region=) at ../../../kwin/effects/boxswitch/boxswitch.cpp:140
#26 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#27 0x00007eff8f9070c2 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/cube/cube.cpp:697
#28 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#29 0x00007eff8f90e412 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/cube/cubeslide.cpp:105
#30 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#31 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#33 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#34 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#35 0x00007eff8f8fe534 in KWin::CoverSwitchEffect::paintScreen (this=0x2083740, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#36 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#37 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#39 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#41 0x00007effa107d01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007effa286012e in KWin::EffectsHandlerImpl::paintScreen (this=0x1f8c7b0, mask=8, region=) at ../../kwin/effects.cpp:122
#43 0x00007effa284b2f5 in KWin::Scene::paintScreen (this=0x1f87dd0, mask=0x7fffa8184f1c, region=0x7fffa8185040) at ../../kwin/scene.cpp:134
#44 0x00007effa28599c0 in KWin::SceneOpenGL::paint (this=0x1f87dd0, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#45 0x00007effa2845c97 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#46 0x00007effa27d13ce in KWin::Workspace::qt_metacall (this=0x1f6e4c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa81851f0) at ./workspace.moc:535
#47 0x00007eff9e399dc3 in QMetaObject::activate (sender=0x1f6e930, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x12) at kernel/qobject.cpp:3294
#48 0x00007eff9e396a33 in QObject::event (this=0x1f6e930, e=0x7fffa81858b0) at kernel/qobject.cpp:1224
#49 0x00007eff9ead3e8c in QApplicationPrivate::notify_helper (this=0x1d9d240, receiver=0x1f6e930, e=0x7fffa81858b0) at kernel/qapplication.cpp:4242
#50 0x00007eff9eada48d in QApplication::notify (this=0x7fffa8185c10, receiver=0x1f6e930, e=0x7fffa81858b0) at kernel/qapplication.cpp:4125
#51 0x00007effa2018666 in KApplication::notify (this=0x7fffa8185c10, receiver=0x1f6e930, event=0x7fffa81858b0) at ../../kdeui/kernel/kapplication.cpp:302
#52 0x00007eff9e38704c in QCoreApplication::notifyInternal (this=0x7fffa8185c10, receiver=0x1f6e930, event=0x7fffa81858b0) at kernel/qcoreapplication.cpp:704
#53 0x00007eff9e3b3d52 in QCoreApplication::sendEvent (this=0x1da1070) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QTimerInfoList::activateTimers (this=0x1da1070) at kernel/qeventdispatcher_unix.cpp:603
#55 0x00007eff9e3b0958 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#56 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#57 0x00007eff98923bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#58 0x00007eff98927598 in ?? () from /lib/libglib-2.0.so.0
#59 0x00007eff989276c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#60 0x00007eff9e3b0623 in QEventDispatcherGlib::processEvents (this=0x1d836d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#61 0x00007eff9eb822fe in QGuiEventDispatcherGlib::processEvents (this=0x7fffa8183140, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#62 0x00007eff9e385972 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#63 0x00007eff9e385d4c in QEventLoop::exec (this=0x7fffa8185b50, flags=) at kernel/qeventloop.cpp:201
#64 0x00007eff9e389a8b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#65 0x00007effa27ea98e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#66 0x00007effa244babd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffa8186118) at libc-start.c:220
#67 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 223061, bug 222040, bug 220810, bug 220633, bug 220369.

Reported using DrKonqi
Comment 1 Martin Flöser 2010-01-18 09:25:58 UTC

*** This bug has been marked as a duplicate of bug 216908 ***