Bug 223061 - KWin crashes when opening FileLight [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: KWin crashes when opening FileLight [KWin::Scene::Window::buildQuads, KWin::S...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-17 01:42 UTC by Storm Walden
Modified: 2010-02-07 21:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.42 KB, text/plain)
2010-02-07 21:04 UTC, Storm Walden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Storm Walden 2010-01-17 01:42:57 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-18-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
KWin crashes immediately upon attempting to run the application "filelight" (KMenu -> applications -> utilities -> filelight). The application ran, and kwin was successfully restarted.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x294a340, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007fedbd42778c in KWin::Scene::paintSimpleScreen (this=0x2305350, orig_mask=<value optimized out>, region=<value optimized out>) at ../../kwin/scene.cpp:237
#7  0x00007fedbd4251e5 in KWin::Scene::finalPaintScreen (this=0x2305350, mask=8, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:176
#8  0x00007fedbd43c096 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=8, region=) at ../../kwin/effects.cpp:126
#9  0x00007fedadc1a42f in KWin::LogoutEffect::paintScreen (this=0x2398aa0, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#10 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#11 0x00007fedadc39610 in KWin::ShadowEffect::paintScreen (this=0x23522d0, mask=8, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#12 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#13 0x00007fedadc20b02 in KWin::PresentWindowsEffect::paintScreen (this=0x2409140, mask=8, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#14 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#15 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#17 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#19 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#21 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#23 0x00007fedadc62307 in KWin::FlipSwitchEffect::paintScreen (this=0x236abe0, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:146
#24 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#25 0x00007fedadc047a2 in KWin::BoxSwitchEffect::paintScreen (this=0x2401b70, mask=8, region=) at ../../../kwin/effects/boxswitch/boxswitch.cpp:140
#26 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#27 0x00007fedadc530c2 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/cube/cube.cpp:697
#28 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#29 0x00007fedadc5a412 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/cube/cubeslide.cpp:105
#30 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#31 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#33 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#34 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#35 0x00007fedadc4a534 in KWin::CoverSwitchEffect::paintScreen (this=0x23f9cc0, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#36 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#37 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#39 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#41 0x00007fedbbc5901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007fedbd43c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x2309510, mask=8, region=) at ../../kwin/effects.cpp:122
#43 0x00007fedbd4272f5 in KWin::Scene::paintScreen (this=0x2305350, mask=0x7fff9abbd8ac, region=0x7fff9abbd9d0) at ../../kwin/scene.cpp:134
#44 0x00007fedbd4359c0 in KWin::SceneOpenGL::paint (this=0x2305350, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#45 0x00007fedbd421c97 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#46 0x00007fedbd3ad3ce in KWin::Workspace::qt_metacall (this=0x22ea650, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff9abbdb80) at ./workspace.moc:535
#47 0x00007fedb8f75dc3 in QMetaObject::activate (sender=0x22eaac0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2c) at kernel/qobject.cpp:3294
#48 0x00007fedb8f72a33 in QObject::event (this=0x22eaac0, e=0x7fff9abbe240) at kernel/qobject.cpp:1224
#49 0x00007fedb96afe8c in QApplicationPrivate::notify_helper (this=0x21a7240, receiver=0x22eaac0, e=0x7fff9abbe240) at kernel/qapplication.cpp:4242
#50 0x00007fedb96b648d in QApplication::notify (this=0x7fff9abbe5a0, receiver=0x22eaac0, e=0x7fff9abbe240) at kernel/qapplication.cpp:4125
#51 0x00007fedbcbf4666 in KApplication::notify (this=0x7fff9abbe5a0, receiver=0x22eaac0, event=0x7fff9abbe240) at ../../kdeui/kernel/kapplication.cpp:302
#52 0x00007fedb8f6304c in QCoreApplication::notifyInternal (this=0x7fff9abbe5a0, receiver=0x22eaac0, event=0x7fff9abbe240) at kernel/qcoreapplication.cpp:704
#53 0x00007fedb8f8fd52 in QCoreApplication::sendEvent (this=0x21ab070) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QTimerInfoList::activateTimers (this=0x21ab070) at kernel/qeventdispatcher_unix.cpp:603
#55 0x00007fedb8f8c958 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#56 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#57 0x00007fedb34ffbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#58 0x00007fedb3503598 in ?? () from /lib/libglib-2.0.so.0
#59 0x00007fedb35036c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#60 0x00007fedb8f8c623 in QEventDispatcherGlib::processEvents (this=0x218d6d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#61 0x00007fedb975e2fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff9abbbad0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#62 0x00007fedb8f61972 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#63 0x00007fedb8f61d4c in QEventLoop::exec (this=0x7fff9abbe4e0, flags=) at kernel/qeventloop.cpp:201
#64 0x00007fedb8f65a8b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#65 0x00007fedbd3c698e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#66 0x00007fedbd027abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff9abbeaa8) at libc-start.c:220
#67 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 222040, bug 220810, bug 220633, bug 220369, bug 220038.

Reported using DrKonqi
Comment 1 Martin Flöser 2010-01-17 10:02:40 UTC

*** This bug has been marked as a duplicate of bug 216908 ***
Comment 2 Storm Walden 2010-02-07 21:04:15 UTC
Created attachment 40593 [details]
New crash information added by DrKonqi