Bug 220633 - Kwin crahsed while installing packages [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crahsed while installing packages [KWin::Scene::Window::buildQuads, KWin...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-30 04:12 UTC by Storm Walden
Modified: 2009-12-30 10:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Storm Walden 2009-12-30 04:12:19 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
I was installing packages from the repositories (specifically, packages related to the 7-zip archiving tool), and Kwin suddenly crashed when the installation of the packages was complete.

Kwin had also been crashing during normal log-out...

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x2344120, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007fc0a078778c in KWin::Scene::paintSimpleScreen (this=0x1bf5f80, orig_mask=<value optimized out>, region=<value optimized out>) at ../../kwin/scene.cpp:237
#7  0x00007fc0a07851e5 in KWin::Scene::finalPaintScreen (this=0x1bf5f80, mask=0, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:176
#8  0x00007fc0a079c096 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=0, region=) at ../../kwin/effects.cpp:126
#9  0x00007fc090f7c42f in KWin::LogoutEffect::paintScreen (this=0x1ca06b0, mask=0, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#10 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#11 0x00007fc090f9b610 in KWin::ShadowEffect::paintScreen (this=0x1c895b0, mask=0, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#12 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#13 0x00007fc090f82b02 in KWin::PresentWindowsEffect::paintScreen (this=0x1cb5dc0, mask=0, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#14 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#15 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#17 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#19 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#21 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#23 0x00007fc090fc4307 in KWin::FlipSwitchEffect::paintScreen (this=0x1c52970, mask=0, region=<value optimized out>, data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:146
#24 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#25 0x00007fc090f667a2 in KWin::BoxSwitchEffect::paintScreen (this=0x1c98f90, mask=0, region=) at ../../../kwin/effects/boxswitch/boxswitch.cpp:140
#26 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#27 0x00007fc090fb50c2 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=0, region=) at ../../../kwin/effects/cube/cube.cpp:697
#28 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#29 0x00007fc090fbc412 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=0, region=) at ../../../kwin/effects/cube/cubeslide.cpp:105
#30 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#31 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#33 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#34 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#35 0x00007fc090fac534 in KWin::CoverSwitchEffect::paintScreen (this=0x1c9bb10, mask=0, region=<value optimized out>, data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#36 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#37 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#39 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#41 0x00007fc09efb901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007fc0a079c12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1becc40, mask=0, region=) at ../../kwin/effects.cpp:122
#43 0x00007fc0a07872f5 in KWin::Scene::paintScreen (this=0x1bf5f80, mask=0x7fff6927f2ac, region=0x7fff6927f3d0) at ../../kwin/scene.cpp:134
#44 0x00007fc0a07959c0 in KWin::SceneOpenGL::paint (this=0x1bf5f80, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#45 0x00007fc0a0781c97 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#46 0x00007fc0a070d3ce in KWin::Workspace::qt_metacall (this=0x1bd1c50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff6927f580) at ./workspace.moc:535
#47 0x00007fc09c2d5dc3 in QMetaObject::activate (sender=0x1bd20c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x13a) at kernel/qobject.cpp:3294
#48 0x00007fc09c2d2a33 in QObject::event (this=0x1bd20c0, e=0x7fff6927fc40) at kernel/qobject.cpp:1224
#49 0x00007fc09ca0fe8c in QApplicationPrivate::notify_helper (this=0x1a90240, receiver=0x1bd20c0, e=0x7fff6927fc40) at kernel/qapplication.cpp:4242
#50 0x00007fc09ca1648d in QApplication::notify (this=0x7fff6927ffa0, receiver=0x1bd20c0, e=0x7fff6927fc40) at kernel/qapplication.cpp:4125
#51 0x00007fc09ff54666 in KApplication::notify (this=0x7fff6927ffa0, receiver=0x1bd20c0, event=0x7fff6927fc40) at ../../kdeui/kernel/kapplication.cpp:302
#52 0x00007fc09c2c304c in QCoreApplication::notifyInternal (this=0x7fff6927ffa0, receiver=0x1bd20c0, event=0x7fff6927fc40) at kernel/qcoreapplication.cpp:704
#53 0x00007fc09c2efd52 in QCoreApplication::sendEvent (this=0x1a94070) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QTimerInfoList::activateTimers (this=0x1a94070) at kernel/qeventdispatcher_unix.cpp:603
#55 0x00007fc09c2ec958 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#56 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#57 0x00007fc09685fbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#58 0x00007fc096863598 in ?? () from /lib/libglib-2.0.so.0
#59 0x00007fc0968636c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#60 0x00007fc09c2ec623 in QEventDispatcherGlib::processEvents (this=0x1a766d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#61 0x00007fc09cabe2fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff6927d4d0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#62 0x00007fc09c2c1972 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#63 0x00007fc09c2c1d4c in QEventLoop::exec (this=0x7fff6927fee0, flags=) at kernel/qeventloop.cpp:201
#64 0x00007fc09c2c5a8b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#65 0x00007fc0a072698e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#66 0x00007fc0a0387abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff692804a8) at libc-start.c:220
#67 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 220369, bug 220038, bug 219607, bug 219364, bug 219255.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-30 10:13:17 UTC

*** This bug has been marked as a duplicate of bug 216908 ***