Bug 220810 - kWin crashes at the end of installing packages [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: kWin crashes at the end of installing packages [KWin::Scene::Window::buildQua...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-31 14:52 UTC by Nikos
Modified: 2009-12-31 14:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos 2009-12-31 14:52:00 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic-pae i686
Distribution: Ubuntu 9.10

-- Information about the crash:
When using Synaptic to install/update packages, kWin sometimes crashes at the end of installation.

The crash can be reproduced some of the times.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0xb787148a in KWin::Scene::Window::buildQuads (this=0x8316a40, force=false) at ../../kwin/scene.cpp:485
#7  0xb78725ce in KWin::Scene::paintSimpleScreen (this=0x837d060, orig_mask=0, region=...) at ../../kwin/scene.cpp:237
#8  0xb786fdf9 in KWin::Scene::finalPaintScreen (this=0x837d060, mask=0, region=..., data=...) at ../../kwin/scene.cpp:176
#9  0xb788965c in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:126
#10 0xb05b9e47 in KWin::LogoutEffect::paintScreen (this=0x8279f38, mask=0, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:196
#11 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#12 0xb05da43f in KWin::ShadowEffect::paintScreen (this=0x837da18, mask=<value optimized out>, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:182
#13 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#14 0xb05c06ff in KWin::PresentWindowsEffect::paintScreen (this=0x83a21c0, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#15 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#16 0xb6facd96 in KWin::Effect::paintScreen (this=0x8383e78, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#17 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#18 0xb6facd96 in KWin::Effect::paintScreen (this=0x82c6c38, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#20 0xb6facd96 in KWin::Effect::paintScreen (this=0x84ae068, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#21 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#22 0xb6facd96 in KWin::Effect::paintScreen (this=0x839f6d0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#23 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#24 0xb6facd96 in KWin::Effect::paintScreen (this=0x83229a0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#25 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#26 0xb6facd96 in KWin::Effect::paintScreen (this=0x8345898, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#27 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#28 0xb05a54a3 in KWin::DesktopGridEffect::paintScreen (this=0x8308638, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#29 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#30 0xb6facd96 in KWin::Effect::paintScreen (this=0x836c318, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#32 0xb6facd96 in KWin::Effect::paintScreen (this=0x8399e48, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#34 0xb6facd96 in KWin::Effect::paintScreen (this=0x82c6840, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#36 0xb6facd96 in KWin::Effect::paintScreen (this=0x84a4e28, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#38 0xb05ecdfc in KWin::CoverSwitchEffect::paintScreen (this=0x84ae080, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#39 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#40 0xb6facd96 in KWin::Effect::paintScreen (this=0x83229c8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#41 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#42 0xb6facd96 in KWin::Effect::paintScreen (this=0x829f988, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#43 0xb78896e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x8355668, mask=0, region=..., data=...) at ../../kwin/effects.cpp:122
#44 0xb78720e4 in KWin::Scene::paintScreen (this=0x837d060, mask=0xbfc1d6b8, region=0xbfc1d784) at ../../kwin/scene.cpp:134
#45 0xb7881e9a in KWin::SceneOpenGL::paint (this=0x837d060, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:747
#46 0xb786c224 in KWin::Workspace::performCompositing (this=0x8347cb0) at ../../kwin/composite.cpp:424
#47 0xb77e8736 in KWin::Workspace::qt_metacall (this=0x8347cb0, _c=QMetaObject::InvokeMetaMethod, _id=173, _a=0xbfc1d8ac) at ./workspace.moc:535
#48 0xb5ee111a in QMetaObject::metacall (object=0x8347cb0, cl=QMetaObject::InvokeMetaMethod, idx=173, argv=0xbfc1d8ac) at kernel/qmetaobject.cpp:237
#49 0xb5eef89b in QMetaObject::activate (sender=0x8347f38, m=0xb5ff05a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3294
#50 0xb5f411c7 in QTimer::timeout (this=0x8347f38) at .moc/release-shared/moc_qtimer.cpp:134
#51 0xb5ef7b4e in QTimer::timerEvent (this=0x8347f38, e=0xbfc1dd90) at kernel/qtimer.cpp:271
#52 0xb5eec704 in QObject::event (this=0x8347f38, e=0xbfc1c3dc) at kernel/qobject.cpp:1224
#53 0xb61a219c in QApplicationPrivate::notify_helper (this=0x823e738, receiver=0x8347f38, e=0xbfc1dd90) at kernel/qapplication.cpp:4242
#54 0xb61a8df7 in QApplication::notify (this=0xbfc1e108, receiver=0x8347f38, e=0xbfc1dd90) at kernel/qapplication.cpp:3661
#55 0xb74a4f8a in KApplication::notify (this=0xbfc1e108, receiver=0x8347f38, event=0xbfc1dd90) at ../../kdeui/kernel/kapplication.cpp:302
#56 0xb78021ff in KWin::Application::notify (this=0xbfc1e108, o=0x8347f38, e=0xbfc1dd90) at ../../kwin/main.cpp:370
#57 0xb5edbeab in QCoreApplication::notifyInternal (this=0xbfc1e108, receiver=0x8347f38, event=0xbfc1dd90) at kernel/qcoreapplication.cpp:704
#58 0xb5f0b286 in QCoreApplication::sendEvent (this=0x8241a34) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#59 QTimerInfoList::activateTimers (this=0x8241a34) at kernel/qeventdispatcher_unix.cpp:603
#60 0xb5f07f17 in timerSourceDispatch (source=0x82415a8) at kernel/qeventdispatcher_glib.cpp:184
#61 idleTimerSourceDispatch (source=0x82415a8) at kernel/qeventdispatcher_glib.cpp:231
#62 0xb2e16e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#63 0xb2e1a730 in ?? () from /lib/libglib-2.0.so.0
#64 0xb2e1a863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#65 0xb5f07bd5 in QEventDispatcherGlib::processEvents (this=0x823e620, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#66 0xb625fb75 in QGuiEventDispatcherGlib::processEvents (this=0x823e620, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#67 0xb5eda4c9 in QEventLoop::processEvents (this=0xbfc1e054, flags=) at kernel/qeventloop.cpp:149
#68 0xb5eda91a in QEventLoop::exec (this=0xbfc1e054, flags=...) at kernel/qeventloop.cpp:201
#69 0xb5edeb0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#70 0xb61a2237 in QApplication::exec () at kernel/qapplication.cpp:3570
#71 0xb7803e10 in kdemain (argc=1, argv=0xbfc1e314) at ../../kwin/main.cpp:526
#72 0x080485cb in main (argc=1, argv=0xbfc1e314) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 216908.

Possible duplicates by query: bug 220633, bug 220369, bug 220038, bug 219607, bug 219364.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-31 14:54:58 UTC

*** This bug has been marked as a duplicate of bug 216908 ***