Bug 222299 - Konqueror crashed after pressing ctrl-tab
Summary: Konqueror crashed after pressing ctrl-tab
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 22:48 UTC by Federico De Malmayne Duppa
Modified: 2010-03-08 16:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Federico De Malmayne Duppa 2010-01-11 22:48:15 UTC
Application: konqueror (4.3.90 (KDE 4.3.90 (KDE 4.4 RC1)))
KDE Platform Version: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
i had 2 websites opened, after ctrl-tab it crashes.

I'm using kubuntu 9.10 with ppa repos (kde 4.4 rc1)

if you need more info I can provide.. It happens every single time.

The crash can be reproduced every time.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77e3700 (LWP 5294))]

Thread 2 (Thread 0xafff3b70 (LWP 5850)):
#0  0x00d48422 in __kernel_vsyscall ()
#1  0x00cea142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0103c28f in QWaitConditionPrivate::wait (this=0x853f314, mutex=0x853f310, time=30000) at thread/qwaitcondition_unix.cpp:85
#3  QWaitCondition::wait (this=0x853f314, mutex=0x853f310, time=30000) at thread/qwaitcondition_unix.cpp:159
#4  0x0103020b in QThreadPoolThread::run (this=0x8a825a8) at concurrent/qthreadpool.cpp:140
#5  0x0103b3ae in QThreadPrivate::start (arg=0x8a825a8) at thread/qthread_unix.cpp:244
#6  0x00ce580e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x007c18de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77e3700 (LWP 5294)):
[KCrash Handler]
#6  0x020df2a9 in QTabWidget::qt_metacall (this=0x84b5d98, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbf8b19fc) at .moc/release-shared/moc_qtabwidget.cpp:143
#7  0x00b9c66a in KTabWidget::qt_metacall (this=0x84b5d98, _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0xbf8b19fc) at ./ktabwidget.moc:128
#8  0x06fd4c1a in KonqFrameTabs::qt_metacall (this=0x84b5d98, _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0xbf8b19fc) at ./konqtabs.moc:100
#9  0x0114211a in QMetaObject::metacall (object=0x84b5d98, cl=3213564412, idx=37, argv=0xbf8b19fc) at kernel/qmetaobject.cpp:237
#10 0x0115089b in QMetaObject::activate (sender=0x84b5ee8, m=0x7054720, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3294
#11 0x06fcc217 in KonqFrameContainer::ctrlTabPressed (this=0x84b5ee8) at ./konqframecontainer.moc:88
#12 0x06fc8cfd in KonqFrame::eventFilter (this=0x9143630, ev=0xbf8b1e74) at ../../../../apps/konqueror/src/konqframe.cpp:180
#13 0x0113c14a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x81fc8e8, receiver=0x9122048, event=0xbf8b1e74) at kernel/qcoreapplication.cpp:819
#14 0x01c0e179 in QApplicationPrivate::notify_helper (this=0x81fc8e8, receiver=0x9122048, e=0xbf8b1e74) at kernel/qapplication.cpp:4238
#15 0x01c1680e in QApplication::notify (this=0xbf8b2a44, receiver=0x9122048, e=0xbf8b1e74) at kernel/qapplication.cpp:3720
#16 0x00a8167a in KApplication::notify (this=0xbf8b2a44, receiver=0x9545790, event=0xbf8b1e74) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x0113ceab in QCoreApplication::notifyInternal (this=0xbf8b2a44, receiver=0x9545790, event=0xbf8b1e74) at kernel/qcoreapplication.cpp:704
#18 0x01c0f07e in QCoreApplication::sendSpontaneousEvent (receiver=0x9545790, event=0x84b5d98) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#19 qt_sendSpontaneousEvent (receiver=0x9545790, event=0x84b5d98) at kernel/qapplication.cpp:5219
#20 0x01cc6840 in QKeyMapper::sendKeyEvent (keyWidget=0x9545790, grab=false, type=QEvent::KeyPress, code=16777217, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=23, nativeVirtualKey=65289, nativeModifiers=4) at kernel/qkeymapper_x11.cpp:1861
#21 0x01cc8d89 in QKeyMapperPrivate::translateKeyEvent (this=0x8227178, keyWidget=0x9545790, event=0xbf8b252c, grab=16) at kernel/qkeymapper_x11.cpp:1831
#22 0x01c9c4c7 in QApplication::x11ProcessEvent (this=0xbf8b2a44, event=0xbf8b252c) at kernel/qapplication_x11.cpp:3394
#23 0x01ccc04a in x11EventSourceDispatch (s=0x81ffa70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#24 0x035c6e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x035ca730 in ?? () from /lib/libglib-2.0.so.0
#26 0x035ca863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x01168bd5 in QEventDispatcherGlib::processEvents (this=0x81fc8c8, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#28 0x01ccbb75 in QGuiEventDispatcherGlib::processEvents (this=0x81fc8c8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x0113b4c9 in QEventLoop::processEvents (this=0xbf8b2824, flags=) at kernel/qeventloop.cpp:149
#30 0x0113b91a in QEventLoop::exec (this=0xbf8b2824, flags=...) at kernel/qeventloop.cpp:201
#31 0x0113fb0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x01c0e237 in QApplication::exec () at kernel/qapplication.cpp:3570
#33 0x0703f88e in kdemain (argc=2, argv=0x81d7a88) at ../../../../apps/konqueror/src/konqmain.cpp:271
#34 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x81c77fc "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x81c7800 "federico-laptop;1263245492;756907;4442_TIME1167990") at ../../kinit/kinit.cpp:706
#35 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1198
#36 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1391
#37 0x0804fe27 in main (argc=4, argv=0xbf8b3624, envp=0xbf8b3638) at ../../kinit/kinit.cpp:1830

This bug may be a duplicate of or related to bug 203809.

Possible duplicates by query: bug 217568, bug 214360, bug 205969, bug 203809, bug 200077.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-01-14 21:59:04 UTC
Thanks for the bug report! I can confirm the crash in trunk (r1072715): Open Konqueror, press Ctrl-T to open a new tab, click the first tab, press Ctrl-Tab.

Probably related to bug 203809, but the backtrace of that one looks a bit different (does not contain KonqFrameContainer::ctrlTabPressed)...
Comment 2 Frank Reininghaus 2010-03-08 16:01:15 UTC
I cannot reproduce the crash any more in 4.3.5 or current trunk, so I think it's a duplicate of bug 203809 which has been fixed a while ago :-)

*** This bug has been marked as a duplicate of bug 203809 ***