Bug 205969 - crash on press ctrl+tab
Summary: crash on press ctrl+tab
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-02 11:06 UTC by Pavel Mlčoch
Modified: 2009-09-02 11:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Mlčoch 2009-09-02 11:06:16 UTC
Application that crashed: konqueror
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-8-generic i686
Distribution: Ubuntu karmic (development branch)

What I was doing when the application crashed:
Konqeuror crash after I pressed Ctrl+Tab to switch the tab

 -- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[KCrash Handler]
#6  0x04051f39 in QTabWidget::qt_metacall (this=0x8864410, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbf91bc1c) at .moc/release-shared/moc_qtabwidget.cpp:137
#7  0x012c83aa in KTabWidget::qt_metacall (this=0x8864410, _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0xbf91bc1c) at ./ktabwidget.moc:124
#8  0x007ab99a in KonqFrameTabs::qt_metacall (this=0x8864410, _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0xbf91bc1c) at ./konqtabs.moc:94
#9  0x04fca253 in QMetaObject::activate (sender=0x8864670, from_signal_index=28, to_signal_index=28, argv=0x0) at kernel/qobject.cpp:3113
#10 0x04fcaeb2 in QMetaObject::activate (sender=0x8864670, m=0x846400, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#11 0x007a2fe7 in KonqFrameContainer::ctrlTabPressed (this=0x8864670) at ./konqframecontainer.moc:82
#12 0x0079fcdd in KonqFrame::eventFilter (this=0x8fdad60, ev=0xbf91c054) at ../../../../apps/konqueror/src/konqframe.cpp:180
#13 0x04fb382a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8527c40, receiver=0x903c8c0, event=0xbf91c054) at kernel/qcoreapplication.cpp:726
#14 0x03bccf1c in QApplicationPrivate::notify_helper (this=0x8527c40, receiver=0x903c8c0, e=0xbf91c054) at kernel/qapplication.cpp:4052
#15 0x03bd5768 in QApplication::notify (this=0xbf91dc74, receiver=0x903c8c0, e=0xbf91c054) at kernel/qapplication.cpp:3662
#16 0x011b8f7a in KApplication::notify (this=0xbf91dc74, receiver=0x88eabc8, event=0xbf91c054) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x04fb46bb in QCoreApplication::notifyInternal (this=0xbf91dc74, receiver=0x88eabc8, event=0xbf91c054) at kernel/qcoreapplication.cpp:610
#18 0x03bcde1e in QCoreApplication::sendSpontaneousEvent (receiver=0x88eabc8, event=0x8864410) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#19 qt_sendSpontaneousEvent (receiver=0x88eabc8, event=0x8864410) at kernel/qapplication.cpp:4958
#20 0x03c6a350 in QKeyMapper::sendKeyEvent (keyWidget=0x88eabc8, grab=false, type=QEvent::KeyPress, code=16777217, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=23, nativeVirtualKey=65289, nativeModifiers=20) at kernel/qkeymapper_x11.cpp:1861
#21 0x03c6c879 in QKeyMapperPrivate::translateKeyEvent (this=0x854f940, keyWidget=0x88eabc8, event=0xbf91d83c, grab=5) at kernel/qkeymapper_x11.cpp:1831
#22 0x03c40df7 in QApplication::x11ProcessEvent (this=0xbf91dc74, event=0xbf91d83c) at kernel/qapplication_x11.cpp:3443
#23 0x03c6e3f2 in x11EventSourceDispatch (s=0x852ae00, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#24 0x02d44d78 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x02d48620 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0x02d48753 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0x04fdf01c in QEventDispatcherGlib::processEvents (this=0x850f9d8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x03c6dad5 in QGuiEventDispatcherGlib::processEvents (this=0x850f9d8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x04fb2c69 in QEventLoop::processEvents (this=0xbf91db34, flags=) at kernel/qeventloop.cpp:149
#30 0x04fb30ba in QEventLoop::exec (this=0xbf91db34, flags=...) at kernel/qeventloop.cpp:201
#31 0x04fb552f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x03bccdc7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0081ff9f in kdemain (argc=1, argv=0xbf91e044) at ../../../../apps/konqueror/src/konqmain.cpp:271
#34 0x080485eb in main (argc=1, argv=0xbf91e044) at konqueror_dummy.cpp:3

Reported using DrKonqi
Comment 1 FiNeX 2009-09-02 11:13:17 UTC

*** This bug has been marked as a duplicate of bug 203809 ***