Bug 214360 - Pressing ctrl-tab in konqueror instantly crashes it
Summary: Pressing ctrl-tab in konqueror instantly crashes it
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-13 10:41 UTC by Nikita Bige
Modified: 2009-11-29 22:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Bige 2009-11-13 10:41:01 UTC
Application that crashed: konqueror
Version of the application: 4.3.3 (KDE 4.3.3)
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.6.0
Operating System: Linux 2.6.30.9-96.fc11.x86_64 x86_64

What I was doing when the application crashed:
How to reproduce the problem...

Start konqueror
press [ctrl][tab] 



 -- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4cff36b820 (LWP 9654))]

Thread 3 (Thread 0x7f4cf0f88910 (LWP 9663)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x000000387ce727f2 in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x000000387ce67f71 in QThreadPoolThread::run (this=0x34899f0) at concurrent/qthreadpool.cpp:140
#4  0x000000387ce718d5 in QThreadPrivate::start (arg=0x34899f0) at thread/qthread_unix.cpp:244
#5  0x000000347380686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x0000003472cde3bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4ceb543910 (LWP 9666)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x000000387ce727f2 in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x000000387ce67f71 in QThreadPoolThread::run (this=0x39b4e10) at concurrent/qthreadpool.cpp:140
#4  0x000000387ce718d5 in QThreadPrivate::start (arg=0x39b4e10) at thread/qthread_unix.cpp:244
#5  0x000000347380686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x0000003472cde3bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4cff36b820 (LWP 9654)):
[KCrash Handler]
#5  0x0000003516fff291 in QTabWidget::qt_metacall (this=0x26de650, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5b734550) at .moc/release-shared/moc_qtabwidget.cpp:143
#6  0x00007f4cffd98b75 in KTabWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkdeui.so.5
#7  0x00007f4d00eabb85 in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib64/libkdeinit4_konqueror.so
#8  0x000000387cf7675a in QMetaObject::activate (sender=0x2db9ad0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff5b734550) at kernel/qobject.cpp:3398
#9  0x00007f4d00ea0b3a in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib64/libkdeinit4_konqueror.so
#10 0x000000387cf62a97 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x3cc4e50, event=0x7fff5b734aa0) at kernel/qcoreapplication.cpp:819
#11 0x0000003516ba9b7c in QApplicationPrivate::notify_helper (this=0x22cc570, receiver=0x3cc4e50, e=0x7fff5b734aa0) at kernel/qapplication.cpp:4273
#12 0x0000003516bb097c in QApplication::notify (this=<value optimized out>, receiver=0x3cc4e50, e=0x7fff5b734aa0) at kernel/qapplication.cpp:3761
#13 0x00007f4cffca7be6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#14 0x000000387cf6367c in QCoreApplication::notifyInternal (this=0x7fff5b735b90, receiver=0x3bf4a10, event=0x7fff5b734aa0) at kernel/qcoreapplication.cpp:704
#15 0x0000003516c483aa in QKeyMapper::sendKeyEvent (keyWidget=0x3bf4a10, grab=<value optimized out>, type=QEvent::KeyPress, code=16777217, modifiers=<value optimized out>, text=@0x7fff5b734cc0, 
    autorepeat=false, count=1, nativeScanCode=23, nativeVirtualKey=65289, nativeModifiers=20) at kernel/qkeymapper_x11.cpp:1861
#16 0x0000003516c4a940 in QKeyMapperPrivate::translateKeyEvent (this=0x7fff5b734c80, keyWidget=0x3bf4a10, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1831
#17 0x0000003516c24654 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff5b735670) at kernel/qapplication_x11.cpp:3425
#18 0x0000003516c4d432 in x11EventSourceDispatch (s=0x22d0310, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#19 0x0000003d9f43790e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#20 0x0000003d9f43b0e8 in ?? () from /lib64/libglib-2.0.so.0
#21 0x0000003d9f43b20a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#22 0x000000387cf8c833 in QEventDispatcherGlib::processEvents (this=0x22b0880, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#23 0x0000003516c4d01e in QGuiEventDispatcherGlib::processEvents (this=0x2dba100, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#24 0x000000387cf61fc2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#25 0x000000387cf6239c in QEventLoop::exec (this=0x7fff5b7359a0, flags={i = 0}) at kernel/qeventloop.cpp:201
#26 0x000000387cf647a9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#27 0x00007f4d00f145d3 in kdemain () from /usr/lib64/libkdeinit4_konqueror.so
#28 0x0000003472c1ea2d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff5b7365a8) at libc-start.c:220
#29 0x0000000000400759 in _start ()

Reported using DrKonqi
Comment 1 Raphael Kubo da Costa 2009-11-16 05:48:01 UTC
Confirmed here with trunk.
Comment 2 Raphael Kubo da Costa 2009-11-16 05:49:45 UTC
The functions leading to {Q,K}TabWidget::qt_metacall are different here. Backtrace:

Application: Konqueror (konqueror), signal: Segmentation fault
[KCrash Handler]
#6  0xb61a7ef0 in QTabWidget::qt_metacall (this=0x8c7ec98, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfb393b8) at .moc/debug-shared/moc_qtabwidget.cpp:143
#7  0xb70f46ba in KTabWidget::qt_metacall (this=0x8c7ec98, _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0xbfb393b8) at /home/kubo/kde4/src/build/kdelibs/kdeui/ktabwidget.moc:128
#8  0xb7806fca in KonqFrameTabs::qt_metacall (this=0x8c7ec98, _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0xbfb393b8) at /home/kubo/kde4/src/build/kdebase/apps/konqueror/src/konqtabs.moc:100
#9  0xb690f034 in QMetaObject::metacall (object=0x8c7ec98, cl=QMetaObject::InvokeMetaMethod, idx=37, argv=0xbfb393b8) at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#10 0xb69230dd in QMetaObject::activate (sender=0x8c7fe80, m=0xb78aea20, local_signal_index=0, argv=0x0) at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qobject.cpp:3274
#11 0xb78032f7 in KonqFrameContainer::ctrlTabPressed (this=0x8c7fe80) at /home/kubo/kde4/src/build/kdebase/apps/konqueror/src/konqframecontainer.moc:88
#12 0xb78002cd in KonqFrame::eventFilter (this=0x8ccd9e8, ev=0xbfb3993c) at /home/kubo/kde4/src/kdebase/apps/konqueror/src/konqframe.cpp:180
#13 0xb6907d5f in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x830fa40, receiver=0xb55a778, event=0xbfb3993c)
    at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:819
#14 0xb5c33f88 in QApplicationPrivate::notify_helper (this=0x830fa40, receiver=0xb55a778, e=0xbfb3993c) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qapplication.cpp:4238
#15 0xb5c31d29 in QApplication::notify (this=0xbfb3a53c, receiver=0xb55a778, e=0xbfb3993c) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qapplication.cpp:3720
#16 0xb6fe697b in KApplication::notify (this=0xbfb3a53c, receiver=0x8f689e8, event=0xbfb3993c) at /home/kubo/kde4/src/kdelibs/kdeui/kernel/kapplication.cpp:302
#17 0xb6907a81 in QCoreApplication::notifyInternal (this=0xbfb3a53c, receiver=0x8f689e8, event=0xbfb3993c) at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:704
#18 0xb5c36151 in QCoreApplication::sendSpontaneousEvent (receiver=0x8f689e8, event=0xbfb3993c) at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:218
#19 0xb5c342eb in qt_sendSpontaneousEvent (receiver=0x8f689e8, event=0xbfb3993c) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qapplication.cpp:5219
#20 0xb5d05a0a in QKeyMapper::sendKeyEvent (keyWidget=0x8f689e8, grab=false, type=QEvent::KeyPress, code=16777217, modifiers=..., text=..., autorepeat=false, count=1, nativeScanCode=23, 
    nativeVirtualKey=65289, nativeModifiers=20) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qkeymapper_x11.cpp:1861
#21 0xb5d0571c in QKeyMapperPrivate::translateKeyEvent (this=0x8336a90, keyWidget=0x8f689e8, event=0xbfb3a060, grab=false) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qkeymapper_x11.cpp:1831
#22 0xb5cd1815 in QApplication::x11ProcessEvent (this=0xbfb3a53c, event=0xbfb3a060) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:3394
#23 0xb5d0799d in x11EventSourceDispatch (s=0x8312cb0, callback=0, user_data=0x0) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:146
#24 0xb5366328 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0xb5369ba0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#26 0xb5369cd3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0xb693f4ac in QEventDispatcherGlib::processEvents (this=0x830fa20, flags=...) at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:407
#28 0xb5d07fc4 in QGuiEventDispatcherGlib::processEvents (this=0x830fa20, flags=...) at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:202
#29 0xb6904e8b in QEventLoop::processEvents (this=0xbfb3a33c, flags=...) at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#30 0xb6904fd0 in QEventLoop::exec (this=0xbfb3a33c, flags=...) at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qeventloop.cpp:201
#31 0xb690815d in QCoreApplication::exec () at /home/kubo/kde4/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:981
#32 0xb5c315cc in QApplication::exec () at /home/kubo/kde4/src/qt-copy/src/gui/kernel/qapplication.cpp:3570
#33 0xb7871d03 in kdemain (argc=1, argv=0xbfb3a864) at /home/kubo/kde4/src/kdebase/apps/konqueror/src/konqmain.cpp:257
#34 0x0804875b in main (argc=1, argv=0xbfb3a864) at /home/kubo/kde4/src/build/kdebase/apps/konqueror/src/konqueror_dummy.cpp:3
Comment 3 Raphael Kubo da Costa 2009-11-16 06:00:18 UTC
Valgrind log:

==8959== Invalid read of size 4
==8959==    at 0x58BFEF0: QTabWidget::qt_metacall(QMetaObject::Call, int, void**) (moc_qtabwidget.cpp:143)
==8959==    by 0x49836B9: KTabWidget::qt_metacall(QMetaObject::Call, int, void**) (ktabwidget.moc:128)
==8959==    by 0x407AFC9: KonqFrameTabs::qt_metacall(QMetaObject::Call, int, void**) (konqtabs.moc:100)
==8959==    by 0x5007033: QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) (qmetaobject.cpp:237)
==8959==    by 0x501B0DC: QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (qobject.cpp:3274)
==8959==    by 0x40772F6: KonqFrameContainer::ctrlTabPressed() (konqframecontainer.moc:88)
==8959==    by 0x40742CC: KonqFrame::eventFilter(QObject*, QEvent*) (konqframe.cpp:180)
==8959==    by 0x4FFFD5E: QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) (qcoreapplication.cpp:819)
==8959==    by 0x534BF87: QApplicationPrivate::notify_helper(QObject*, QEvent*) (qapplication.cpp:4238)
==8959==    by 0x5349D28: QApplication::notify(QObject*, QEvent*) (qapplication.cpp:3720)
==8959==    by 0x487597A: KApplication::notify(QObject*, QEvent*) (kapplication.cpp:302)
==8959==    by 0x4FFFA80: QCoreApplication::notifyInternal(QObject*, QEvent*) (qcoreapplication.cpp:704)
==8959==  Address 0x1c is not stack'd, malloc'd or (recently) free'd
==8959==
Comment 4 FiNeX 2009-11-29 22:39:23 UTC

*** This bug has been marked as a duplicate of bug 203809 ***