Bug 217568 - Konqueror crash when pressing Ctrl+tab - 5 photo tabs open
Summary: Konqueror crash when pressing Ctrl+tab - 5 photo tabs open
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-06 13:16 UTC by Xavier Mehrenberger
Modified: 2009-12-06 14:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Mehrenberger 2009-12-06 13:16:17 UTC
Application that crashed: konqueror
Version of the application: 4.3.4 (KDE 4.3.4)
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-ARCH x86_64

What I was doing when the application crashed:
Browsed to a folder containing photos (on a SDHC flash drive), opened ~5 in different tabs with middle-mouse button, then hit Ctrl-Tab to view the first photo. Photo previews (thumbnails) were enabled.

 -- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcbb28fa760 (LWP 3236))]

Thread 2 (Thread 0x7fcba10be710 (LWP 4009)):
#0  0x00007fcbae2e53e9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fcbafcb5bd2 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fcbafcabd32 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007fcbafcb4ba5 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007fcbae2e081a in start_thread () from /lib/libpthread.so.0
#5  0x00007fcbb219f8cd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcbb28fa760 (LWP 3236)):
[KCrash Handler]
#5  0x00007fcbaf6662b1 in QTabWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtGui.so.4
#6  0x00007fcbb0a9ed95 in KTabWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdeui.so.5
#7  0x00007fcbb2490785 in KonqFrameTabs::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdeinit4_konqueror.so
#8  0x00007fcbafdaed3c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#9  0x00007fcbb248577a in KonqFrame::eventFilter(QObject*, QEvent*) () from /usr/lib/libkdeinit4_konqueror.so
#10 0x00007fcbafd98f47 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#11 0x00007fcbaf24b04c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#12 0x00007fcbaf252e63 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x00007fcbb09ad8f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#14 0x00007fcbafd99bfc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007fcbaf2daaca in ?? () from /usr/lib/libQtGui.so.4
#16 0x00007fcbaf2dd011 in ?? () from /usr/lib/libQtGui.so.4
#17 0x00007fcbaf2b6494 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007fcbaf2de96c in ?? () from /usr/lib/libQtGui.so.4
#19 0x00007fcbabb491fe in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0x00007fcbabb4cbb8 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#21 0x00007fcbabb4cce0 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#22 0x00007fcbafdc2123 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#23 0x00007fcbaf2de14e in ?? () from /usr/lib/libQtGui.so.4
#24 0x00007fcbafd98532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007fcbafd98904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007fcbafd9aab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#27 0x00007fcbb24f9363 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#28 0x00007fcbb20efb6d in __libc_start_main () from /lib/libc.so.6
#29 0x0000000000400629 in _start ()

Reported using DrKonqi
Comment 1 FiNeX 2009-12-06 14:01:59 UTC

*** This bug has been marked as a duplicate of bug 203809 ***