Bug 211147 - More options for Default Applications
Summary: More options for Default Applications
Status: RESOLVED NOT A BUG
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_componentchooser (show other bugs)
Version: unspecified
Platform: unspecified Unspecified
: NOR wishlist with 208 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2009-10-19 23:33 UTC by KDE Brainstorm Submissions
Modified: 2020-01-22 16:12 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KDE Brainstorm Submissions 2009-10-19 23:33:33 UTC
Version:            (using KDE 4.3.2)
Installed from:    I Don't Know

I would like to see more options under Default Applications - namely, options that are typically harder to change in File Associations. For example, because there are many different image, audio and video formats, it would make sense to have a default image viewing program, default music/audio player and a default video player instead of finding each individual extension in File Associations.
As well as these three, it would also make sense to have a default Office suite choice. This would, for example, have KOffice and OpenOffice.org as options, then another, "Select application for each document type:" bullet that shows a small list of different document types and a button that opens the, "Select Application" dialogue. The list would include the likes of, "Word Processor", "Spreadsheets", "Presentation viewer", "Database application" etc. This would let people set e.g. Abiword as their default word processor, GNU spread (I think it's called) as the default spreadsheet manager and the rest as OpenOffice.org.

This would greatly ease the process of changing preferred applications. For example, some might prefer VLC media player or MPlayer to Dragon, but don't want the hassle of switching every single video filetype to use VLC.
Comment 1 KDE Brainstorm Submissions 2009-10-19 23:33:56 UTC
This feature request was originally submitted through KDE Brainstorm, and has been submitted to Bugzilla due to popular demand. Original idea: http://forum.kde.org/brainstorm.php?mode=idea&i=59451
Comment 2 Christoph Feck 2009-11-25 00:11:44 UTC
*** Bug 215938 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2010-03-30 08:51:01 UTC
*** Bug 232545 has been marked as a duplicate of this bug. ***
Comment 4 Y 2010-11-24 18:52:35 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Christoph Feck 2011-04-02 15:51:59 UTC
*** Bug 269928 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2013-02-02 21:54:23 UTC
*** Bug 312793 has been marked as a duplicate of this bug. ***
Comment 7 Patrick Silva 2017-10-15 13:37:34 UTC
An option to set default torrent client to open magnet links would nice too.
Comment 8 Patrick Silva 2017-10-15 13:38:12 UTC
An option to set default torrent client to open magnet links would be nice too.
Comment 9 Nate Graham 2020-01-22 16:12:12 UTC
Please open separate bugs for each individual request for a new entry here. Huge meta-bugs like this aren't actionable.