Bug 204340 - knetworkmanager does not show system connections
Summary: knetworkmanager does not show system connections
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: knetworkmanager (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal with 625 votes (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
: 207151 228181 232770 249954 251512 252664 257303 259148 270574 (view as bug list)
Depends on:
Blocks: 222563
  Show dependency treegraph
 
Reported: 2009-08-18 23:20 UTC by Martin Vidner
Modified: 2011-07-07 23:16 UTC (History)
36 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of the applet menu (51.52 KB, image/png)
2009-08-18 23:37 UTC, Martin Vidner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Vidner 2009-08-18 23:20:27 UTC
Version:           NetworkManager-kde4-0.9.svn1010399-88.1 (using KDE 4.3.0)
OS:                Linux
Installed from:    SuSE RPMs

knetworkmanager does not show the system wide connections. They were configured using nm-applet.

Here is how they are seen by cnetworkmanager:
(where it says "1" it is actually "true")
> ./cnetworkmanager --ci system,Auto\ frogs
Section                  | Property    | Value                               
-------------------------+-------------+-------------------------------------
802-11-wireless          |             |                                     
                         | ssid        | frogs                               
                         | fallback    | 1                                   
                         | security    | 802-11-wireless-security            
                         | mode        | infrastructure                      
                         | seen-bssids | 00:13:10:06:e3:77                   
connection               |             |                                     
                         | timestamp   | 1248301923                          
                         | autoconnect | 0                                   
                         | type        | 802-11-wireless                     
                         | uuid        | 75df2646-947d-4a5d-bbec-d7c05541c91b
                         | id          | Auto frogs                          
ipv4                     |             |                                     
                         | routes      |                                     
                         | addresses   |                                     
                         | dns         |                                     
                         | method      | auto                                
802-11-wireless-security |             |                                     
                         | key-mgmt    | none                                
                         | auth-alg    | open                                
> ./cnetworkmanager --ci system,Auto\ Novell
Section                  | Property        | Value                               
-------------------------+-----------------+-------------------------------------
802-11-wireless-security |                 |                                     
                         | key-mgmt        | wpa-eap                             
connection               |                 |                                     
                         | timestamp       | 1248783939                          
                         | type            | 802-11-wireless                     
                         | uuid            | bdc78490-5f86-4f34-8f51-8c13d270cf80
                         | id              | Auto Novell                         
ipv4                     |                 |                                     
                         | routes          |                                     
                         | addresses       |                                     
                         | dns             |                                     
                         | method          | auto                                
802-1x                   |                 |
                         | eap             | ttls
                         | system-ca-certs | 1
                         | identity        | mvidner
                         | phase2-auth     | mschapv2
802-11-wireless          |                 |
                         | ssid            | Novell
                         | security        | 802-11-wireless-security
                         | mode            | infrastructure
                         | seen-bssids     | 00:1a:1e:a6:f9:c1, 00:1a:1e:a6:f7:61
Comment 1 Martin Vidner 2009-08-18 23:37:31 UTC
Created attachment 36264 [details]
screenshot of the applet menu

The tooltip says Active but the menu does not think so.
Comment 2 Luiz Angelo De Luca 2009-09-15 05:30:13 UTC
I think that an advice in "system connection" checkbox should be a lot more informative that just keep it disabled. Something like:

[ ] System Connection (Still not implemented, use nm-applet)

This would save hours for some who try to find the correct permission to enable the box.

Another very important advice would be in the "not listing system connection". I don't know if, in the future, it would be interesting to let the user ignore the system connections. If so, another disabled checkbox on the main interface like:

[ ] Use System Connection (Still not implemented)

would be very wellcome.

The same goes to DSL tab. It has plenty of space to add a (not implemented) to the tab or the same as the label of a false item inside it.

Please, these are simple changes that makes the difference and can save bug reports.
Comment 3 Will Stephenson 2009-09-27 22:04:44 UTC
*** Bug 207151 has been marked as a duplicate of this bug. ***
Comment 4 Will Stephenson 2009-09-27 22:05:54 UTC
NB the above duplicate relates to the side-effect that NM always prefers system connections.
Comment 5 Tom Chiverton 2009-10-03 20:27:46 UTC
I agree. Either remove the option or relabel it. You can't have it just hanging around with no way to use it. I vote for removing until it works.

A text block would also need to be added explaining that you can't configure system connections here etc. etc.
Comment 6 Tom Chiverton 2010-01-25 18:57:39 UTC
In 4.4 RC2 I see no indication that system connections are hidden. This makes for an odd looking GUI, because I can see my wireless is connected, yet no connections are listed.
Comment 7 omega 2010-03-31 17:12:22 UTC
please fix this bug because it's very important for who use other network like vpn for example.
Comment 8 diaz 2010-08-31 21:14:23 UTC
Is this bug at this time and age not yet fixed or am i missing something? xD
Comment 9 Andrei ILIE 2010-09-16 23:15:17 UTC
I am using KNetworkManager (1:0.9-0.20.20100603.fc13).

It still does not allow system-wide network configuration and that is sad, considering that KNetworkManager should be ___THE___ tool for graphically managing network connections.

The KDE users all over the world, should give up using tools like:
   OpenSUSE's "yast-lan"
   Fedora's "system-config-network"

and focus on KNetworkManager.
Comment 10 guilo19 2010-10-03 17:22:58 UTC
Same here, very stupid bug. Please fix !
Comment 11 Tom Chiverton 2010-10-13 23:18:23 UTC
@Andrei: More than sad, it's terrible from a user perspective that it *lies* by saying there are no connections even though it's connected. As far as I can tell it doesn't even say 'click here to launch the system connection editor that may list additional connections' or similar.
Comment 12 Lamarque V. Souza 2011-03-19 04:20:44 UTC
*** Bug 251512 has been marked as a duplicate of this bug. ***
Comment 13 Lamarque V. Souza 2011-03-28 19:28:36 UTC
*** Bug 228181 has been marked as a duplicate of this bug. ***
Comment 14 Lamarque V. Souza 2011-03-28 19:29:46 UTC
We have a proposed implementation: http://git.reviewboard.kde.org/r/100947/

please try it and report the problems.
Comment 15 Lamarque V. Souza 2011-03-28 19:39:43 UTC
*** Bug 232770 has been marked as a duplicate of this bug. ***
Comment 16 Lamarque V. Souza 2011-03-28 19:49:57 UTC
*** Bug 259148 has been marked as a duplicate of this bug. ***
Comment 17 Lamarque V. Souza 2011-03-28 19:57:41 UTC
*** Bug 249954 has been marked as a duplicate of this bug. ***
Comment 18 Lamarque V. Souza 2011-03-28 20:02:48 UTC
*** Bug 257303 has been marked as a duplicate of this bug. ***
Comment 19 Eugene Shalygin 2011-04-06 16:02:41 UTC
(In reply to comment #14)
> We have a proposed implementation: http://git.reviewboard.kde.org/r/100947/
> 
> please try it and report the problems.

Patch works fine on Gentoo~amd64/KDE 4.6.1. After removing NetworkManager plugin for reading Gentoo-specific network settings (plugin does not write WPA config correctly) reading and writing of system connections works. Thanks a lot for the work!
Comment 20 H.H. 2011-04-10 11:38:28 UTC
Will this fix 

http://git.reviewboard.kde.org/r/100947/

make it into kde-4.6.3? This is really a severe bug!
Comment 21 H.H. 2011-04-10 13:11:29 UTC
I have tested the fix in kde-4.6.2 from here 

http://quickgit.kde.org/?p=clones%2Fnetworkmanagement%2Fborzenkov%2Fnetworkmanagement.git&a=summary

the kcm module works fine, although the plasmoid seems not to work..
Comment 22 Lamarque V. Souza 2011-04-11 01:44:06 UTC
*** Bug 270574 has been marked as a duplicate of this bug. ***
Comment 23 Lamarque V. Souza 2011-04-14 15:14:03 UTC
Git commit 111a9f8711f97b8b66b978fda84ccfe0ad25cfcb by Lamarque V. Souza.
Committed on 14/04/2011 at 15:14.
Pushed by lvsouza into branch 'master'.

Add systemwide connection support for NM 0.8.
There are still some things to fix in this patch, but it easier for me to
fix them if the patch is in the repository, so commiting it.
Many thanks to Gökçen Eraslan and Andrey Borzenkov for working in this
patch.

BUG: 204340
REVIEW: 100947

M  +1    -0    backends/NetworkManager/CMakeLists.txt     
M  +52   -3    backends/NetworkManager/connectiondbus.cpp     
M  +1    -0    backends/NetworkManager/connectiondbus.h     
M  +4    -6    backends/NetworkManager/generateDbusAdapters.sh     
M  +206  -5    backends/NetworkManager/nmdbussettingsconnectionprovider.cpp     
M  +14   -0    backends/NetworkManager/nmdbussettingsconnectionprovider.h     
M  +132  -25   backends/NetworkManager/settings/802-11-wireless-securitydbus.cpp     
M  +1    -0    backends/NetworkManager/settings/802-11-wirelessdbus.cpp     
M  +12   -3    backends/NetworkManager/settings/802-1xdbus.cpp     
M  +8    -6    backends/NetworkManager/settings/gsmdbus.cpp     
M  +45   -5    backends/NetworkManager/settings/ipv4dbus.cpp     
M  +7    -2    backends/NetworkManager/settings/pppoedbus.cpp     
M  +7    -2    libs/client/remoteactivatablelist.cpp     
M  +50   -4    libs/internals/connection.cpp     
M  +11   -1    libs/internals/connection.h     
M  +1    -0    libs/internals/connectionpersistence.cpp     
M  +3    -2    libs/internals/settings/802-11-wireless-security.cpp     
M  +30   -0    libs/internals/settings/802-11-wireless-security.h     
M  +5    -0    libs/internals/settings/802-11-wireless-securitypersistence.cpp     
M  +25   -0    libs/internals/settings/802-11-wireless.h     
M  +1    -1    libs/internals/settings/802-1x.cpp     
M  +26   -0    libs/internals/settings/802-3-ethernet.h     
M  +0    -17   libs/internals/settings/gsm.h     
M  +0    -4    libs/internals/settings/gsmpersistence.cpp     
M  +2    -2    libs/service/connectionlistpersistence.cpp     
M  +3    -3    libs/ui/802_11_wirelesswidget.cpp     
M  +35   -0    libs/ui/cdmaconnectioneditor.cpp     
M  +6    -0    libs/ui/cdmaconnectioneditor.h     
M  +1    -1    libs/ui/connection.ui     
M  +81   -9    libs/ui/connectioneditor.cpp     
M  +17   -2    libs/ui/connectioneditor.h     
M  +15   -2    libs/ui/connectionprefs.cpp     
M  +1    -1    libs/ui/connectionprefs.h     
M  +1    -1    libs/ui/connectionsecretsjob.cpp     
M  +4    -2    libs/ui/connectionwidget.cpp     
M  +18   -34   libs/ui/gsm.ui     
M  +53   -1    libs/ui/gsmconnectioneditor.cpp     
M  +6    -0    libs/ui/gsmconnectioneditor.h     
M  +0    -4    libs/ui/gsmwidget.cpp     
M  +3    -0    libs/ui/networkmanagement_vpnuiplugin.desktop     
M  +29   -3    libs/ui/pppoepreferences.cpp     
M  +9    -0    libs/ui/pppoepreferences.h     
M  +1    -1    libs/ui/security/eapmethodstack.cpp     
M  +1    -1    libs/ui/security/eapmethodstack.h     
M  +1    -1    libs/ui/security/nullsecuritywidget.cpp     
M  +1    -1    libs/ui/security/nullsecuritywidget.h     
M  +1    -1    libs/ui/security/securityeap.cpp     
M  +1    -1    libs/ui/security/securityeap.h     
M  +1    -1    libs/ui/security/securityleap.cpp     
M  +1    -1    libs/ui/security/securityleap.h     
M  +18   -0    libs/ui/security/securitywidget.cpp     
M  +5    -1    libs/ui/security/securitywidget.h     
M  +5    -0    libs/ui/security/securitywidget_p.h     
M  +33   -8    libs/ui/security/wepwidget.cpp     
M  +2    -1    libs/ui/security/wepwidget.h     
M  +28   -6    libs/ui/security/wirelesssecuritysettingwidget.cpp     
M  +14   -2    libs/ui/security/wpapskwidget.cpp     
M  +2    -1    libs/ui/security/wpapskwidget.h     
M  +41   -6    libs/ui/vpnpreferences.cpp     
M  +6    -0    libs/ui/vpnpreferences.h     
M  +30   -4    libs/ui/wiredpreferences.cpp     
M  +9    -0    libs/ui/wiredpreferences.h     
M  +4    -5    libs/ui/wiredwidget.cpp     
M  +70   -0    libs/ui/wirelesspreferences.cpp     
M  +6    -0    libs/ui/wirelesspreferences.h     
M  +1    -1    monolithic/tooltipbuilder.cpp     
M  +3    -1    settings/config/CMakeLists.txt     
M  +385  -60   settings/config/manageconnectionwidget.cpp     
M  +40   -2    settings/config/manageconnectionwidget.h     
M  +25   -0    settings/config/manageconnectionwidget.ui     
M  +1    -1    settings/config/managetraywidget.cpp     
M  +18   -3    settings/config/mobileproviders.cpp     
M  +3    -1    settings/configshell/CMakeLists.txt     
M  +11   -6    settings/configshell/main.cpp     
M  +1    -1    vpnplugins/novellvpn/networkmanagement_novellvpnui.desktop     
M  +1    -1    vpnplugins/openvpn/networkmanagement_openvpnui.desktop     
M  +1    -1    vpnplugins/pptp/networkmanagement_pptpui.desktop     
M  +1    -1    vpnplugins/strongswan/networkmanagement_strongswanui.desktop     
M  +1    -1    vpnplugins/vpnc/networkmanagement_vpncui.desktop     

http://commits.kde.org/networkmanagement/111a9f8711f97b8b66b978fda84ccfe0ad25cfcb
Comment 24 Matěj Laitl 2011-04-14 15:38:00 UTC
It seems that current git master right after the merge (111a9f8711) doesn't build (at least for me):


CMake Error in backends/NetworkManager/CMakeLists.txt:
  Cannot find source file "nm-exported-connection-secrets-interface.cpp".
  Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
  .hxx .in .txx
Comment 25 Lamarque V. Souza 2011-04-14 15:53:18 UTC
Git commit eded33f26836341feb6e3b94ffc6cff05e063451 by Lamarque V. Souza.
Committed on 14/04/2011 at 15:58.
Pushed by lvsouza into branch 'master'.

Adding missing files from commit
111a9f8711f97b8b66b978fda84ccfe0ad25cfcb

CCBUG: 204340

A  +26   -0    backends/NetworkManager/nm-exported-connection-secrets-interface.cpp         [License: GENERATED FILE]  *
A  +50   -0    backends/NetworkManager/nm-exported-connection-secrets-interface.h         [License: GENERATED FILE]  *

The files marked with a * at the end have a non valid license. Please read: http://techbase.kde.org/Policies/Licensing_Policy and use the headers which are listed at that page.


http://commits.kde.org/networkmanagement/eded33f26836341feb6e3b94ffc6cff05e063451
Comment 26 Lamarque V. Souza 2011-07-07 23:16:32 UTC
*** Bug 252664 has been marked as a duplicate of this bug. ***