Bug 257303 - unable to modify/disable 'Auto eth0'
Summary: unable to modify/disable 'Auto eth0'
Status: RESOLVED DUPLICATE of bug 204340
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
: 267322 271561 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-19 09:23 UTC by Uqbar
Modified: 2011-05-31 08:41 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uqbar 2010-11-19 09:23:01 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

1. There's an "Auto eth0" connection but no way to modify or disable it.
2. If you disable the wireless network it will be re-enables with the next session.
3. If you disable the networking completely, it will be re-enabled the next session.

Reproducible: Always

Steps to Reproduce:
Issue 1.
1.1 Left-click on the networking icon to pop the widget up
1.2 Check the "Auto eth0" is shown in the right panel
1.3 Click on "Manage connections"
1.4 Check the "Wired connections" section

Issue 2.
2.1 Left-click on the networking icon to pop the widget up
2.2 Unmark "Enable wireless networks"
2.3 Close the session and re-open one (same user)

Issue 3.
3.1 Left-click on the networking icon to pop the widget up
3.2 Unmark "Enable network"
2.3 Close the session and re-open one (same user)

Actual Results:  
Issue 1: There's no wired connection for "Auto eth0"
Issue 2: The wireless network are enabled
Issue 3: The network is enabled

Expected Results:  
Issue 1: There should be a connection profile for "Auto eth0" in the wired network section.
Issue 2: The wireless network should stay disabled.
Issue 3: The network should stay disabled.
Comment 1 Uqbar 2010-11-19 09:25:31 UTC
For issue no.1 I would advise to eliminate the "Auto eth0" connection.
Comment 2 Uqbar 2011-02-25 10:33:53 UTC
Severity: normal
Priority: normal
Status: unconfirmed

I think this very bug is being underestimated.
This is a major KDE bug: the network connection management is not working as the backend stuff does.

And the GNOME counterpart applet is working flawlessly.
Comment 3 Sebastian Kügler 2011-02-25 13:29:40 UTC
Please file individual bugs for your issues, one bug per issue. In general, lists of bugs in bugreports don't work well. I've put the bugreport in limbo state until it's useful.

As to //1: This comes from NetworkManager, not sure if it's possible at all to edit it, if it is, please file another bugreport for this issue

To be honest, I'm quite puzzled by this bugreport, because of this list. "random collection of things that strike me" doesn't work well if you try to fix issues in an ordered manner.
Comment 4 Rex Dieter 2011-02-28 17:50:24 UTC
In an effort to improve things here, let's refocus this onto issue 1 (and adjusting summary) to match: unable to modify/disable 'Auto eth0'
Comment 5 Rex Dieter 2011-02-28 18:21:25 UTC
*** Bug 267322 has been marked as a duplicate of this bug. ***
Comment 6 Lamarque V. Souza 2011-03-28 20:02:48 UTC
Probably your wired connection is a system connection. NetworkManager usually
creates a system wired connection, but since we have not commited the system
connection implementation you need to wait a bit more until we do it or you can
test it yourself: http://git.reviewboard.kde.org/r/100947/

*** This bug has been marked as a duplicate of bug 204340 ***
Comment 7 Lamarque V. Souza 2011-04-23 20:22:28 UTC
*** Bug 271561 has been marked as a duplicate of this bug. ***