Bug 186936 - kmail hangs fetching emails after being woken up from suspend
Summary: kmail hangs fetching emails after being woken up from suspend
Status: RESOLVED DUPLICATE of bug 74484
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.11.1
Platform: unspecified Linux
: NOR normal with 60 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 132088 172410 193660 194315 195284 196340 208976 209781 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-12 10:27 UTC by Nicholas Allen
Modified: 2010-06-01 22:15 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Allen 2009-03-12 10:27:46 UTC
Version:           1.11.1 (using 4.2.1 (KDE 4.2.1), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.27-11-generic

If I suspend my computer and the wake it up again kmail can no longer check for new emails. I have to quit kmail and then restart it in order for this to work.

The interface is still responsive when this happens - it's just that there is no progress when checking for new emails.
Comment 1 Jaime Torres 2009-06-05 10:46:26 UTC
*** Bug 194315 has been marked as a duplicate of this bug. ***
Comment 2 Jaime Torres 2009-06-05 10:46:38 UTC
*** Bug 195284 has been marked as a duplicate of this bug. ***
Comment 3 Jaime Torres 2009-06-05 10:48:25 UTC
Just to see if this kmail specific or a kde libs problem.
Have you noticed similiar problems whith other KDE applications?
Comment 4 Craig Magina 2009-06-05 15:35:45 UTC
I have not noticed this with any other application.  Kopete reconnects just fine, as an example.
Comment 5 andrew 2009-06-06 12:11:40 UTC
I have not encountered the problem with akregator.  But I'm also not seeing the problem right now either.  What has changed?  Well I've started using konqeror for web browsing.  (Previously I used firefox exclusively.)  So maybe there is some interplay.
Comment 6 andrew 2009-06-08 05:32:50 UTC
More info:  kmail reported to me that the process managing the imap connection terminated unexpectedly.  This is the heart of the problem.  Had to restart kmail to regain mail access.  Is it possible for this process to simply be restarted after an unexpected crash?  It doesn't crash the mail program after all.
Comment 7 andrew 2009-06-08 13:29:00 UTC
That message (just happened again):

Unexpected Program Termination
The program on your computer which provides access to the imaps://imap.gmail.com protocol has unexpectedly terminated.

I guess that rules out the notion of interplay with konq
Comment 8 Ivan Andrianov 2009-06-16 14:31:40 UTC
*** Bug 196340 has been marked as a duplicate of this bug. ***
Comment 9 Nico Schlömer 2009-06-22 14:21:33 UTC
*** Bug 193660 has been marked as a duplicate of this bug. ***
Comment 10 andrew 2009-08-07 15:00:16 UTC
It looks to me like this bug is a duplicate of 172410... which also has 40 votes.
Comment 11 Christophe Marin 2009-10-07 18:16:10 UTC
*** Bug 208976 has been marked as a duplicate of this bug. ***
Comment 12 Christophe Marin 2009-10-07 18:16:22 UTC
*** Bug 209781 has been marked as a duplicate of this bug. ***
Comment 13 Raúl 2009-10-21 10:53:24 UTC
I think andrew (#10) is right. I'm attacching information there.
Comment 14 Marcel Schaal 2009-11-03 20:26:07 UTC
*** This bug has been confirmed by popular vote. ***
Comment 15 Christophe Marin 2009-11-14 22:08:56 UTC
*** Bug 172410 has been marked as a duplicate of this bug. ***
Comment 16 Christophe Marin 2009-11-14 22:09:58 UTC
*** Bug 132088 has been marked as a duplicate of this bug. ***
Comment 17 Igor Alexandrov 2009-12-03 09:52:39 UTC
Still exists in KDE 4.3.4.
Comment 18 Werner Meyer 2009-12-09 23:35:00 UTC
I have this problem already years with different kmail-versions (always running under gnome and with IMAP).
After the internet-connection was closed or the computer slept (standby) kmail is not able to look for new e-mails. Only after a popup-message (something like: „unexpectedly internet-connection was broken“) appeared (I always have to wait for that message, or - if it does'nt come - have to restart kmail) and I clicked OK, it works again.
Comment 19 Anze 2010-01-12 20:10:42 UTC
I confirm that. I had this problem under KDE 4.3.* and it's still very much there in 4.4 rc.
It says "The connection to account timed out". Simply restarting kmail has no effect, I have to kill it's kio_file and kmail processes under System Activity for it to start working again.
Comment 20 Mr 337 2010-04-07 22:25:34 UTC
I can confirm this in KDE 4.4.1, KMail 1.13.1 - hangs after suspend

Have to restart KMail after every suspend.
Comment 21 Thomas McGuire 2010-06-01 22:15:20 UTC

*** This bug has been marked as a duplicate of bug 74484 ***