Bug 181437 - Detailed view: for better clarity, rolling over an element should highlight the whole line, not just the name of the element
Summary: Detailed view: for better clarity, rolling over an element should highlight t...
Status: CLOSED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: details mode (show other bugs)
Version: 21.08.0
Platform: Compiled Sources Unspecified
: NOR wishlist with 186 votes (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 419435 421315 428274 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-20 23:26 UTC by mathesis
Modified: 2022-05-13 12:51 UTC (History)
22 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mathesis 2009-01-20 23:26:08 UTC
Version:            (using Devel)
Installed from:    Compiled sources

For users who prefer using the detailed view and for better clarity, dolphin should highlight the whole line (i.e. all columns) rather than the name of the element over which the mouse is.

Notes:
- for the time being, to highlight an element you have to roll over the name of the element itself, being in the column 'name' (i.e. after the extension of the name but in the column "name") is not sufficient.
- I think this should be also applicable once an element is selected.
Comment 1 Dario Andres 2009-01-21 01:07:27 UTC
Well.. there was some bug report some time ago asking for the inclusion of the behaviour you are reporting (kde3-like selecting where only the name is selected/hovered instead the whole "Name" column)... Not really sure if the behaviour can be reverted or if Peter can make it optional...
Comment 2 mathesis 2009-01-21 20:41:22 UTC
I think I was not clear:
- I would be happy that the whole "Name" column is highlighted rather than just the name.
- but my report is more for all the columns to be highlighted in order to easy reading of permissions, owner, modification date etc. for one particular element.
I find the white & grey lines not sufficient.
Comment 3 Dotan Cohen 2009-05-30 12:15:31 UTC
> I would be happy that the whole "Name" column is
> highlighted rather than just the name.

I think that you mean that you would like the whole row highlighted, not just the cell in the Name column. Could you please clarify that is what you meant? In other words, you want Name, Size, and Date to be highlighted, along with anything else on the row.

By the way, if this is the behaviour that the OP is asking for, then I completely agree.
Comment 4 mathesis 2009-05-31 23:50:03 UTC
Basically yes, this is what I ask for.
I had only one remark on the current behaviour where to highlight the name, you don't just need to be in the "Name" column but really over the text itself / Name of the file itsefl. Not practical.
Comment 5 geoff 2010-08-22 04:10:07 UTC
I support this request. A fully highlighted row makes it easier to relate the other file's attributes to the name. Like the OP, I do not find the white/light grey highlighting to be enough.

If some people do not like the effect, then please let's have it configurable by the user.
Comment 6 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:22:28 UTC
Resetting assignee to default as per bug #305719
Comment 8 Hamidreza Jafari 2018-12-27 15:46:46 UTC
(In reply to mathesis from comment #4)
> Basically yes, this is what I ask for.
> I had only one remark on the current behaviour where to highlight the name,
> you don't just need to be in the "Name" column but really over the text
> itself / Name of the file itsefl. Not practical.

mathesis did not make clear what he intended. What I want, support and think is reasonable is that the complete row for an item that has the focus be highlighted / differentiated.
Comment 9 mathesis 2019-01-03 14:46:00 UTC
Hello,

What I suggested is that the focus be given to an item when the mouse is over any of the column field of the item and anywhere in the columns (as of today you have to be over the filename even if the width of the column is wide enough to have a blank space after the filename; and when the focus is given to an element the full row is highlighted.

Hope this is clearer.
Comment 10 Hamidreza Jafari 2019-01-06 16:02:23 UTC
Simply it is best to highlight the complete row as soon as the mouse pointer passes over it regardless of which column (field) the mouse pointer is traveling in. This is required for user friendly inspection of the details of an item. Actually this is the standard behavior expected from a list element containing multiple fields.
Comment 11 Erik Quaeghebeur 2020-02-14 14:20:19 UTC
Ark does it this way. Perhaps a look at its source code can help make implementing cost less time.
Comment 12 postix 2020-05-02 09:35:54 UTC
Once the whole line will be selected / highlighted, it should be possible (by option?) to select a file also by a single left click somewhere in the row. 

Clicking again in the same row would deselect it.

Currently you can already do that by drawing a selection rectangle in the single row, where the item is, which you'd like to select. However, this is not very convenient for a single item.
Comment 13 Nate Graham 2020-05-12 16:26:49 UTC
*** Bug 421315 has been marked as a duplicate of this bug. ***
Comment 14 Nate Graham 2020-05-19 17:42:54 UTC
*** Bug 419435 has been marked as a duplicate of this bug. ***
Comment 15 Nate Graham 2020-05-19 17:44:24 UTC
One concern is that this could make multi-selection using a box/rubber band selection more difficult. Indeed, the file dialog--which uses kdiroperator, which implements this behavior--doesn't even support that feature at all. Nonetheless, the other file managers you mentioned seem to have solved this problem in a fairly elegant way:
- click-and-drag upwards in an empty area = drag a selection box
- click-and-drag sideways in an empty area = drag-and-drop
- click-and-drag in any direction on an item's icon or label = drag-and-drop

I think it would make sense if Dolphin implemented this too (and then the file dialog, for that matter).
Comment 16 Andres Betts 2020-06-02 03:03:49 UTC
I support the overall idea of this bug report.
Comment 17 Roman 2020-08-02 21:53:16 UTC
Im also really want to have at least an option for this behaviour, this is the only thing that keeps me from daily use of Dolphin.
Comment 18 Christoph Feck 2020-10-26 18:31:08 UTC
*** Bug 428274 has been marked as a duplicate of this bug. ***
Comment 19 Felix Ernst 2022-01-16 14:45:09 UTC
Git commit d3839617193e92463806580699caa595c892b8a6 by Felix Ernst, on behalf of Tom Lin.
Committed on 16/01/2022 at 14:01.
Pushed by felixernst into branch 'master'.

Full row highlight implementation

This commit implements full-row selection and hover highlights for the
details view mode.

This commit also contains fixes for 444680, 444753, both uncovered
during this change.
Related: bug 444680, bug 444753
FIXED-IN: 22.04

M  +143  -36   src/kitemviews/kitemlistcontroller.cpp
M  +16   -0    src/kitemviews/kitemlistheader.cpp
M  +9    -0    src/kitemviews/kitemlistheader.h
M  +51   -5    src/kitemviews/kitemlistview.cpp
M  +11   -0    src/kitemviews/kitemlistview.h
M  +32   -0    src/kitemviews/kitemlistwidget.cpp
M  +10   -1    src/kitemviews/kitemlistwidget.h
M  +4    -0    src/kitemviews/kstandarditemlistview.cpp
M  +42   -10   src/kitemviews/kstandarditemlistwidget.cpp
M  +6    -0    src/kitemviews/kstandarditemlistwidget.h
M  +92   -34   src/kitemviews/private/kitemlistheaderwidget.cpp
M  +15   -0    src/kitemviews/private/kitemlistheaderwidget.h
M  +4    -0    src/settings/dolphin_detailsmodesettings.kcfg
M  +1    -0    src/views/dolphinitemlistview.cpp
M  +17   -0    src/views/dolphinview.cpp
M  +1    -0    src/views/dolphinview.h

https://invent.kde.org/system/dolphin/commit/d3839617193e92463806580699caa595c892b8a6
Comment 20 Andrew Udvare 2022-04-25 03:15:02 UTC
I like and dislike this change. Can we get an option for this? 'Highlight entire row' in View Modes -> Details?
Comment 21 ConteZero 2022-04-26 07:26:27 UTC
I really hate this change, I hope this behavior becomes optional.
As it is now it is too easy to open a file unintentionally by clicking somewhere to the right of the file name.
Comment 22 postix 2022-04-26 08:37:48 UTC
(In reply to Andrew Udvare from comment #20)
> I like and dislike this change. Can we get an option for this? 'Highlight entire row' in View Modes -> Details?

(In reply to ConteZero from comment #21)
> I really hate this change, I hope this behavior becomes optional.
> As it is now it is too easy to open a file unintentionally by clicking somewhere to the right of the file name.

I guess, you both use "single click" and therefore prefer the previous "highlight only the file name" solution?
Comment 23 ConteZero 2022-04-26 09:32:27 UTC
(In reply to postix from comment #22)
> I guess, you both use "single click" and therefore prefer the previous
> "highlight only the file name" solution?

Yes, I use "single click"
Comment 24 postix 2022-05-07 12:39:07 UTC
(In reply to ConteZero from comment #21)
> I really hate this change, I hope this behavior becomes optional.
> As it is now it is too easy to open a file unintentionally by clicking somewhere to the right of the file name.

(In reply to ConteZero from comment #23)
> Yes, I use "single click"

I'd recommend to you to open a separate usability bug report for it. :)
Comment 25 pier andre 2022-05-13 11:22:45 UTC
(In reply to ConteZero from comment #21)
> I really hate this change, I hope this behavior becomes optional.
> As it is now it is too easy to open a file unintentionally by clicking
> somewhere to the right of the file name.

also me use single click and also agree with ConteZero, I tried but is very annoying behaviour, I also prefere to have an option to activate this behaviour, also the right click when a line is activated result annoying to deselect or click elsewhere to have menu for folder actions like open a terminal here instead a file menu like happen now, it was very better before behaviour
Comment 26 pier andre 2022-05-13 11:43:43 UTC
(In reply to Roman from comment #17)
> Im also really want to have at least an option for this behaviour, this is
> the only thing that keeps me from daily use of Dolphin.

me also really would like to have at least an option for this behaviour as the traditional KDE approach claim to be a very configurable destop environment, as like was done in the case of rename in line
Comment 27 ConteZero 2022-05-13 11:45:58 UTC
(In reply to pier andre from comment #25)
> (In reply to ConteZero from comment #21)
> > I really hate this change, I hope this behavior becomes optional.
> > As it is now it is too easy to open a file unintentionally by clicking
> > somewhere to the right of the file name.
> 
> also me use single click and also agree with ConteZero, I tried but is very
> annoying behaviour, I also prefere to have an option to activate this
> behaviour, also the right click when a line is activated result annoying to
> deselect or click elsewhere to have menu for folder actions like open a
> terminal here instead a file menu like happen now, it was very better before
> behaviour

In bug
https://bugs.kde.org/show_bug.cgi?id=453528
I expressed my opinion on how to try to improve this "feature" by making it more usable for those who use the single click mode, but the bug was closed and I was told that I just have to get used to it.
Comment 28 Nate Graham 2022-05-13 12:51:13 UTC
Please don't re-open closed bugs. If you don't like this change, file a new bug report about it. It will probably be marked as a duplicate of Bug 453700, but we track the feedback on big features like this and may make changes if we get consistent feedback one way or another.