Bug 170775 - webcam constantly stays on when being in the configuration menu
Summary: webcam constantly stays on when being in the configuration menu
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: Audio/Video Plugin (show other bugs)
Version: 0.60.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 181020 230713 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-10 01:22 UTC by Adrien Kwok
Modified: 2013-06-12 00:43 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrien Kwok 2008-09-10 01:22:53 UTC
Version:           0.60.1 (using 4.1.2 (KDE 4.1.1 (KDE 4.1 >= 20080828)) "release 32.2", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.25.11-0.1-default

The problem here is that whenever I launch the configuration box, the webcam is turned on. Once I quit the configuration box, the webcam still stays turned on and could not be turned off. This is a major issue as I just want to change the software setting and do not want to use the webcam.

It's very annoying. I have a Logitech QuickCam Chat with the GSPCA driver that came with openSUSE 11.

Thanks.
Comment 1 Jesse Litton 2009-02-02 00:47:04 UTC
Does the same thing happen in 0.70.0?  If it does, it's likely a GSPCA issue, as I do not have this issue with that version and my QuickCam Pro 9000.
Comment 2 Pino Toscano 2009-03-26 18:18:04 UTC
*** Bug 181020 has been marked as a duplicate of this bug. ***
Comment 3 Frank Schaefer 2010-03-14 16:11:07 UTC
*** Bug 230713 has been marked as a duplicate of this bug. ***
Comment 4 Frank Schaefer 2010-04-02 12:49:12 UTC
*** Bug 233044 has been marked as a duplicate of this bug. ***
Comment 5 Frank Schaefer 2010-05-25 17:32:26 UTC
*** Bug 238728 has been marked as a duplicate of this bug. ***
Comment 6 Pali Rohár 2013-06-12 00:43:32 UTC
Git commit 8e6d6364ed8987416d4cba457ca6fee91b168aac by Pali Rohár.
Committed on 12/06/2013 at 02:39.
Pushed by pali into branch 'master'.

Activate webcam preview in settings dialog only if webcam tab is selected
Related: bug 233044, bug 238728
FIXED-IN: 4.11

M  +81   -23   kopete/config/avdevice/avdeviceconfig.cpp
M  +5    -0    kopete/config/avdevice/avdeviceconfig.h

http://commits.kde.org/kopete/8e6d6364ed8987416d4cba457ca6fee91b168aac