Bug 233044 - configuration dialog turns on webcam
Summary: configuration dialog turns on webcam
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: Audio/Video Plugin (show other bugs)
Version: 1.0.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-02 09:39 UTC by Harald Sitter
Modified: 2013-06-12 00:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Sitter 2010-04-02 09:39:47 UTC
Version:            (using KDE 4.4.2)
OS:                Linux
Installed from:    Ubuntu Packages

My dell mini 10v got a builtin webcam. This webcam always gets turned on when entering the kopete configuration dialog.

Granted, this is not important, but say you want to tweak your kopete settings to perfection while being on battery, the constant switching of the webcam could become a problem.

Also it is kind of annoying to be lid in the face in the dark (there is status light next to the cam) ;)

IMHO the webcam should only be activated once the user switches to the appropriate configuration part.
Thanks for taking this into consideration :)
Comment 1 Frank Schaefer 2010-04-02 12:49:12 UTC

*** This bug has been marked as a duplicate of bug 170775 ***
Comment 2 Pali Rohár 2013-06-12 00:43:32 UTC
Git commit 8e6d6364ed8987416d4cba457ca6fee91b168aac by Pali Rohár.
Committed on 12/06/2013 at 02:39.
Pushed by pali into branch 'master'.

Activate webcam preview in settings dialog only if webcam tab is selected
Related: bug 170775, bug 238728
FIXED-IN: 4.11

M  +81   -23   kopete/config/avdevice/avdeviceconfig.cpp
M  +5    -0    kopete/config/avdevice/avdeviceconfig.h

http://commits.kde.org/kopete/8e6d6364ed8987416d4cba457ca6fee91b168aac