Bug 238728 - entering kopete settings instantly activates webcam
Summary: entering kopete settings instantly activates webcam
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: Audio/Video Plugin (show other bugs)
Version: 1.0.0
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-24 20:54 UTC by m.wege
Modified: 2013-06-12 00:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2010-05-24 20:54:59 UTC
Version:           0.3 (using KDE 4.4.3) 
OS:                Linux

When I enter kopete settings the webcam is instantly activated. I do not think that is necessary. It would be besser if the video would only be activated when entering that plugin or even only when choosing "Configure/Test webcam" 

Reproducible: Always




OS: Linux (i686) release 2.6.32-22-generic-pae
Compiler: cc
Comment 1 Frank Schaefer 2010-05-25 17:32:26 UTC

*** This bug has been marked as a duplicate of bug 170775 ***
Comment 2 Pali Rohár 2013-06-12 00:43:32 UTC
Git commit 8e6d6364ed8987416d4cba457ca6fee91b168aac by Pali Rohár.
Committed on 12/06/2013 at 02:39.
Pushed by pali into branch 'master'.

Activate webcam preview in settings dialog only if webcam tab is selected
Related: bug 170775, bug 233044
FIXED-IN: 4.11

M  +81   -23   kopete/config/avdevice/avdeviceconfig.cpp
M  +5    -0    kopete/config/avdevice/avdeviceconfig.h

http://commits.kde.org/kopete/8e6d6364ed8987416d4cba457ca6fee91b168aac