Bug 167428 - Shortcuts with accented keys does not work properly
Summary: Shortcuts with accented keys does not work properly
Status: RESOLVED DUPLICATE of bug 375518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_keys (show other bugs)
Version: 4.10.0
Platform: Ubuntu Packages Linux
: NOR normal with 141 votes (vote)
Target Milestone: ---
Assignee: Michael Jansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-25 14:57 UTC by Damien Gombault
Modified: 2021-03-26 16:07 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damien Gombault 2008-07-25 14:57:30 UTC
Version:            (using KDE 4.0.98)
Installed from:    Ubuntu Packages
OS:                Linux

I use an AZERTY keyboard and I use Alt+&, Alt+é, Alt+", etc. to switch desktops.
On a QWERTY keyboard, it corresponds to Alt+1, Alt+2, Alt+3, etc.

Alt+& works, Alt+", and the other combinations work too except Alt+é.
When I configure the shortcut, I see Alt+É.

The shortcut will work only if I press the capslock key before.

I tried other accented keys like è, ç, à and ù : same problem.
Comment 1 Damien Gombault 2008-09-07 12:18:31 UTC
I confirm this with KDE 4.1.1 and Gentoo.
Comment 2 Jean Delvare 2008-09-24 16:05:07 UTC
Same problem here with KDE 4.1.1 on openSuse 11.0.
Comment 3 Jean Delvare 2008-09-24 16:15:46 UTC
I tried manually editing ~/.kde4/share/config/kglobalshortcutsrc, replacing Alt+É with Alt+é or Alt+2, but it didn't help.
Comment 4 Michael Jansen 2009-02-04 23:35:34 UTC
Could you please retry with kde 4.2? I did some bigger changes that might impact your experiences.

- we now tell if some key is unsupported
- we fixed using shift as a modifier for some keys.

Thx.
Comment 5 Damien Gombault 2009-07-22 20:09:44 UTC
I retried with KDE 4.3 RC3 and this is currently not fixed.

All shortcuts with accented characters does not work (é, à, ç, ...).

If I define a shortcut Alt+é, the configuration window shows `Alt+É` but the shortcut does not work. Same problem with other accented chars.

If I define a shortcut Alt+Shift+é, it shows `Alt+2` (on an AZERTY keyboard shift+é is 2) and the shortcut does not work. Same problem with other accented chars.

If I define a shortcut Alt+&, the configuration window shows `Alt+&` and the shortcut _works_.

If I define a shortcut Alt+Shift+&, it shows `Alt+1` (on an AZERTY keyboard shift+& is 1) and the shortcut does not work.
Comment 6 Christoph Feck 2009-12-02 09:30:50 UTC
*** Bug 182434 has been marked as a duplicate of this bug. ***
Comment 7 Seblu 2009-12-02 10:46:02 UTC
Same issue with kde 4.3.4 on gentoo and kde 4.3.3 on debian.

Can you please take a look about this issue :)
Comment 8 Jean Delvare 2010-03-01 11:17:37 UTC
I just tested again with KDE 4.3.5 (SLED 11 SP1) and the problem is still present. Can KDE developers please take a look? As far as I am concerned, this is a blocker to KDE 4 migration. I simply can't live without my usual keyboard shortcuts.

At least the bug status should be updated. With several people reporting this bug, the "unconfirmed" state doesn't seem appropriate.
Comment 9 bigben99 2010-08-20 11:21:29 UTC
Confirmed with KDE 4.4.2 on Ubuntu 10.04 Lucid (https://bugs.launchpad.net/bugs/387915)
Comment 10 Andreas Hartmetz 2010-09-17 21:34:19 UTC
*** Bug 177321 has been marked as a duplicate of this bug. ***
Comment 11 Andreas Hartmetz 2010-09-17 21:36:25 UTC
*** Bug 176514 has been marked as a duplicate of this bug. ***
Comment 12 Seblu 2010-11-11 19:05:55 UTC
Same bug on KDE 4.5.3 :'(
Comment 13 Damien Gombault 2011-08-01 14:09:51 UTC
I also have this problem with KDE 4.7.0.

This bug has been reported many times with many comments.
I think the status of this bug should be change to NEW.
Comment 14 Vincent Barrielle 2011-12-22 10:20:35 UTC
*** This bug has been confirmed by popular vote. ***
Comment 15 Damien Gombault 2012-02-02 11:49:38 UTC
This bug is still present with KDE 4.8.0.
Comment 16 Damien Gombault 2012-08-02 08:04:54 UTC
This bug is still present with KDE 4.9.0.

Tested with Arch Linux packages.
Comment 17 Matthieu Bouron 2012-09-10 06:12:03 UTC
Bug still present in KDE 4.9.0.
Comment 18 Damien Gombault 2013-02-07 08:40:05 UTC
This bug is still present in KDE 4.10.0 (Arch Linux).
Comment 19 Anne-Marie Mahfouf 2013-05-11 08:40:08 UTC

*** This bug has been marked as a duplicate of bug 252594 ***
Comment 20 Nate Graham 2021-03-26 16:07:59 UTC

*** This bug has been marked as a duplicate of bug 375518 ***